You are not logged in.

#1 2010-11-04 10:11:04

ricemark20
Member
From: Woodstock, IL
Registered: 2010-11-03
Posts: 14

Sansa Fuze not being recognized

I stopped seeing my Fuze in thunar. 
The output of lsusb is:

Bus 004 Device 028: ID 0781:74c3 SanDisk Corp.

So I know it's there, but I can't get past this output of dmesg:

usb 1-6: new high speed USB device using ehci_hcd and address 55
usb 1-6: device not accepting address 55, error -71
hub 1-0:1.0: unable to enumerate USB device on port 6
usb 4-2: new full speed USB device using uhci_hcd and address 29
usb 4-2: device descriptor read/all, error -84
usb 4-2: new full speed USB device using uhci_hcd and address 30
usb 4-2: device descriptor read/all, error -84
usb 4-2: new full speed USB device using uhci_hcd and address 31
usb 4-2: device descriptor read/all, error -84
usb 4-2: new full speed USB device using uhci_hcd and address 32
usb 4-2: not running at top speed; connect to a high speed hub
usb 4-2: unable to read config index 0 descriptor/all
usb 4-2: can't read configurations, error -71
hub 4-0:1.0: unable to enumerate USB device on port 2
usb 4-2: new full speed USB device using uhci_hcd and address 33
usb 4-2: not running at top speed; connect to a high speed hub
usb 4-2: unable to read config index 0 descriptor/start: -84
usb 4-2: chopping to 0 config(s)
usb 4-2: string descriptor 0 read error: -84
usb 4-2: no configuration chosen from 0 choices

Last edited by ricemark20 (2010-11-04 10:14:20)

Offline

#2 2010-11-04 16:41:18

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,213
Website

Re: Sansa Fuze not being recognized

Are you sure it is in 'mass storage'-mode? IIRC I had a Sansa MP3-player and I could only see it show up after holding down a button for more than 5 seconds and then connecting it to my pc.

Offline

#3 2010-11-04 16:57:53

Snowknight
Member
Registered: 2009-06-11
Posts: 55
Website

Re: Sansa Fuze not being recognized

If you use Sandisk's firmware, yes, make sure the USB mode is set to MSC. The "auto" option didn't work for me. Though I use nautilus, my Fuze seemed to use MTP until I forced MSC.

Offline

#4 2010-11-10 10:52:02

ricemark20
Member
From: Woodstock, IL
Registered: 2010-11-03
Posts: 14

Re: Sansa Fuze not being recognized

zenlord wrote:

Are you sure it is in 'mass storage'-mode? IIRC I had a Sansa MP3-player and I could only see it show up after holding down a button for more than 5 seconds and then connecting it to my pc.

I have it in msc mode.

Bus 004 Device 022: ID 0781:74c3 SanDisk Corp. Sansa Fuze V2 (msc)

Is there a way I can use the ID 0781:74c3 to mount the device?

Offline

#5 2010-11-10 12:23:40

keenerd
Trusted User (TU)
Registered: 2007-02-22
Posts: 647
Website

Re: Sansa Fuze not being recognized

The Sansa Fuze does not have partitions.  Mine just worked when I mounted /dev/sdb.  (No partition number!)

Offline

Board footer

Powered by FluxBB