You are not logged in.

#1 2011-02-02 18:21:43

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 229

[solved] Unable to login using KDM since 4.6

Since the big update to 4.6 I'm unable to login with KDM: login data is accepted, screen gets dark, but then instead of an upcoming session I get back to KDM login. I know there are various topics around, but they all describe a setup for KDE, which is not the case for me.

I'm using KDM only for login and then start an awesome3 session. I've tried a new account but this didn't change anything.

kdm.log:

X.Org X Server 1.9.3.901 (1.9.4 RC 1)
Release Date: 2011-01-07
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.36-ARCH x86_64 
Current Operating System: Linux thor 2.6.37-ARCH #1 SMP PREEMPT Sat Jan 29 20:00:33 CET 2011 x86_64
Kernel command line: cryptdevice=/dev/disk/by-uuid/b279588a-0ddc-4447-8844-2053caa492db:root root=/dev/mapper/root resume=/dev/disk/by-uuid/0ffde2a1-8408-4b83-b82d-565e7f9f38fc quiet ro
Build Date: 08 January 2011  11:24:47PM
 
Current version of pixman: 0.20.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb  2 18:56:20 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
(EE) Logitech Logitech Illuminated Keyboard: failed to initialize for relative axes.
QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'
klauncher(2477) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(2471)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"

I double-checked dbus, which is definitely running. Loggin in via vt1 and then starting Xorg via startx works fine.

Edit:
- yes, I have integrated all new config files (.pacnew) for shadow
- yes, I have tried reinstalling kdm
- yes, I have uninstalled hal and added dbus to the DAEMONS
    smile

Last edited by lynix (2011-02-06 09:59:19)

Offline

#2 2011-02-02 18:50:19

FSM
Member
Registered: 2008-04-14
Posts: 33

Re: [solved] Unable to login using KDM since 4.6

Can you start any other window managers via KDM (like twm, openbox)?

Offline

#3 2011-02-02 18:57:33

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,148

Re: [solved] Unable to login using KDM since 4.6

can you post your ~/.xinitrc?


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#4 2011-02-02 19:10:47

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 229

Re: [solved] Unable to login using KDM since 4.6

FSM wrote:

Can you start any other window managers via KDM (like twm, openbox)?

No, I can't. Tried twm and KDE.

Inxsible wrote:

can you post your ~/.xinitrc?

I did not have one until KDM stopped working. As workaround I use this:

#!/bin/sh

exec awesome &>$HOME/.xsession-errors

Offline

#5 2011-02-02 19:18:16

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,148

Re: [solved] Unable to login using KDM since 4.6

kdm, I believe needs consolekit. Have you tried one of the following options (According to the wiki)

exec ck-launch-session dbus-launch awesome $>$HOME/.xsession-errors

OR

exec ck-launch-session awesome $>$HOME/.xsession-errors

Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#6 2011-02-02 19:24:24

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 229

Re: [solved] Unable to login using KDM since 4.6

Why should I have an .xinitrc when using a login manager?

I think any existing .xinitrc gets only used when starting X manually with startx - please correct me if I'm wrong smile

Offline

#7 2011-02-04 21:16:58

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 229

Re: [solved] Unable to login using KDM since 4.6

Okay, some progress: reinstalled dbus and now I'm able to login using kdm and a new user account.

I'm now trying to figure out what makes the new user different. Assuming it is some config file, I already renamed some directories to exclude them, but no success yet.

Any ideas what could cause the problrm? Here's a list of my current dot-folders:

.bash_history
.bash_profile
.bashrc
.bzr.log
.cache
.ccache
.cddb
.config
.conkyrc
.cups
.dbus
.directory
.dmrc
.eclipse
.fontconfig
.fonts.conf
.fprint
.gconf
.gconfd
.gimp-2.6
.gitconfig
.gnome2
.gnupg
.googleearth
.gstreamer-0.10
.gtk-bookmarks
.gtk-custom-papers
.gtkrc-2.0
.htoprc
.icedteaplugin
.icons
.java
.jd
.lesshst
.local
.macromedia
.mednafen
.mkvtoolnix
.mozilla
.mplayer
.netx
.nv
.Osmos
.pki
.pulse-cookie
.purple
.ramdisks
.recently-used
.recently-used.xbel
.sane
.shoijfg.swp
.sqlite_history
.ssh
.subversion
.thumbnails
.thunderbird
.TrueCrypt
.unison
.vim
.viminfo
.vimrc
.VirtualBox
.wallpaper
.WorldOfGoo
.Xauthority
.xine
.xinitrc
.xsession-errors

Offline

#8 2011-02-04 21:32:25

Loose_Control
Member
From: Germany
Registered: 2011-01-11
Posts: 136

Re: [solved] Unable to login using KDM since 4.6

i had the same problem some time ago...
deleting /var/tmp/kdecache-username could help

Offline

#9 2011-02-04 21:41:18

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 229

Re: [solved] Unable to login using KDM since 4.6

Loose_Control wrote:

i had the same problem some time ago...
deleting /var/tmp/kdecache-username could help

Thanks for the tip, but /var/tmp is a ramdisk on my system, so I already cleared it on every boot smile

I also renamed ~/.kderc and ~/.kde4, but no effect.

Offline

#10 2011-02-06 09:59:03

lynix
Member
From: Karlsruhe, Germany
Registered: 2008-04-23
Posts: 229

Re: [solved] Unable to login using KDM since 4.6

Mea culpa smile

The day I upgraded to 4.6, I copied over the .bashrc from a server setup, which contains the following line:

tty -s || exit

Another case of the bug sitting in front of the screen... wink

Offline

Board footer

Powered by FluxBB