You are not logged in.

#1 2011-02-08 09:05:49

eduedix
Member
Registered: 2011-02-08
Posts: 35

catalyst 2.6.37 lag

Hi,
I installed archlinux on my game pc. But there is a problem with the graphics. I got hd4770, so i installed catalyst-hook driver. Well fglrx is in lsmod, so drivers are loaded already.

When i try to run enemy-territory, well in menus there is no problem at all. But in the match there is a biig lag independent of the server i am playing on. this is the same with americas-army armyops game.

I do not know what logs you need, so please let me know whatever you want. Waiting for your help.

Have a nice day,
eduedix

Offline

#2 2011-02-08 09:08:23

eduedix
Member
Registered: 2011-02-08
Posts: 35

Re: catalyst 2.6.37 lag

By the way, i had no problem in my Ubuntu system, although i think it has a different kernel but the same gfx driver.

Offline

#3 2011-02-08 09:54:28

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: catalyst 2.6.37 lag

Have you tried disabling vsync in amdcccle?


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#4 2011-02-08 09:59:05

eduedix
Member
Registered: 2011-02-08
Posts: 35

Re: catalyst 2.6.37 lag

When i try to run it :


erdem ~ $ amdcccle
Parse error on line 2 of section ServerLayout in file /etc/X11/xorg.conf
    "Identifier" is not a valid keyword in this section.
Parse error on line 2 of section ServerLayout in file /etc/X11/xorg.conf
    "Identifier" is not a valid keyword in this section.
Segfault error

Offline

#5 2011-02-10 21:12:44

eduedix
Member
Registered: 2011-02-08
Posts: 35

Re: catalyst 2.6.37 lag

Somehow got amdcccle working, took the vsync option to "quality" which is 0 vsync. but there is still no difference.

Offline

#6 2011-02-11 06:05:28

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: catalyst 2.6.37 lag

Hm... your xorg.conf seems to be strange.

I personally would exit X, delete the complete /etc/ati (delete it in X and the current config gets rewritten when exiting X), reinstall catalyst, delete the xorg.conf and create a new one with aticonfig --initial.
New versions of catalyst often have problems with old configs...


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#7 2011-02-11 10:27:10

eduedix
Member
Registered: 2011-02-08
Posts: 35

Re: catalyst 2.6.37 lag

tried what you told me, but it is still the same. i also think something is wrong with xorg.conf but it really is what aticonfig --initial creates.

here is my xorg.conf:
http://pastebin.com/GyNQQF8Y

vsync is also disabled in the games.

Offline

#8 2011-02-11 14:49:52

popux
Member
Registered: 2010-05-02
Posts: 1

Re: catalyst 2.6.37 lag

I also have issues with catalyst 11.1 with 2.6.37 kernel, x86_64
I have an AGP 3850

When I move a window, xorg uses 100% cpu, it runs better with compiz...
OpenGL apps like games still works with just a little loss of performance.

So, before there is a solution, I reverted to catalyst 10.12 & kernel 2.6.36, and it runs like before, everything is fluid

edit : in fact no, watching a movie in vlc is horrible, it takes a minute before ctrl-q respond...
:-(

Last edited by popux (2011-02-11 18:51:52)

Offline

#9 2011-02-20 18:24:48

devadittya
Member
From: Bangalore
Registered: 2009-11-16
Posts: 127
Website

Re: catalyst 2.6.37 lag

And this is where my problem was. I was switching from KWin to compiz, enabling/disabling every check box, and here's the solution.
Went to a 2.6.36, and 10.12, and CPU is finally normal!

Offline

#10 2011-02-22 20:45:36

SeanM
Member
Registered: 2011-02-07
Posts: 25

Re: catalyst 2.6.37 lag

So... If I'm following this correctly, the people thus far who have noticed a performance problem with  fglrx  have resolved it by moving away from the new .37 kernel?

Does anyone have any idea what specific patch in .37 might be causing this behaviour?

Offline

Board footer

Powered by FluxBB