You are not logged in.

#1 2011-05-03 11:13:11

fzzbt
Member
Registered: 2011-02-19
Posts: 13

Gnome3 with gnome-shell starts with empty blue screen

when i have gnome-shell installed, gnome3 starts with empty blue screen.
i cant do anything in it.
there are no panels, desktop  icons or anything.
without gnome-shell installed i can get gnome starting properly.

any ideas?

Offline

#2 2011-05-03 11:18:23

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3 with gnome-shell starts with empty blue screen

paste ~/.xsession-errors and pacman -Qm


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2011-05-03 11:26:48

fzzbt
Member
Registered: 2011-02-19
Posts: 13

Re: Gnome3 with gnome-shell starts with empty blue screen

wonder wrote:

paste ~/.xsession-errors and pacman -Qm

here

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
gnome-session[3365]: WARNING: Could not parse desktop file /home/fuzzybyte/.config/autostart/xfce4-tips-autostart.desktop: Key file does not have key 'Name'
gnome-session[3365]: WARNING: could not read /home/fuzzybyte/.config/autostart/xfce4-tips-autostart.desktop
gnome-session[3365]: WARNING: Could not parse desktop file /home/fuzzybyte/.config/autostart/xfce4-settings-helper-autostart.desktop: Key file does not have key 'Name'
gnome-session[3365]: WARNING: could not read /home/fuzzybyte/.config/autostart/xfce4-settings-helper-autostart.desktop
gnome-session[3365]: WARNING: Could not parse desktop file /home/fuzzybyte/.config/autostart/xfconf-migration-4.6.desktop: Key file does not have key 'Name'
gnome-session[3365]: WARNING: could not read /home/fuzzybyte/.config/autostart/xfconf-migration-4.6.desktop
GNOME_KEYRING_CONTROL=/tmp/keyring-cIyOJk
SSH_AUTH_SOCK=/tmp/keyring-cIyOJk/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-cIyOJk
SSH_AUTH_SOCK=/tmp/keyring-cIyOJk/ssh
GPG_AGENT_INFO=/tmp/keyring-cIyOJk/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-cIyOJk
SSH_AUTH_SOCK=/tmp/keyring-cIyOJk/ssh
GPG_AGENT_INFO=/tmp/keyring-cIyOJk/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-cIyOJk
SSH_AUTH_SOCK=/tmp/keyring-cIyOJk/ssh
GPG_AGENT_INFO=/tmp/keyring-cIyOJk/gpg:0:1

(gnome-settings-daemon:3409): keybindings-plugin-WARNING **: Key binding (hamster-applet) is incomplete

(gnome-settings-daemon:3409): keybindings-plugin-WARNING **: Key binding (screenreader) is incomplete

(gnome-settings-daemon:3409): keybindings-plugin-WARNING **: Key binding (magnifier) is incomplete

(gnome-settings-daemon:3409): keybindings-plugin-WARNING **: Key binding (onscreenkeyboard) is incomplete
gnome-session[3365]: WARNING: Application 'gnome-shell.desktop' killed by signal

acroread 9.4.2-1
bitcoin-bin 0.3.20.2-1
codecs64 20071007-1
csstidy 1.4-1
eclipse-pydev 1.6.5-4
kega-fusion 3.63-11
libvoikko 3.2-1
ntfs-config 1.0.1-6
python-gnomeapplet 2.32.0-4
suomi-malaga-voikko 1.8-1
ttf-mona 2.90-1
ttf-ms-fonts 2.0-7
voikko-libreoffice 3.2-1
xorg-res-utils 1.0.3-3

Last edited by fzzbt (2011-05-03 11:27:37)

Offline

#4 2011-05-03 11:33:57

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3 with gnome-shell starts with empty blue screen

try deleting everything from /home/fuzzybyte/.config/autostart


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2011-05-03 11:36:12

fzzbt
Member
Registered: 2011-02-19
Posts: 13

Re: Gnome3 with gnome-shell starts with empty blue screen

wonder wrote:

try deleting everything from /home/fuzzybyte/.config/autostart

that didn't do anything other than just  removed the xfce error messages

Offline

#6 2011-05-03 11:37:33

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3 with gnome-shell starts with empty blue screen

what video card do you have?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#7 2011-05-03 11:39:56

fzzbt
Member
Registered: 2011-02-19
Posts: 13

Re: Gnome3 with gnome-shell starts with empty blue screen

wonder wrote:

what video card do you have?

radeon 6870hd with xf86-video-ati drivers.

i got the shell working earlier for a while with catalyst drivers, but i think i  did something that broke it after boot.
anyway, i cant get it working with either drivers  anymore.

Offline

#8 2011-05-03 11:41:22

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3 with gnome-shell starts with empty blue screen

be sure you are not disabling KMS. that's the only requirement


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#9 2011-05-03 13:01:08

fzzbt
Member
Registered: 2011-02-19
Posts: 13

Re: Gnome3 with gnome-shell starts with empty blue screen

nevermind. i dont want to use gnome anymore.
right now, gnome3 experience feels like KDE4 in its early days; it's just a polished turd.

bye bye gnome.

Offline

#10 2011-05-03 14:08:19

Segura
Member
Registered: 2011-03-05
Posts: 12

Re: Gnome3 with gnome-shell starts with empty blue screen

Hi, I had the same problem. Maybe it's because you installed gnome shell before the release with jhbuild, in my case I could start only if I run on "low graphics mode" without "gnome-shell" installed.
To fix it I removed previous gtk3 packages like "package gtk3" and reinstalled gnome and gnome-extra.

Hope it helps

PD: Sorry for my bad english.

Offline

#11 2011-05-03 19:07:48

acsorama
Member
Registered: 2011-05-03
Posts: 2

Re: Gnome3 with gnome-shell starts with empty blue screen

I had the same problem.

.xsession-errors file is:
---------------------------------------
/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session

(gnome-settings-daemon:19336): keybindings-plugin-WARNING **: A gyorsbillentyű (screenreader) hiányos

(gnome-settings-daemon:19336): keybindings-plugin-WARNING **: A gyorsbillentyű (magnifier) hiányos

(gnome-settings-daemon:19336): keybindings-plugin-WARNING **: A gyorsbillentyű (onscreenkeyboard) hiányos
GNOME_KEYRING_CONTROL=/tmp/keyring-o0enyG
GPG_AGENT_INFO=/tmp/keyring-o0enyG/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-o0enyG
GPG_AGENT_INFO=/tmp/keyring-o0enyG/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-o0enyG
GPG_AGENT_INFO=/tmp/keyring-o0enyG/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-o0enyG
GPG_AGENT_INFO=/tmp/keyring-o0enyG/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-o0enyG/ssh
gnome-session[19299]: WARNING: Application 'gnome-shell.desktop' killed by signal

MCS->Xfconf settings migration complete

[2011-05-11 15:48] [WARNING] System is not able to show notifications.

(gnome-settings-daemon:19336): libnotify-WARNING **: Failed to connect to proxy
Failed to receive server caps.
------------------------------------------

output of pacman -Qm is :

acroread 9.4.2-1
beecrypt 4.2.1-4
btrfs-progs-git 20110130-1
chromium-browser-bin 73331-1
chromium-codecs-ffmpeg-nonfree-bin 12.0.715.0.79484-1
cloog-ppl 0.15.10-2
clutter-imcontext 0.1.4-1
dropbox 1.0.28-1
gip 1.7.0_1-1
gjs-dev 0.7.11-1
glib2-newest 2.28.1-1
gnome-audio 2.22.2-1
gnome-cups-manager 0.33-6
gnome-netstatus 2.28.2-1
gnome-ssh-askpass2 5.5p1-1
gobject-introspection-dev 0.10.3-1
google-earth 6.0.1.2032-3
gtkpacman 2.3.1-4
html2ps 1.0b7-1
ld-lsb 3-2
libgail-gnome 1.20.4-1
libjpeg6 6b-9
libpng12 1.2.44-1
man2html 3.0.1-2
metamorphose2 0.8.2-1
mkinitcpio-btrfs 0.3-3
ntpdate 4.2.6-1
openswan 2.6.32-1
openxencenter rev227_20100510-4
openxenmanager-svn 60-1
package-query 0.7-1
pulseaudio-mixer-applet 0.2.2-6
python2-gtkchart-git 20110221-1
python-brasero 2.32.0-4
python-cssutils 0.9.7-1
python-evince 2.32.0-4
python-gnomeapplet 2.32.0-4
python-mediaprofiles 2.32.0-4
rpm 5.2.1-3
solaris-pl 0.5.2-1
teamviewer 6.0.9224-3
transmission-remote-gui-bin 3.0.1-1
virtualbox_bin 4.0.4-3
yaourt 0.10.1-2
zfs 0.5.2-1


video card is nvidia (asus GT520) work perfectly with previous gnome and xfce (win7 also)

Offline

#12 2011-05-03 20:17:40

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Gnome3 with gnome-shell starts with empty blue screen

@acsorama don't you see the problem?
gjs-dev 0.7.11-1 glib2-newest 2.28.1-1 gobject-introspection-dev 0.10.3-1

this packages are NOT from the repos. replace them with stock

pacman -S gjs glib2 gobject-introspection


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#13 2011-05-04 11:34:16

acsorama
Member
Registered: 2011-05-03
Posts: 2

Re: Gnome3 with gnome-shell starts with empty blue screen

Thank you for quick answer.  After I issue "pacman -S gjs glib2 gobject-introspection" command I try to use gnome3.
Now  I got a message like this "OOps .. Something wrong happened, and a system cant recover it. Logout and try a new login" in a nice window.
Here is a new .xsession-errors file,

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
gnome-session[1842]: WARNING: Could not parse desktop file /home/gnome/.config/autostart/xfconf-migration-4.6.desktop: A kulcsfájlban nincs „Name” kulcs
gnome-session[1842]: WARNING: could not read /home/gnome/.config/autostart/xfconf-migration-4.6.desktop
GNOME_KEYRING_CONTROL=/tmp/keyring-QMenYD
GNOME_KEYRING_CONTROL=/tmp/keyring-QMenYD
SSH_AUTH_SOCK=/tmp/keyring-QMenYD/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-QMenYD
GNOME_KEYRING_CONTROL=/tmp/keyring-QMenYD
SSH_AUTH_SOCK=/tmp/keyring-QMenYD/ssh
GPG_AGENT_INFO=/tmp/keyring-QMenYD/gpg:0:1

(gnome-settings-daemon:1880): keybindings-plugin-WARNING **: A gyorsbillentyű (screenreader) hiányos

(gnome-settings-daemon:1880): keybindings-plugin-WARNING **: A gyorsbillentyű (magnifier) hiányos

(gnome-settings-daemon:1880): keybindings-plugin-WARNING **: A gyorsbillentyű (onscreenkeyboard) hiányos

MCS->Xfconf settings migration complete

Figyelmeztetés az ablakkezelőtől: Log level 8: gtk_style_context_get: assertion `priv->widget_path != NULL' failed
Failed to play sound: File or data not found
gnome-session[1842]: WARNING: Application 'gnome-shell.desktop' killed by signal
Figyelmeztetés az ablakkezelőtől: Log level 8: gtk_style_context_get: assertion `priv->widget_path != NULL' failed
gnome-session[1842]: WARNING: App 'gnome-shell.desktop' respawning too quickly
gnome-session[1842]: WARNING: Application 'gnome-shell.desktop' killed by signal

(gnome-settings-daemon:1880): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
applet.py: Fatal IO error 11 (Erőforrás átmenetileg nem érhető el) on X server :0.
(gnome-screensaver:1968): Gdk-WARNING **: gnome-screensaver: Fatal IO error 11 (Erőforrás átmenetileg nem érhető el) on X server :0.


(gdu-notification-daemon:1958): Gdk-WARNING **: gdu-notification-daemon: Fatal IO error 11 (Erőforrás átmenetileg nem érhető el) on X server :0.


what can I do ???

Last edited by acsorama (2011-05-04 12:00:08)

Offline

#14 2011-05-05 07:51:31

fzzbt
Member
Registered: 2011-02-19
Posts: 13

Re: Gnome3 with gnome-shell starts with empty blue screen

update: turns out it was not a gnome problem but likely a bug in the open source ati drivers.
by using git version of the drivers gnome at least  starts, but it is very unstable.

anyway, shit sucks.

Offline

#15 2011-05-05 09:15:42

DKnight
Member
Registered: 2010-12-23
Posts: 19

Re: Gnome3 with gnome-shell starts with empty blue screen

Same problem here... I had to reinstall the entire system, now it works. I have a nvidia card btw...

Offline

#16 2011-05-05 13:17:32

thms
Member
Registered: 2010-02-01
Posts: 117

Re: Gnome3 with gnome-shell starts with empty blue screen

Isn't there anything else one can do (reinstalling sounds like the MS way)?

I want to test gnome3 and only get a blue screen too:

/etc/gdm/Xsession: Beginning session setup...
Fehlgeschlagen: Modulinitialisierung fehlgeschlagen
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
Fensterverwalter-Warnung:0, gespeichert in GConf-Schlüssel /apps/metacity/general/num_workspaces, liegt außerhalb des Bereichs 1-36
Fensterverwalter-Warnung:0, gespeichert in GConf-Schlüssel /desktop/gnome/peripherals/mouse/cursor_size, liegt außerhalb des Bereichs 1-128
Fensterverwalter-Warnung:Thema »Adwaita« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »Adwaita« gefunden werden

Fensterverwalter-Warnung:Thema »Simple« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »Simple« gefunden werden

Fensterverwalter-Warnung:Thema »Raleigh« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »Raleigh« gefunden werden

Fensterverwalter-Warnung:Thema »QtCurve« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »QtCurve« gefunden werden

Fensterverwalter-Warnung:Thema »Emacs« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »Emacs« gefunden werden

Fensterverwalter-Warnung:Thema »Default« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »Default« gefunden werden

Fensterverwalter-Warnung:Thema »oxygen-gtk« konnte nicht geladen werden: Es konnte keine gültige Datei für das Thema »oxygen-gtk« gefunden werden

Fensterverwalter-Fehler:Es konnte kein Thema gefunden werden! Stellen Sie sicher, dass /usr/share/themes existiert und zumindest die mitgelieferten Themen enthält.
Failed to play sound: File or data not found
Fehlgeschlagen: Modulinitialisierung fehlgeschlagen
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 12 requests (12 known processed) with 0 events remaining.
$ pacman -Qm
acroread 9.4.2-1
bespin-svn 1309-1
cloog-ppl 0.15.10-2
customizable-weather-plasmoid 1.4.0-1
gcalcli 1.4-4
gcc-gcj-ecj 4.5-1
hdsentinel 0.3-3
hunspell-de-de 20100727-1
kfilebox 0.4.7-2
kile-i18n 2.1b5-4
latexila 2.0.7-3
libhupnp-svn 93-1
mingetty 1.08-3
minitube 1.4-1
montecarlo-font 1-1
package-query 0.8-1
playonlinux 3.8.12-2
smooth-tasks wip_2010_11_06-1
teamviewer 6.0.9224-4
ttf-ms-fonts 2.0-3
unetbootin 549-1
virtualbox-ext-oracle 4.0.4-1
xorg-res-utils 1.0.3-3
yaourt 0.10.1-2

Thanks

Offline

#17 2011-05-05 14:54:23

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Gnome3 with gnome-shell starts with empty blue screen

I have Gnome 3 / Gnome-shell installed and working fine on both my nVidia based desktop and an ATI Radeon X1200 based laptop. I'm fairly new to Arch Linux (less than a month), but what I did was first installed the Arch Linux x86_64 system both base and base-devel and then after getting a working X system with open source drivers, I followed the tutorial from the wiki regarding Gnome 3 and issued a pacman -Syyu and then pacman -S testing/gnome and then pacman -S testing/gnome-extra since everything was in the testing repo at the time. Now you can leave the testing out and just do pacman -S gnome and pacman -S gnome-extra (as root, of course). I have the nVidia proprietary drivers from the repo working on my desktop and the open source ATI driver working on the laptop. Of course, even when it is working you are going to get a mostly empty blue screen that looks like a blue curtain with Gnome-shell, but there should be a black panel at the top with a few icons and the clock / calendar and the user name in the right corner. You won't have any desktop icons with out tweaking some config files and then you have to fire up nautilus first every login before they will show up.

Last edited by sidneyk (2011-05-05 14:54:58)

Offline

#18 2011-05-05 15:24:16

PollyMath
Member
Registered: 2011-05-05
Posts: 14

Re: Gnome3 with gnome-shell starts with empty blue screen

Hi,

I have a similar problem.

I have just done a fresh install of Arch x86_64 + Gnome 3.0.1
The install (and update) went without a hitch.
After i created my user account,I installed X and the nvidia driver (v270.41.06),
and both the 'Gnome' and 'Gnome-extra' groups.

I tried loading the 'Display manager' via the 'inittab' and
the Daemon method (https://wiki.archlinux.org/index.php/Display_Manager)

On both occassions, the boot sequence would reach the nvidia splash screen
and then go black (nothing displayed at all).

i also tried to use 'Automatic login' with both these methods, with the
same result.

If i use 'startx' (https://wiki.archlinux.org/index.php/Gn … ning_GNOME)
Gnome 3 starts just fine, with my username in the top-right corner.

Can anyone tell me how i can get Gnome 3 to load automatically at startup.

Many Thanks.
Regards, PollyMath.

Offline

#19 2011-05-05 16:08:54

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: Gnome3 with gnome-shell starts with empty blue screen

PollyMath, did you modify both lines in the inittab? The one dealing with the default near the top changes from 3 to 5 and near the bottom you also have to uncomment only the line that deals with gdm and make sure the other ones are commented, assuming that you're using gdm and have it installed. I am not using the daemon method and therefore have no entry in the daemon array for gdm. At first I missed the first inittab edit about the default run level of X11 and had the same problem, although I never see an nVidia logo, I may have disabled it though. Hope this helps. These are the changes in inittab that I made:
(Near the top)
## Only one of the following two lines can be uncommented!
# Boot to console
#id:3:initdefault:
# Boot to X11
id:5:initdefault:

(At the bottom)
# Example lines for starting a login manager
#x:5:respawn:/usr/bin/xdm -nodaemon
x:5:respawn:/usr/sbin/gdm -nodaemon
#x:5:respawn:/usr/bin/kdm -nodaemon
#x:5:respawn:/usr/bin/slim >/dev/null 2>&1

Offline

#20 2011-05-08 18:11:43

PollyMath
Member
Registered: 2011-05-05
Posts: 14

Re: Gnome3 with gnome-shell starts with empty blue screen

Hi sidneyk,

Thankyou for your response.
I'm sorry for the delay getting back to you.
I have been trawling the forums for a solution.
I found a solution to *my* problem here: https://bbs.archlinux.org/viewtopic.php?id=118452
The last line of the first post. I would never had figured that out on my own.

Regards, PollyMath.

Offline

#21 2011-05-08 21:24:18

Costinio
Member
Registered: 2007-07-12
Posts: 12

Re: Gnome3 with gnome-shell starts with empty blue screen

I have the exact same problem. I use nouveau driver with old nvidia mx440.
If I have nouveau-dri installed I get the following errors in .xsession-errors
Without nouveau-dri gnome3 starts in fallback mode.

/etc/gdm/Xsession: Beginning session setup...
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
GNOME_KEYRING_CONTROL=/tmp/keyring-nY6n7h
GNOME_KEYRING_CONTROL=/tmp/keyring-nY6n7h
GNOME_KEYRING_CONTROL=/tmp/keyring-nY6n7h
GPG_AGENT_INFO=/tmp/keyring-nY6n7h/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-nY6n7h
GPG_AGENT_INFO=/tmp/keyring-nY6n7h/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-nY6n7h/ssh

(gnome-settings-daemon:3683): keybindings-plugin-WARNING **: Key binding (hamster-applet) is incomplete

(gnome-settings-daemon:3683): keybindings-plugin-WARNING **: Key binding (screenreader) is incomplete

(gnome-settings-daemon:3683): keybindings-plugin-WARNING **: Key binding (magnifier) is incomplete

(gnome-settings-daemon:3683): keybindings-plugin-WARNING **: Key binding (onscreenkeyboard) is incomplete
    JS ERROR: !!!   Exception was: Error: Requiring NetworkManager, version none: Typelib file for namespace 'NetworkManager' (any version) not found
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = '("Requiring NetworkManager, version none: Typelib file for namespace 'NetworkManager' (any version) not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/status/network.js:8
'
    JS ERROR: !!!     message = 'Requiring NetworkManager, version none: Typelib file for namespace 'NetworkManager' (any version) not found'
      JS LOG: NMApplet is not supported. It is possible that your NetworkManager version is too old
      JS LOG: GNOME Shell started at Sun May 08 2011 23:34:47 GMT+0300 (EEST)
/usr/share/wicd/gtk/wicd-client.py:1029: GtkWarning: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
  mainloop.run()

(gnome-power-manager:3725): Gdk-WARNING **: gnome-power-manager: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.


(gnome-settings-daemon:3683): Gdk-WARNING **: gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

[1304886882,000,xklavier.c:xkl_engine_start_listen/]     The backend does not require manual layout management - but it is provided by the application
[1304886882,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]     Page for group 0 is not ready
[1304886882,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]     Page for group 0 is not ready
[1304886882,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]     Page for group 0 is not ready
[1304886882,000,gkbd-status.c:gkbd_status_set_current_page_for_group/]     Page for group 0 is not ready
** Message: Got disconnected from the session message bus; retrying to reconnect every 10 seconds
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
(evolution-alarm-notify:3724): libecal-DEBUG: GDBus connection is closed, remote peer vanished: Underlying GIOStream returned 0 bytes on an async read
(evolution-alarm-notify:3724): libecal-DEBUG: e-cal.c:449: ECal GDBus connection is closed, remote peer vanished: Underlying GIOStream returned 0 bytes on an async read

(evolution-alarm-notify:3724): libecal-WARNING **: gdbus_cal_disconnect: Failed to close calendar, The connection is closed

(evolution-alarm-notify:3724): libecal-DEBUG: e-cal.c:449: ECal GDBus connection is closed, remote peer vanished: Underlying GIOStream returned 0 bytes on an async read

(evolution-alarm-notify:3724): libecal-WARNING **: gdbus_cal_disconnect: Failed to close calendar, The connection is closed

(evolution-alarm-notify:3724): libecal-DEBUG: e-cal.c:449: ECal GDBus connection is closed, remote peer vanished: Underlying GIOStream returned 0 bytes on an async read

(evolution-alarm-notify:3724): libecal-WARNING **: gdbus_cal_disconnect: Failed to close calendar, The connection is closed

(evolution-alarm-notify:3724): libecal-DEBUG: e-cal.c:449: ECal GDBus connection is closed, remote peer vanished: Underlying GIOStream returned 0 bytes on an async read

(evolution-alarm-notify:3724): libecal-WARNING **: gdbus_cal_disconnect: Failed to close calendar, The connection is closed

g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
gnome-session[3644]: Gdk-WARNING: The application 'gnome-session' lost its connection to the display :0;
most likely the X server was shut down or you killed/destroyed
the application.

Window manager warning: Log level 16: gnome-shell: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

gnome-shell-calendar-server[3758]: Lost (or failed to acquire) the name org.gnome.Shell.CalendarServer - exiting
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

(gdu-notification-daemon:3728): Gdk-WARNING **: gdu-notification-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

wicd-client.py: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Importing pynotify failed, notifications disabled.
Has notifications support False
Loading...
Connecting to daemon...
Connected.
displaytray True
Done loading.
[costinio@costinio-desktop ~]$ pacman -Qm
bauerbill 2011.01.28.1-1
butt 0.1.12-2
google-earth 6.0.2.2074-1
gtk-candido-engine 0.9.1-4
j7z 1.1.0-1
jdownloader latest-14
ld-lsb 3-2
libjpeg6 6b-9
libpng12 1.2.44-1
linuxdcpp 1.1.0-1
murrine-themes-collection 20101228-1
opera-beta 11.10b1-1
package-query 0.8-1
perl-xyne-arch 2011.02.06.1-2
perl-xyne-common 2011.02.03.3-2
powerpill 2010.08.26.1-1
python-brasero 2.32.0-4
shoutcast_trans 0.40-1
ttf-ms-fonts 2.0-8
xorg-res-utils 1.0.3-3
yaourt 0.10.1-2

Offline

#22 2011-05-13 13:47:46

mostafa
Member
Registered: 2011-05-13
Posts: 6

Re: Gnome3 with gnome-shell starts with empty blue screen

I have Arch on two different machines, and had this problem on both.

I guess to fix the problem you have to run

gnome-session-properties

and uncheck Automatically remember running applications when logging in under Options tab.

Hope that helps.

Last edited by mostafa (2011-05-13 13:49:53)

Offline

#23 2011-05-17 09:36:36

mini
Member
Registered: 2006-12-18
Posts: 132

Re: Gnome3 with gnome-shell starts with empty blue screen

To uncheck Automatically remember running applications when logging in under Options tab helped for me. Thanks a lot

Offline

#24 2011-05-26 13:03:11

LeCrayonVert
Member
Registered: 2010-09-01
Posts: 133

Re: Gnome3 with gnome-shell starts with empty blue screen

How could I uncheck this option as I can only start with an empty blue screen ?


I believe in a world I can and do understand. A rational universe, explained through rational means.

Offline

#25 2011-05-26 13:37:35

mostafa
Member
Registered: 2011-05-13
Posts: 6

Re: Gnome3 with gnome-shell starts with empty blue screen

Fortunately, I had an old setting which allowed me to run the terminal with Mod4+Enter and it turned out very useful in this case.

You can temporarily try another desktop environment at the login time if you have any installed, or enable fallback mode of GNOME 3. The wiki says you can enable the fallback mode with a terminal by this commnad:

$ GSETTINGS_BACKEND=dconf gsettings set org.gnome.desktop.session session-name gnome-fallback

Offline

Board footer

Powered by FluxBB