You are not logged in.

#1 2011-06-13 09:43:10

QueenZ
Member
Registered: 2011-06-13
Posts: 5

Xorg: Fatal server error, no screens found

Hi, I just installed Arch Linux 2010 fresh. And after my installation completed, I installed Xorg using pacman -Syu xorg-server and pacman -Syu xorg-xinit.

But when I run startx it gives me a fatal error that goes something like...

Fatal server error: no screens found
xinit: giving up
xinit: unable to connect to X Server: connection refused
xinit: server error

Take a look at this screenshot, to get the full picture..
http://www.bildites.lv/images/wieanqq9te86gbi8x246.png

What's wrong? what do i need to do to be able to run X?


-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Offline

#2 2011-06-13 09:50:11

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,800
Website

Re: Xorg: Fatal server error, no screens found

The instruction in the Beginners' Guide is:

# pacman -S xorg-server xorg-xinit xorg-utils xorg-server-utils

The error is also telling you that you don't have a video driver: https://wiki.archlinux.org/index.php/Be … deo_driver


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2011-06-13 14:16:13

QueenZ
Member
Registered: 2011-06-13
Posts: 5

Re: Xorg: Fatal server error, no screens found

I installed all of the packages you listed - xorg-utils and xorg-server-utils but I'm still getting the same error. I'm using VirtualBox, what drivers do I need?

Offline

#4 2011-06-13 14:20:41

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: Xorg: Fatal server error, no screens found

you need drivers for whatever video card you have on your machine.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2011-06-13 14:33:21

QueenZ
Member
Registered: 2011-06-13
Posts: 5

Re: Xorg: Fatal server error, no screens found

OK, after installing the drivers, X seems to start for 1 second and then shuts down immediately... I get this kind of error after it has shut down..

http://www.bildites.lv/images/1c5ytbitrhvaqchihtgl.png

Removed image tags for large image -- Inxsible

Last edited by Inxsible (2011-06-13 14:37:03)

Offline

#6 2011-06-13 14:34:33

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: Xorg: Fatal server error, no screens found

what card do you have and what driver did you install? roll


Also please read the image posting rules that Jason listed in your first post. Thumbnails only !


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#7 2011-06-13 15:37:02

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: Xorg: Fatal server error, no screens found

You are installing in Virtualbox - did you set up Guest additions etc as described here? Some more random ideas - If you manually created xorg.conf files, try without them, have a look at the vboxclient thing and don't use root account for startx.

Offline

#8 2011-06-13 15:37:42

QueenZ
Member
Registered: 2011-06-13
Posts: 5

Re: Xorg: Fatal server error, no screens found

VirtualBox drivers....

Offline

#9 2011-06-13 17:45:40

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,800
Website

Re: Xorg: Fatal server error, no screens found

Please read the How To Post section of the Forum Etiquette -- in fact, read the whole thing.

If you are looking for assistance, you need to (a) provide us with the information we need to help you and (b) demonstrate that you are willing to help yourself. Currently, you are doing neither.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#10 2011-06-13 18:26:28

QueenZ
Member
Registered: 2011-06-13
Posts: 5

Re: Xorg: Fatal server error, no screens found

hokasch wrote:

You are installing in Virtualbox - did you set up Guest additions etc as described here? Some more random ideas - If you manually created xorg.conf files, try without them, have a look at the vboxclient thing and don't use root account for startx.

Yes, I installed the Guest additions. I don't have xorg conf file. how do i look at vboxclient?

Offline

Board footer

Powered by FluxBB