You are not logged in.

#1 2011-08-29 16:12:48

zanian
Member
Registered: 2009-05-20
Posts: 7

[Solved] Microphone, alsa, horrible background noise

Hi,

I recently did a fresh install of Arch linux and now my microphone does not work.  I can't tell if this happened before I jumped to linux 3.0, because I was out of town when the kernel was released.  However, I am pretty sure that my microphone worked with 2.6.  Anyway, I have fiddled around with alsamixer and nothing seems to get rid of this horrible background noise.  You can barely distinguish voices in the background and altering the levels in alsamixer does not change the intensity of the sound.  I can mute the microphone with spacebar, so alsamixer is working.  The rest of my sound controls work fine and microphone noise is there with headphones plugged in so it can't be feedback. 
EDIT: the noise occurs in every program I've tried: skype, arecord, wine and even with virtualbox.

These are the alsa packages installed:

alsa-lib 1.0.24.1-1
alsa-oss 1.0.17-1
alsa-plugins 1.0.24-2
alsa-utils 1.0.24.2-3
lib32-alsa-lib 1.0.24.1-1
lib32-alsa-oss 1.0.17-2
lib32-alsa-plugins 1.0.24-1

These are the relevant settings:

.asoundrc.asoundconf

!defaults.pcm.card SB
defaults.ctl.card SB
defaults.pcm.device 0
defaults.pcm.subdevice -1
defaults.pcm.nonblock 1
defaults.pcm.compat 0
defaults.pcm.minperiodtime 5000
defaults.pcm.ipc_key 5678293
defaults.pcm.ipc_gid audio
defaults.pcm.ipc_perm 0660
defaults.pcm.dmix.max_periods 0
defaults.pcm.dmix.rate 48000
defaults.pcm.dmix.format "unchanged"
defaults.pcm.dmix.card defaults.pcm.card
defaults.pcm.dmix.device defaults.pcm.device
defaults.pcm.dsnoop.card defaults.pcm.card
defaults.pcm.dsnoop.device defaults.pcm.device
defaults.pcm.front.card defaults.pcm.card
defaults.pcm.front.device defaults.pcm.device
defaults.pcm.rear.card defaults.pcm.card
defaults.pcm.rear.device defaults.pcm.device
defaults.pcm.center_lfe.card defaults.pcm.card
defaults.pcm.center_lfe.device defaults.pcm.device
defaults.pcm.side.card defaults.pcm.card
defaults.pcm.side.device defaults.pcm.device
defaults.pcm.surround40.card defaults.pcm.card
defaults.pcm.surround40.device defaults.pcm.device
defaults.pcm.surround41.card defaults.pcm.card
defaults.pcm.surround41.device defaults.pcm.device
defaults.pcm.surround50.card defaults.pcm.card
defaults.pcm.surround50.device defaults.pcm.device
defaults.pcm.surround51.card defaults.pcm.card
defaults.pcm.surround51.device defaults.pcm.device
defaults.pcm.surround71.card defaults.pcm.card
defaults.pcm.surround71.device defaults.pcm.device
defaults.pcm.iec958.card defaults.pcm.card
defaults.pcm.iec958.device defaults.pcm.device
defaults.pcm.modem.card defaults.pcm.card
defaults.pcm.modem.device defaults.pcm.device
defaults.pcm.file_format "raw"
defaults.pcm.file_truncate true
defaults.rawmidi.card 0
defaults.rawmidi.device 0
defaults.rawmidi.subdevice -1
defaults.hwdep.card 0
defaults.hwdep.device 0
defaults.timer.class 2
defaults.timer.sclass 0
defaults.timer.card 0
defaults.timer.device 0
defaults.timer.subdevice 0
defaults.namehint.showall off
defaults.namehint.basic on
defaults.namehint.extended off
lspci -vv

Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
	Subsystem: Hewlett-Packard Company Device 30fc
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at d2500000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel

Audio device: ATI Technologies Inc RS780 Azalia controller
	Subsystem: ATI Technologies Inc RS780 Azalia controller
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 19
	Region 0: Memory at d2410000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel
cat /proc/asound/cards

 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd2500000 irq 16
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xd2410000 irq 19
head -n 1 /proc/asound/SB/codec#*

==> /proc/asound/SB/codec#0 <==
Codec: IDT 92HD71B7X

==> /proc/asound/SB/codec#1 <==
Codec: LSI ID 1040
amixer

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 29 [45%] [-26.25dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Bass Speaker',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front Mic Jack Mode',0
  Capabilities: enum
  Items: 'Mic In' 'Line In'
  Item0: 'Mic In'
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Playback Source',0
  Capabilities: enum
  Items: 'Digital Playback' 'Analog Mux 1' 'Analog Mux 2'
  Item0: 'Digital Playback'
Simple mixer control 'Beep',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 3
  Mono: Playback 0 [0%] [-18.00dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control 'Digital',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]
Simple mixer control 'Internal Mic',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 3
  Front Left: Capture 3 [100%] [30.00dB]
  Front Right: Capture 3 [100%] [30.00dB]
Simple mixer control 'Mux',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 3
  Front Left: Capture 3 [100%] [30.00dB]
  Front Right: Capture 3 [100%] [30.00dB]

Let me know if I am missing any settings!  Thanks in advance.

Last edited by zanian (2011-08-29 19:46:06)

Offline

#2 2011-08-29 17:40:35

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: [Solved] Microphone, alsa, horrible background noise

Well me in your situation, I would try it without all those custom settings. I'd remove the ~/.asoundrc stuff. Maybe there's a setting in there which causes those problems.

Offline

#3 2011-08-29 18:00:18

zanian
Member
Registered: 2009-05-20
Posts: 7

Re: [Solved] Microphone, alsa, horrible background noise

Well me in your situation, I would try it without all those custom settings. I'd remove the ~/.asoundrc stuff. Maybe there's a setting in there which causes those problems.

No change.

Offline

#4 2011-08-29 18:12:37

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: [Solved] Microphone, alsa, horrible background noise

Try manually loading soundcore

and also see this thread ::  https://bbs.archlinux.org/viewtopic.php?pid=982212


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2011-08-29 19:45:14

zanian
Member
Registered: 2009-05-20
Posts: 7

Re: [Solved] Microphone, alsa, horrible background noise

I had to mess with a whole bunch of settings in conjunction.  The issue was that my Internal Mic was at 100, but needed to be at 0, while Digital had to be at 24 (for db gain: 0).  Anyway, everything works now, sorry to have posted for such an easy solution.  Regardless, I appreciate your answers and the documentation which I will bookmark.
Thanks!

Offline

#6 2013-04-13 16:13:50

benjaminisant
Member
Registered: 2013-04-13
Posts: 1

Re: [Solved] Microphone, alsa, horrible background noise

You're all pardoned, your self reply just let me solve the same issue much faster than you did wink

Offline

#7 2013-04-15 13:45:54

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: [Solved] Microphone, alsa, horrible background noise

benjaminisant, please do not necrobump threads. Our policy :: https://wiki.archlinux.org/index.php/Fo … Bumping.22


Closing....


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB