You are not logged in.

#1 2011-10-18 12:39:34

junkie
Member
From: Hungary
Registered: 2011-10-12
Posts: 20

[SOLVED] How to disable these messages at boot?

So I managed to install Arch, and set up the network. I have a Broadcom 4313 wireless chip, all I had to do is blacklist the bcma module, because it conflicted with the brcmsmac module, both are loaded by default (no need to add anything to MODULES=(), only the blacklist bcma entry to modprobe.conf)

So now I have a wlan0 interface that works perfectly fine, only I get these status messages during boot, that are totally unnecessary, see screenshot. These just pop up from nowhere, and annoy the heck out of me, disrupting the login and whatnot.

So can these be turned off somehow? I suspect they come from the brcmsmac module itself.

http://dl.dropbox.com/u/20678367/arch-n … ssages.png

Mod edit:
The image is too large: https://wiki.archlinux.org/index.php/Fo … s_and_Code

Last edited by bernarcher (2011-10-18 19:16:57)

Offline

#2 2011-10-18 12:54:15

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,606
Website

Re: [SOLVED] How to disable these messages at boot?

Well, the first thing that comes to mind is Alt-F2... obviously not he most elegant solution smile


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#3 2011-10-18 13:00:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,425

Re: [SOLVED] How to disable these messages at boot?

Do you have 'quiet' on your kernel boot line in grub?

kernel /vmlinuz-linux root=/dev/disk/by-uuid/bf1d191b-0f0d-4961-bd67-4d023a2e5873 quiet ro

Offline

#4 2011-10-18 13:17:24

Gusar
Member
Registered: 2009-08-25
Posts: 3,428

Re: [SOLVED] How to disable these messages at boot?

Add "dmesg -n 3" to /etc/rc.local

Offline

#5 2011-10-18 13:53:28

junkie
Member
From: Hungary
Registered: 2011-10-12
Posts: 20

Re: [SOLVED] How to disable these messages at boot?

karol wrote:

Do you have 'quiet' on your kernel boot line in grub?

kernel /vmlinuz-linux root=/dev/disk/by-uuid/bf1d191b-0f0d-4961-bd67-4d023a2e5873 quiet ro

No, no quiet.

Offline

#6 2011-10-18 13:55:14

junkie
Member
From: Hungary
Registered: 2011-10-12
Posts: 20

Re: [SOLVED] How to disable these messages at boot?

Gusar wrote:

Add "dmesg -n 3" to /etc/rc.local

That seems to solve my problem, thank you!

Just out of curiosity, what numbers, or levels are available for the -n switch? The man doesn't state that.

Offline

#7 2011-10-18 13:55:37

karol
Archivist
Registered: 2009-05-06
Posts: 25,425

Re: [SOLVED] How to disable these messages at boot?

junkie wrote:
karol wrote:

Do you have 'quiet' on your kernel boot line in grub?

kernel /vmlinuz-linux root=/dev/disk/by-uuid/bf1d191b-0f0d-4961-bd67-4d023a2e5873 quiet ro

No, no quiet.

Add it. If this doesn't work, try 'loglevel=3'.

[2011-07-31 18:35] warning: /etc/rc.conf installed as /etc/rc.conf.pacnew
[2011-07-31 18:35] VERBOSE= in rc.conf no longer has any effect.
[2011-07-31 18:35] Please append 'quiet' to your kernel command line.

Offline

#8 2011-10-18 13:59:04

karol
Archivist
Registered: 2009-05-06
Posts: 25,425

Re: [SOLVED] How to disable these messages at boot?

junkie wrote:
Gusar wrote:

Add "dmesg -n 3" to /etc/rc.local

That seems to solve my problem, thank you!

Just out of curiosity, what numbers, or levels are available for the -n switch? The man doesn't state that.

http://mailman.archlinux.org/pipermail/ … 21114.html

https://bbs.archlinux.de/viewtopic.php?pid=267954 (it's from the German Arch forum, but the loglevel= stuff is in English)
Full list: http://www.kernel.org/doc/Documentation … meters.txt

Last edited by karol (2011-10-18 14:02:47)

Offline

#9 2011-10-18 14:06:24

junkie
Member
From: Hungary
Registered: 2011-10-12
Posts: 20

Re: [SOLVED] How to disable these messages at boot?

The loglevel=3 does the job, too. smile

"quiet" doesn't seem to do anything.

The last link is what I was looking for, thanks.

Offline

#10 2011-10-18 21:03:57

Math
Member
Registered: 2011-10-10
Posts: 19

Re: [SOLVED] How to disable these messages at boot?

https://bbs.archlinux.org/viewtopic.php?id=126188
I had the same thing a week ago.

Installing the broadcom-wl from the AUR also worked for me.

Not sure what's the best option?

Last edited by Math (2011-10-18 21:04:35)

Offline

#11 2011-10-19 00:35:27

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [SOLVED] How to disable these messages at boot?

Best option is to harass upstream to get rid of these debug messages by classifying them properly.

Offline

Board footer

Powered by FluxBB