You are not logged in.

#1 2005-07-01 18:22:59

From: Croatia
Registered: 2005-06-17
Posts: 34

PPP dies with signal 11


I rarely post my problems on forums as I usually find some way to resolve it (searching on google) or someone from IRC helps.

However, this is really a tough cookie and I am totally down on this.

Yesterday, I wanted to give celestia (a space program) a try so I pacmanized it (pacman -Sy celestia), ran it, got impressed in a few seconds just to get "deimpressed" when it froze up the whole system. The only thing left to do was to manually shut the computer down and then turn it back on again.

After I did that, started Arch I tried to connect to the net, but then it started giving me headaches that last up until now.

I use wvdial to connect and everything worked very well until then. This is what I repetedly get now:

--> Sending: AT &FW3+MS=V92,1,28800,33600,28800,56000
AT &FW3+MS=V92,1,28800,33600,28800,56000
--> Sending: ATX3
--> Modem initialized.
--> Sending: ATDT076767676
--> Waiting for carrier.
--> No Carrier!  Trying again.   
--> Sending: ATDT076767676
--> Waiting for carrier.
CONNECT 52000 V42B
                        Dobro dosli na  servis   

                      CARNetovih Modemskih Ulaza

                Saznajte sve o CMU servisu na URL adresi:


User Access Verification
--> Carrier detected.  Waiting for prompt.
--> Looks like a login prompt.
--> Sending: dpekic.foi
--> Looks like a password prompt.
--> Sending: (password)
--> Hmm... a prompt.  Sending "ppp".
Entering PPP mode.
Async interface address is unnumbered (Loopback0)
Your IP address is MTU is 1500 bytes
Header compression is on.
~[7f]}#@!}!c} }4}"}&} }*} } }%}&T$O!}'}"}(}"8};~
--> PPP negotiation detected.
--> Starting pppd at Sat Jul  2 17:38:00 2005
--> pid of pppd: 6081
--> PPP was killed! (signal = 11)
--> Disconnecting at Sat Jul  2 17:38:01 2005
--> The PPP daemon has died: Peer didn't authenticatie itself (exit code = 11)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 11)

That is pretty much the whole output after running wvdial, all the usual except the ending. So, it does connect, but when it comes to starting pppd and probably the final authentication (peer authentication) it simply fails. The man pppd doesn't give any more useful info and I can't find anything in logs as well.

I haven't edited any configuration files related to ppp or wvdial for a while, certainly not when I was downloading and installing celestia.
This has happened exactly after celestia froze up and I had to manually (dirty) restart the comp. My guess is that this dirty restart left some file somewhere in an "unfinished" state which is not causing problems. The thing is that I don't have a clue to what would that file be. I went through the /etc/ppp and everything looks normal there. /etc/wvdial.conf is normal as well. I even deleted the content of the /var/tmp and /tmp directories, but it doesn't help.

Btw, right after the first freeze up of nautilus I was actually able to connect once after a few tries. I don't have a clue why. However, later when I tried running celestia a few more times to see what may be causing its freezup, I couldn't connect one single time anymore. (and everytime I ran celestia it froze the system and made me do a dirty shut down).

I would be very grateful if anyone would be able to share any helpful insights to this, or even a solution.

Thank you


#2 2005-07-01 23:14:06

From: Croatia
Registered: 2005-06-17
Posts: 34

Re: PPP dies with signal 11

Ah.. never mind. I wasted whole day on this and just in the evening somehow came to the idea to look into /var/run where I saw some files that looked like might be related to the ppp and this problem. The files were left there instead of deleted because the connection nor the computer wasn't shut down properly.

I deleted the files and now all works fine.

Now, I just wonder why does celestia freeze. It's such an awesome program...


Board footer

Powered by FluxBB