You are not logged in.

#1 2012-02-01 12:40:33

Registered: 2010-11-06
Posts: 43

proftpd, anonymous login failed.

Hello, I can't login to ftp server with anonymous login. Here is config file:

ServerName                      "ProFTPD at fourier"
ServerType                      standalone
DefaultServer                   on
# Port 21 is the standard FTP port.
Port                            21
# Don't use IPv6 support by default.
UseIPv6                         off

Umask                           022

MaxInstances                    30

# Set the user and group under which the server will run.
User                            nobody
Group                           nobody

# Normally, we want files to be overwriteable.
AllowOverwrite          on

# Bar use of SITE CHMOD by default
#  DenyAll

# A basic anonymous configuration, no upload directories.  If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous /srv/ftp>
  AnonRequirePassword off
  # Allow logins if they are disabled above.
  <Limit LOGIN>

  # Maximum clients with message
  MaxClients                    5 "Sorry, max %m users -- try again later"

  User                          ftp
  Group                         ftp
  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias                     anonymous ftp

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
 # An upload directory that allows storing files but not retrieving
  # or creating directories.
  <Directory incomming/*>
    <Limit READ>

    <Limit STOR>

Here the answer of ftp client:

Connected to fourier.
220 ProFTPD 1.3.4a Server (ProFTPD at fourier) []
Name (fourier:eugene): ftp
331 Anonymous login ok, send your complete email address as your password
530 Login incorrect.
ftp: Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.

Last edited by roginovicci (2012-02-01 13:47:33)


#2 2013-02-24 15:50:20

Registered: 2013-02-22
Posts: 2

Re: proftpd, anonymous login failed.

Put "RequireValidShell off" to proftpd.conf


Board footer

Powered by FluxBB