You are not logged in.

#1 2012-02-02 16:51:00

Registered: 2010-11-16
Posts: 39

iwlwifi disconnecting every few minutes


I've got an intel wifi card (Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)), using iwlwifi. Every few minutes I get disconnected from the AP and when trying to reconnect it fails most of the times. Reloading iwlwifi or the networkmanager doesn't help. Is this a bug or may be something wrong with my configuration?


Edit: I am using a Toshiba portege laptop

Last edited by jackgu1988 (2012-02-02 16:52:55)


#2 2012-02-02 16:59:07

Registered: 2009-08-25
Posts: 3,605

Re: iwlwifi disconnecting every few minutes


#3 2012-02-02 17:07:15

Registered: 2010-11-16
Posts: 39

Re: iwlwifi disconnecting every few minutes

Damn! My wifi is almost useless now. I hope  it will be fixed when the next kernel comes out!


#4 2012-02-07 23:25:14

Registered: 2011-12-24
Posts: 189

Re: iwlwifi disconnecting every few minutes

Oh...does anyone where were we can go look for progress? I found this but it hasn't been updated for several days. This makes me sad that my constant disconnects were a problem on my end. sad


#5 2012-02-07 23:39:47

Registered: 2009-08-25
Posts: 3,605

Re: iwlwifi disconnecting every few minutes

Hspasta wrote:

Oh...does anyone where were we can go look for progress?

Follow the link I gave, it leads to a patch. Use it, compile yourself a patched kernel. This is open source. Make use of that.

There's also something else, you could try disabling hardware encryption - /etc/modprobe.d/modprobe.conf

option iwlwifi swcrypto=1

Last edited by Gusar (2012-02-08 13:22:01)


#6 2012-02-18 00:42:00

Registered: 2012-01-26
Posts: 22

Re: iwlwifi disconnecting every few minutes

modprobe iwlwifi 11n_disable=1

Fixes the problem for now … gi?id=2328

Last edited by LLStarks (2012-02-18 00:42:27)


#7 2012-08-07 05:27:37

Registered: 2012-08-07
Posts: 1

Re: iwlwifi disconnecting every few minutes

I had a similar problem on my Dell XPS 15z also with the Intel Centrino Advanced-N 6230. If you followed the install guide like I did, you may have a vestigial network manager daemon left over from initial configuration in your rc.conf, which in my case was net-auto-wireless. Checking the rc.conf and making sure there are no daemons to conflict with networkmanager may solve your problem without a patch or modprobe.



#8 2013-01-19 14:46:24

Registered: 2013-01-19
Posts: 1

Re: iwlwifi disconnecting every few minutes

Hi all,

I've installed Arch Linux recently on my laptop and I've been experiencing the same problem myself. I tried jumping from Gentoo forums to Arch Linux forums to you-name-it forums to find an answer to this problem but nothing worked for me.

In these forums, you will find many posts with commands that say that fix that problem (this post will be eventually one of them) but somehow fail to do so in your laptop. I don't know if there is an one-answer-fits-all, but through these searches -and some experimentation of my own- I've found a rather aggressive approach to make my wireless connections more robust. I disabled IPv6 and most of the card's hardware-intensive options.

Still, since this way probably will not work or appeal to most of you, I'd also like to provide a more coherent approach to this problem, so that you will know where to go to after reading this post (than endlessly Google searching).

Step 0: Know your enemy

The problem I was dealing with was similar to the original poster's and happened consistently. When my signal's strength wasn't good and the network card had lots of traffic (downloading a file while watching YouTube while ...), the download speed would abruptly come to a halt. Removing and re-inserting the iwlwifi module would fix it temporarily, but later on it would relapse. Also, there was no apparent error to troubleshoot, since iwlwifi would print on dmesg only the re-connections and not any error.

The above was experienced with kernels 3.2, 3.5, 3.6, 3.7. I can't say for sure that all versions of these kernels are problematic, so you are free to check it out your self. An easy way to check if patches were issued about iwlwifi in a specific kernel version can be found from here. Just compare the dates of the file changes between different kernel versions.

Also, you might want to know that the wifi was working seamlessly with the 3.3.8 version of the kernel. Thus, if you want to check out a different linux kernel, I'd suggest you start with this one. Obviously, this is for people using Debian or other distros that rely on older kernels. So, our first question would be...

Step 1: What is your kernel?

You can find a description of your system with this command:

uname -mor

My output is:

3.7.1-2-ARCH x86_64 GNU/Linux

Step 2: What is your hardware?

It is very important to know what your hardware is. If you have the same hardware as I do, then you probably have more chances to fix it. If you post a question in another forum and then mark your question as solved, people would like to know what your hardware was. If you send a bug report to the iwlwifi team, they will need your card's model.

So, write:

lspci | grep -i net

My output is:

01:00.0 Network controller: Intel Corporation Centrino Wireless-N 130 (rev 34)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Step 3: What is your problem?

You can see more debug info about your problem by writing:


or to filter through these messages:

dmesg | grep iwlwifi

If you see any errors, tracebacks etc. then these are bugs and you'd best search for similar bugs here. If there are no similar bugs, I'd suggest you create a new bug report. The people that answer in this list are core developers of the iwlwifi module and you'd best send them these bug reports in order to help them track down these problems.

Step 4: Solution (?)


The are many ways to disable IPv6. I did it using GRUB:

sudo cp /boot/grub/grub.cfg /boot/grub/grub.bak		#For backup reasons
sudo nano /etc/default/grub

Add this option "ipv6.disable=1" to the line GRUB_CMDLINE_LINUX_DEFAULT=, so that your GRUB looks like this:


Finally, do:

sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo reboot

to update your grub and restart your laptop. If anything goes wrong, you can restore your grub.cfg file using the backup grub.bak we created above.


Provided IPv6 is disabled, you can check in real time which of the following options make a difference, without restarting your laptop:

sudo modprobe -r iwldvm iwlwifi
sudo modprobe iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0  auto_agg=0 swcrypto=1

You can learn more about these options by writing:

modinfo iwlwifi

Hopefully, you will experience no disconnections from now on.
Now, in order to automatically pass these options at startup to iwlwifi, you can create a *.conf file inside /etc/modprobe.d directory.

nano /etc/modprobe.d/iwlwifi.conf

And add this line:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Step 5: This %@#%@ @#%#% doesn't #%@#% work

Well, bummer. I'd highly recommend to inform the developers of iwlwifi about your problem, as I've mentioned above. If the dev list intimidates you, post about this problem here.

Good luck...


It's likely that you may encounter the following strange behavior when trying to connect to your access point.
Copied form my dmesg:

[  904.190052] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S
[  904.197452] iwlwifi 0000:01:00.0: Radio type=0x2-0x2-0x1
[  904.886420] wlan0: authenticate with 00:26:44:b3:16:a4
[  904.928370] wlan0: send auth to 00:26:44:b3:16:a4 (try 1/3)
[  904.930494] wlan0: authenticated
[  904.932220] wlan0: associate with 00:26:44:b3:16:a4 (try 1/3)
[  904.939798] wlan0: RX AssocResp from 00:26:44:b3:16:a4 (capab=0x411 status=0 aid=2)
[  904.942701] wlan0: associated
[  915.641048] wlan0: deauthenticating from 00:26:44:b3:16:a4 by local choice (reason=3)

If the above is coupled with the netcfg's response:

> DHCP IP lease attempt failed.

then you have just encountered a strange dhcpcd bug, which has nothing to do with iwlwifi.
You can find possible solutions here.

Last edited by Brainfree (2013-02-03 07:24:08)


Board footer

Powered by FluxBB