You are not logged in.

#1 2012-02-26 03:08:28

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

[dovecot] dont work after upgrade to dovecot-2.1.1-2

Just FYI, seems like something significant changed in the config.

If you do the update and then restart dovecot, as i did in my case, it seems that you only get a lot of those

Feb 26 04:06:53 localhost dovecot: auth-worker(704): Error: pam(band,93.222.189.203): pam_authenticate() failed: Authentication failure (/etc/pam.d/dovecot missing?

it is true that this file is missing, but he never complained about that file any update before so it seems really to be related to that update....

just wanted to warn you because i think most people wont check the whole config and maybe re-create the whole config in case of an package-release and so run into an not working dovecot

Last edited by Vamp898 (2012-02-26 03:12:33)

Offline

#2 2012-02-26 05:53:33

baobab
Member
Registered: 2010-04-06
Posts: 3

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

See http://wiki2.dovecot.org/Upgrading/2.1, maybe problem is here:

Usernames in authentication are now lowercased by default

I got

Error: user *****: Initialization failed: namespace configuration error: inbox=yes namespace missing

after upgrading to 2.1.1, solved by explicitly defining inbox=yes namespace as suggested.

Btw, it causes auth error:

[07:38:19] IMAP4< * CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE AUTH=PLAIN
[07:38:19] IMAP4< 3 OK Pre-login capabilities listed, post-login capabilities have more.
[07:38:19] IMAP4> 4 AUTHENTICATE PLAIN
[07:38:19] IMAP4< + 
[07:38:19] IMAP4> ****************
[07:38:19] IMAP4< * BYE Internal error occurred. Refer to server log for more information.
** LibSylph-WARNING: [07:38:19] IMAP4 authentication failed.

** IMAP4 authentication failed.

Offline

#3 2012-02-27 14:16:58

jsivak
Member
Registered: 2011-05-13
Posts: 7

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

For those who need the "exact" file to add "inbox=yes" to:

/etc/dovecot/conf.d/15-mailboxes.conf

Offline

#4 2012-02-27 15:49:04

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,961
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

You probably need remove that file. See https://bugs.archlinux.org/task/20809

Offline

#5 2012-02-28 02:07:03

jsivak
Member
Registered: 2011-05-13
Posts: 7

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Pierre wrote:

You probably need remove that file. See https://bugs.archlinux.org/task/20809

Should all config settings be put in /etc/dovecot/dovecot.conf then?

Offline

#6 2012-02-28 12:59:29

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

My last update of dovecot-2.1.1-3 just deleted my dovecot.conf without any informations or telling me something.

Really nice, dovecot doesnt start anymore, the second time i have to configure it this week

Offline

#7 2012-02-28 13:01:12

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Oh no, it was a mistake.

He didn´t deleted my dovecot.conf, he deleted _every_ config file. Now i have to re-configure my dovecot from scratch... just awesome

Offline

#8 2012-02-28 13:01:39

dbb
Member
From: New York City
Registered: 2008-12-14
Posts: 30
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

All the configuration files would have been saved to .pacsave files and warnings issued during installation, just move them back over.

Last edited by dbb (2012-02-28 13:01:59)

Offline

#9 2012-02-28 13:07:08

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

i have 4 pacsave files, thats correct. But that is all.... dovecot dont work if i move those 4 pacsave files back

seems like only the the files i changed are saved, all other files (completely) are deleted

so to clerify,

i have 5 Files

/etc/dovecot/dovecot.conf.pacsave

and inside

/etc/dovecot/conf.d

i have 4 pacsave files. That is _everything_ after the upgrade, there is nothing more, so the dovecot is completely broken and unuseable.

Last edited by Vamp898 (2012-02-28 13:13:56)

Offline

#10 2012-02-28 13:16:25

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Oh nice, i saved my pacsave files in /root and removed dovecot with pacman -Rcns dovecot, also i deleted the /etc/dovecot directory.

Guess what i get after pacman -S dovecot,

nothing xD a dovecot.example in /etc/dovecot and a blank /etc/dovecot/conf.d directory.

Seems like the dovecot packages is completely broken.

Offline

#11 2012-02-28 13:53:36

Dieter
Member
From: Germany
Registered: 2005-10-13
Posts: 128

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Here the not modified config file are also gone after last update and dovecot doesn't run any more. There are no .pacsave files. the old (non-modified) config files are just deleted.
I just downgraded dovecot to 2.2.1-2 which reinstalled the missing config files - and set "IgnorePkg" in pacman.conf until the dovecot issues are solved.

Last edited by Dieter (2012-02-28 13:55:26)

Offline

#12 2012-02-28 14:07:58

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Thats just what i did too. Hoping for -4 with config files...

Offline

#13 2012-02-28 14:42:23

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,641

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Config files have been removed for some reason. You'd better go on and read the logs and fix your local config issue.

Offline

#14 2012-02-28 15:06:52

Vamp898
Member
From: ドイツではまだ住んでいる
Registered: 2009-01-03
Posts: 866
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

AndyRTR wrote:

Config files have been removed for some reason. You'd better go on and read the logs and fix your local config issue.

What Logs? As im not on testing i dont follow any mailling list for such discussions. For important things i take a look on the news on the homepage and if there is nothing i do the upgrade.

Offline

#15 2012-02-28 15:14:57

jsivak
Member
Registered: 2011-05-13
Posts: 7

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Vamp898 wrote:

Oh no, it was a mistake.

He didn´t deleted my dovecot.conf, he deleted _every_ config file. Now i have to re-configure my dovecot from scratch... just awesome

I use etckeeper (avail via AUR) to "control/protect" my /etc files.. that's the only thing that saved my config files.

Offline

#16 2012-03-14 13:24:23

mickey06
Member
Registered: 2011-12-09
Posts: 1

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

Offline

#17 2012-03-28 14:23:33

cmb
Forum Fellow
From: Oklahoma City
Registered: 2008-10-13
Posts: 11
Website

Re: [dovecot] dont work after upgrade to dovecot-2.1.1-2

I just upgraded from dovecot 2.0.17-1 to 2.1.3-1, and all my config files
were gone.  Thankfully, I had a backup!  After copying in my old config
files, dovecot works again.

Offline

Board footer

Powered by FluxBB