You are not logged in.

#1 2012-03-26 17:51:41

Sinma
Member
Registered: 2012-03-26
Posts: 8
Website

[Nginx. PHP-FPM] Dotclear gives blank pages

Hello,


I installed Nginx and PHP-FPM following the documentation, configuration which also worked on my previous server.

I have very recently migrated to another machine, I'm up to date on both machines with (almost) the same configuration, the same packages and the same version of Dotclear.

On this last machine I can not install Dotclear because going on the corresponding url systematically gives me a blank page (no code inside) while Mediawiki works perfectly.

It seems that it is an error 200, having searched various forums. Now the variable "open_basedir" in php.ini file contains the directory of the blog, in addition to / home and / temp. For Nginx, it share the php configuration with MediaWiki.

Thank you in advance,

Last edited by Sinma (2012-03-26 18:36:41)

Offline

#2 2012-03-26 18:27:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [Nginx. PHP-FPM] Dotclear gives blank pages

The title 'Dotclear affiche une page blanche' is not in English. Can you please edit it?

Offline

#3 2012-04-01 10:29:09

a7
Member
Registered: 2012-04-01
Posts: 24

Re: [Nginx. PHP-FPM] Dotclear gives blank pages

Sinma wrote:

On this last machine I can not install Dotclear because going on the corresponding url systematically gives me a blank page (no code inside) while Mediawiki works perfectly.

This does indeed tell us that php-fpm and nginx are proper so it is specific to your Dotclear setup somewhere.

It seems that it is an error 200

This is a http success code, unless you typo-ed.  A blank white page is a common sign of a parsing error on a production-mode-php.ini within a script being called.

So what you probably have is an error in a script being called exclusive to Dotclear.  I would check there, first.  Perhaps a config file with a missing `;` or something akin?  Don't trust your eyes, do it over or use a tool like `sdiff` on a copy of the other machine's configuration.  Otherwise unlock php's error messages within php.ini if applicable.


ex-gentoo && .9 lurker

Offline

#4 2012-04-14 13:37:59

Sinma
Member
Registered: 2012-03-26
Posts: 8
Website

Re: [Nginx. PHP-FPM] Dotclear gives blank pages

Dotclear now works, but it seems not stable… I replace it by Wordpress which works perfectly.

EDIT : I will retry Dotclear tomorrow.

Last edited by Sinma (2012-04-17 23:01:57)

Offline

#5 2014-01-28 22:59:31

Sinma
Member
Registered: 2012-03-26
Posts: 8
Website

Re: [Nginx. PHP-FPM] Dotclear gives blank pages

With new version of Dotclear it works. If someone has the same problem in the future, turn on «display_errors» on «/etc/php/php.ini», in the worst case it’ll help to diagnose the problem. When this parameter is off, a page with an error will give a 404; when on, the error will be displayed (= not secure), so it’s great for debugging.

Offline

Board footer

Powered by FluxBB