You are not logged in.

#1 2012-04-09 08:58:09

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

kernel 3.3.1 panic

I've just upgraded from kernel 3.2.9 to 3.3.1 and upon reboot I faced a nice kernel panic.

It occurs after the display of the grub menu. It shows "Decompressing Linux...Parsing ELF...done" then "Booting the kernel" and then the panic occurs.
The message is : "PANIC : early exception 06 rip 10 : ffffffff81456a10 error 0 cr 2 0"

Is there something I can do apart from reporting the bug upstream ?

System:    Host: xpsl501x Kernel: 3.2.9-1-ARCH x86_64 (64 bit) Desktop: Openbox 3.5.0 Distro: Arch Linux
Machine:   Mobo: Dell model: 00YWG2 version: A08 Bios: Dell version: A08 date: 07/26/2011
CPU:       Quad core Intel Core i7 CPU Q 740 (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
           Clock Speeds: 1: 933.00 MHz 2: 933.00 MHz 3: 933.00 MHz 4: 933.00 MHz 5: 933.00 MHz 6: 933.00 MHz 7: 1734.00 MHz 8: 933.00 MHz
Graphics:  Card: NVIDIA GF108 [GeForce GT 435M] X.Org: 1.12.0.901 driver: nvidia Resolution: 1366x768@50.0hz 
           GLX Renderer: GeForce GT 435M/PCIe/SSE2 GLX Version: 4.2.0 NVIDIA 295.33
Audio:     Card-1: Intel 5 Series/3400 Series Chipset High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.24
           Card-2: NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel
Network:   Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169 
           IF: eth0 state: down mac: f0:4d:a2:65:03:5c
           Card-2: Intel Centrino Wireless-N 1000 driver: iwlwifi 
           IF: wlan0 state: up mac: 8c:a9:82:0a:1e:38
Drives:    HDD Total Size: 500.1GB (12.2% used) 1: /dev/sda ST9500420AS 500.1GB 
Partition: ID: / size: 20G used: 3.8G (20%) fs: ext4 ID: /var size: 20G used: 4.2G (22%) fs: ext4 
           ID: /home size: 422G used: 49G (13%) fs: ext4 ID: swap-1 size: 4.30GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 26.8C mobo: 0.0C gpu: 56C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 125 Uptime: 1:02 Memory: 299.0/3891.0MB Client: Shell inxi: 1.7.31 

Last edited by valr (2012-04-09 09:46:09)

Offline

#2 2012-04-09 10:04:23

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,520
Website

Re: kernel 3.3.1 panic

valr wrote:

Is there something I can do apart from reporting the bug upstream ?

Search our bug tracker and the forums - https://bugs.archlinux.org/task/29240

Last edited by graysky (2012-04-09 10:17:49)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2012-04-09 10:07:57

LoBo3268715
Member
From: WI, USA
Registered: 2012-02-23
Posts: 34

Re: kernel 3.3.1 panic

I also get a kernel panic at boot after upgrading to 3.3.1-1. I'll be digging into the problem after work

Last edited by LoBo3268715 (2012-04-09 10:10:15)


"Linux. A big, bad, scary computer operating system known only by people with neck beards."

Offline

#4 2012-04-09 10:36:25

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

Re: kernel 3.3.1 panic

graysky wrote:
valr wrote:

Is there something I can do apart from reporting the bug upstream ?

Search our bug tracker and the forums - https://bugs.archlinux.org/task/29240

Yep, thanks but I didn't find info on the forum nor google and the bugs currently opened (29240 & 29063) don't help either (I tried the different solutions mentionned without success).

Last edited by valr (2012-04-09 10:37:31)

Offline

#5 2012-04-09 11:55:44

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

Re: kernel 3.3.1 panic

Offline

#6 2012-04-11 01:05:53

jfree143dev
Member
Registered: 2011-04-16
Posts: 6

Re: kernel 3.3.1 panic

I also have a Dell XPS laptop with exactly the same issue...disabling the wireless network card from the BIOS allows it to boot

Offline

#7 2012-04-11 04:31:20

hackfanatic
Member
Registered: 2012-02-12
Posts: 2

Re: kernel 3.3.1 panic

I can confirm that this problem goes away on disabling wifi from Bios setup.

Offline

#8 2012-04-11 17:42:21

dennisbakhuis
Member
Registered: 2012-01-09
Posts: 1

Re: kernel 3.3.1 panic

I have the same issue with the same hardware (dell xps L701x). The laptop boots indeed normally when turning off wlan in the bios.

Offline

#9 2012-04-17 20:09:02

hackfanatic
Member
Registered: 2012-02-12
Posts: 2

Re: kernel 3.3.1 panic

Problem persists with 3.3.2-1, there seems to be a pattern i have a L501x

Offline

#10 2012-04-18 13:11:23

Lothium
Member
Registered: 2009-10-10
Posts: 192

Re: kernel 3.3.1 panic

Same here.

Offline

#11 2012-04-19 17:26:02

jfree143dev
Member
Registered: 2011-04-16
Posts: 6

Re: kernel 3.3.1 panic

A patch has been created to fix the issue. It applies perfectly to the 3.3.2 kernel: https://bugzilla.kernel.org/show_bug.cgi?id=43098#c24

Last edited by jfree143dev (2012-04-19 17:31:12)

Offline

#12 2012-04-21 14:03:37

darkmav
Member
Registered: 2012-01-21
Posts: 73

Re: kernel 3.3.1 panic

I have a Dell XPS 15 L501x and I'm facing the same problem. I can't even boot into Fallback mode. Disabling Wifi through the BIOS lets me boot.

I'm a newbie to Arch, so this question may be dumb...

How do I apply this patch?

Offline

#13 2012-04-21 15:53:50

jfree143dev
Member
Registered: 2011-04-16
Posts: 6

Re: kernel 3.3.1 panic

First, use the Arch Build System to build the kernel if you aren't already:
https://wiki.archlinux.org/index.php/Ke … ild_System

As for applying the patch, see if this thread helps:
https://bbs.archlinux.org/viewtopic.php?pid=1089556

When you start to build the package with 'makepkg', I would recommend using the following command:
MAKEFLAGS="-j4" makepkg

where '4' is the number of CPU cores you have...it'll reduce your compile time.

Also, the next stable release, v3.3.3, will have the patch built-in.

One other consideration you might make is to install the 'linux-lts' package. It will give you a highly stable kernel to fallback on if the 'linux' package is not working for some reason. After installing it you might need to manually add an entry into your /boot/grub/menu.lst (grub v1) or /boot/grub/grub.cfg (grub v2).

Last edited by jfree143dev (2012-04-21 16:09:44)

Offline

#14 2012-04-21 16:07:31

darkmav
Member
Registered: 2012-01-21
Posts: 73

Re: kernel 3.3.1 panic

Thanks for the info. Can all this be done by booting from the Arch CD, mounting the system root, and issuing the command

pacman -S abs base-devel

I ask because when I try to install anything from the group base-devel, I get errors of this kind

warning: could not get filesystem information for /bootmnt: no such file or directory

same warnings for /cowspace, /sfs/root-image, /sfs/lib-modules, etc.

Am I missing something?

Offline

#15 2012-04-21 16:23:16

jfree143dev
Member
Registered: 2011-04-16
Posts: 6

Re: kernel 3.3.1 panic

This is probably what you're looking for:
https://wiki.archlinux.org/index.php/Change_Root

Offline

#16 2012-04-21 16:39:16

darkmav
Member
Registered: 2012-01-21
Posts: 73

Re: kernel 3.3.1 panic

jfree143dev wrote:

This is probably what you're looking for:
https://wiki.archlinux.org/index.php/Change_Root

I know how to change root, this is precisely the procedure I adopted.

I get the same error messages as before :-(

Offline

#17 2012-04-21 21:46:27

darkmav
Member
Registered: 2012-01-21
Posts: 73

Re: kernel 3.3.1 panic

Okay, I managed to get rid of the chroot errors by deleting /etc/mtab, and then I installed abs.

Now, what does it mean by "First of all, you need a clean kernel to start your customization from. Fetch the kernel package files from ABS:

$ ABSROOT=. abs core/linux"

Source: https://wiki.archlinux.org/index.php/Ke … ild_System

Where does ABSROOT have to be set? I imagine it is in /etc/abs.conf but I see

[ "$ABSROOT" = "" ] && ABSROOT="/var/abs/"

already set in this file. Do I have to modify this? Could you please explain how the kernel has to be rebuilt to incorporate this patch...I am not sure I understand this.

EDIT: This is what I'm doing now

$ cd /var/abs/core/linux
$ MAKEFLAGS="-j4" makepkg --asroot
<Missing dependencies: xmlto, docbook-xsl>
$ pacman -S xmlto
$ pacman -S docbook-xsl
$ MAKEFLAGS="-j4" makepkg --asroot

It is downloading linux-3.3.tar.xz

Is this okay?

Last edited by darkmav (2012-04-21 21:52:33)

Offline

#18 2012-04-22 18:09:17

jfree143dev
Member
Registered: 2011-04-16
Posts: 6

Re: kernel 3.3.1 panic

You can use abs to download the entire Arch archive of builds scripts or just individual scripts.

To download the entire archive do this:
# abs
all the files will be located in /var/abs (which is what ABSROOT defaults to)

Individual scripts can be downloaded using a parameter to abs:
# abs core/linux
will download just the core/linux scripts to the /var/abs directory.

By doing 'ABSROOT=. abs core/linux', abs will now override the default directory of /var/abs and use the current directory instead.

In fact, that's how you can temporarily override all environment variables that a given command will use...that's what MAKEFLAGS is doing as well.

BTW, if you download to a directory that your user has write permissions to, then you won't have to run makepkg as root.

Last edited by jfree143dev (2012-04-22 18:10:16)

Offline

Board footer

Powered by FluxBB