You are not logged in.

#1 2012-06-07 17:24:14

mylux
Member
Registered: 2012-03-03
Posts: 17

[Solved] Can't use extra repository

Hello,
Anyone saw it before?
When I run

pacman -Sy

or

 pacman -Syy

Pacman downloads the database files from core and from community
It doesn't show anything about extra.

And when I try to install any package from extra it finds nothing.
I tried setting the SigLevel of the repositories to Never, adjust my mirrorlist and still got nothing to work.

Does anyone experienced this issue?
Thanks in advance.

Last edited by mylux (2012-07-17 23:42:31)

Offline

#2 2012-06-07 17:34:34

isacdaavid
Member
From: México
Registered: 2011-11-21
Posts: 76
Website

Re: [Solved] Can't use extra repository

Yes, me. I'm still figuring out a solution. Something might have gone bad in the last pacman upgrade, perhaps it has to do with the inclusion of trusted signatures on packages. I'm going to check /etc/pacman.conf

Offline

#3 2012-06-07 17:35:46

MinimalBoot
Member
Registered: 2012-05-01
Posts: 38

Re: [Solved] Can't use extra repository

Is extra enabled ( not commented out or missing ) in /etc/pacman.conf ?

Last edited by MinimalBoot (2012-06-07 17:36:27)

Offline

#4 2012-06-07 18:01:20

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,105

Re: [Solved] Can't use extra repository

I saw another thread which mentioned something about some mirrors having issues with the extra repo, and how all the packages were showing up as externally installed via pacman.

Maybe you are using some of the same mirrors. Try changing mirrors to see if the problem persists.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2012-06-07 18:22:20

isacdaavid
Member
From: México
Registered: 2011-11-21
Posts: 76
Website

Re: [Solved] Can't use extra repository

Inxsible wrote:

I saw another thread which mentioned something about some mirrors having issues with the extra repo, and how all the packages were showing up as externally installed via pacman.

Maybe you are using some of the same mirrors. Try changing mirrors to see if the problem persists.

That worked for me! I just commented out all the mirrors I had enabled in /etc/pacman.d/mirrorlist and uncommented some others, so pacman had to sync with new ones.

Offline

#6 2012-06-07 18:23:41

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,105

Re: [Solved] Can't use extra repository

Please mark as [SOLVED]


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#7 2012-06-08 19:55:54

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: [Solved] Can't use extra repository

I'm confused by this annoying problem.  It started for me after pacman upgrade and running the pacman-key commands.

These mirrors have no extra, but do have the other repos:
#Server = http://mirrors.kernel.org/archlinux/$repo/os/$arch
#Server = http://mirrors.us.kernel.org/archlinux/$repo/os/$arch

Yet, if you browse those URLs (i.e. start at http://mirrors.us.kernel.org/archlinux) you can find your way to the extra directories.  I don't see what's different about them vs the other repos.

I finally had luck using this mirror:
Server = http://mirrors.xmission.com/archlinux/$repo/os/$arch

Offline

#8 2012-06-09 10:13:19

akspecs
Member
Registered: 2012-02-11
Posts: 170

Re: [Solved] Can't use extra repository

More and more of these mirrors seem to be losing the extra repo.  This issue has come up a few times in the current day (and each time I would jump to a new mirror).

Offline

#9 2012-06-10 09:16:51

brandnewmath
Member
Registered: 2010-02-01
Posts: 14

Re: [Solved] Can't use extra repository

Indeed, even the one Dave Cohen says above that he eventually used is now showing this error for me. I also can't download large packages even from the [core] repository:

% sudo pacman -Syu --ignore filesystem && sudo pacman -S filesystem --force
:: Synchronizing package databases...
 core is up to date                         0.0   B  0.00B/s 00:00 [------------------------------------]   0%
 haskell is up to date
error: failed retrieving file 'extra.db' from mirrors.xmission.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed to update extra (download library error)
error: failed retrieving file 'community.db' from mirrors.xmission.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
error: failed to update community (download library error)
 multilib is up to date
:: Starting full system upgrade...
warning: filesystem: ignoring package upgrade (2012.2-5 => 2012.6-2)
resolving dependencies...
looking for inter-conflicts...

Targets (11):

Name               Old Version  New Version  Net Change  Download Size

bison              2.5-3        2.5.1-1      0.07 MiB                 
fakeroot           1.18.3-1     1.18.4-1     0.00 MiB                 
glibc              2.15-10      2.15-11      0.00 MiB         7.56 MiB
initscripts        2012.05.1-3  2012.06.1-1  -0.02 MiB                
krb5               1.10.1-3     1.10.2-1     0.00 MiB                 
linux              3.3.7-1      3.3.8-1      0.02 MiB        40.21 MiB
linux-api-headers  3.3.2-1      3.3.8-1      0.00 MiB                 
linux-headers      3.3.7-1      3.3.8-1      0.01 MiB         4.70 MiB
mkinitcpio         0.9.1-1      0.9.2-1      0.00 MiB                 
systemd-tools      184-2        185-1        0.01 MiB                 
wine               1.5.5-1      1.5.6-1      0.54 MiB        28.00 MiB

Total Download Size:    80.47 MiB
Total Installed Size:   388.34 MiB
Net Upgrade Size:       0.62 MiB

Proceed with installation? [Y/n] 
:: Retrieving packages from core...
error: failed retrieving file 'glibc-2.15-11-x86_64.pkg.tar.xz' from mirrors.xmission.com : The requested URL returned error: 404
warning: failed to retrieve some files from core
error: failed retrieving file 'linux-3.3.8-1-x86_64.pkg.tar.xz' from mirrors.xmission.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files from core
error: failed retrieving file 'linux-headers-3.3.8-1-x86_64.pkg.tar.xz' from mirrors.xmission.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files from core
:: Retrieving packages from multilib...
error: failed retrieving file 'wine-1.5.6-1-x86_64.pkg.tar.xz' from mirrors.xmission.com : Operation too slow. Less than 1024 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files from multilib
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

I can rule out the speed of my Internet connection being the 'Operation too slow' errors; speedtest.net just measured me at 92.28Mb/s down and 35.55Mb/s up from my current location. I also see those errors no matter what mirror I use.

Edited to update: I just got home from work and updating my home machine worked fine using my usual http://mirrors.kernel.org/archlinux/. Huh.

Last edited by brandnewmath (2012-06-10 13:37:53)


--
James

Offline

#10 2012-06-12 13:03:32

Kopfweh
Member
Registered: 2011-08-06
Posts: 73

Re: [Solved] Can't use extra repository

Lol, wtf? Sorry for exhuming this old thread, but I just experienced exactly the same porblem with the [community] repository! Uncommenting the line of the server that I used did it for me, too. I used:
Server = http://ftp-stud.hs-esslingen.de/pub/Mir … o/os/$arch
Is this a problem with that specific server?

edit:...I'm using the server again and it work's again. Just updated the databases for one time from another server...strange!

Last edited by Kopfweh (2012-06-12 13:05:13)

Offline

#11 2012-07-03 01:09:02

emphire
Member
From: Canada
Registered: 2007-03-21
Posts: 189

Re: [Solved] Can't use extra repository

I'm having the same issue with the community repo. I've tried several mirrors and they all seem to fizzle-out around 30%. Which mirror worked for you?

Offline

#12 2012-07-03 08:25:08

Gcool
Member
Registered: 2011-08-16
Posts: 1,456

Re: [Solved] Can't use extra repository

Have a look at the mirrorlist page and pick an up to date one.

As a side note. If you have the choice, also pick a http mirror over an ftp one (ftp mirrors have even been removed from pacman's mirrorlist recently).


Burninate!

Offline

Board footer

Powered by FluxBB