You are not logged in.

#1 2005-08-09 16:03:07

Registered: 2004-07-30
Posts: 109

[SOLVED] Ndiswrapper bcmwl5a and WPA

I'm trying to get my wireless network working. When I try to load ndiswrapper (modprobe ndiswrapper), then I get this in my kernel. log:

encryption modes supported: WEP

The module loads, but normally, I should also get WPA-PSK support. This is the hardware and software I'm using:

#> lspci

02:03.0 Network controller: Broadcom Corporation: Unknown device 4320 (rev 03)

#> lshwd   ( more info big_smile )

02:03.0 Network controller: Broadcom Corp.|BCM94306 802.11g NIC (unknown)

It's a built-in card of a Dell Inspiron 9100 laptop. Knowing this, I searched the net and found that I could use ndiswrapper for this card, together with the windows drivers: bcmwl5 or bcmwl5a. Searching this forum and wiki, I found out that the latter is the good one to use, so I did it. Let's see what we've got:

#> pacman -Q ndiswrapper

ndiswrapper 1.2-2

#> pacman -Q ndiswrapper-bcmwl5a

ndiswrapper-bcmwl5a 0.2-1

#> ndiswrapper -l

Installed ndis drivers:
bcmwl5a driver present, hardware present

#> uname -r


I tried WEP with another router than mine, and that seemed to work, but my router uses WPA encryption and also the router at school uses WPA. Therefor, I compiled and installed wpa_supplicant:

#> pacman -Q wpa_supplicant

wpa_supplicant 0.3.9-1

I ran wpa_supplicant in debug-mode and obviously, it didn't work because the driver doesn't support WPA encryption. Now you could say: why do you ask for it then, it isn't even supported by ndiswrapper?! My answer is: I'm sure there should be WPA support from ndiswrapper, because I once got the message "encryption modes supported: WEP, WPA-PSK, blablabla, etc..." but I re-installed my system and I don't find the working software versions anymore. Secondly, on the site of ndiswrapper, they mention WPA support for my hardware and in every example I have seen on the web, I saw WPA support in kernel.log after modprobe-ing.

Anyway, now you know what the problem is, and what software I have, but this is how I try to get things to work (wel... that's what I try at least big_smile).

#> modprobe ndiswrapper
#> dmesg | tail

ndiswrapper version 1.2 loaded (preempt=yes,smp=yes)
ndiswrapper: driver bcmwl5a (Broadcom,10/28/2003, loaded
ACPI: PCI Interrupt 0000:02:03.0[A] -> GSI 17 (level, low) -> IRQ 17
ndiswrapper: using irq 17
wlan0: ndiswrapper ethernet device 00:0b:7d:0e:80:5a using driver bcmwl5a, configuration file 14E4:4320.5.conf
wlan0: encryption modes supported: WEP

Damn, there's the message again!

#>iwconfig wlan0

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:00:00:00:00:00   
          Bit Rate:54 Mb/s   Tx-Power:25 dBm   
          RTS thr:2347 B   Fragment thr:2346 B   
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

#> ifconfig wlan0

wlan0     Link encap:Ethernet  HWaddr 00:0B:7D:0E:80:5A  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

My router (USR8054) gives the IP with DHCP to wlan0 (client).
If you need anything else (config files, log messages, etc...) just say it. smile


#2 2005-08-10 15:27:48

Registered: 2004-07-30
Posts: 109

Re: [SOLVED] Ndiswrapper bcmwl5a and WPA

I found out what the problem was. If I scanned for networks, I couldn't find the router, it returned: no scanning results or something like that.

I found on the ndiswrapper website (wiki) that this problem exists because I possibly didn't enable the wifi card. They were right. I had to press fn+F2 to turn it on (hardware). If I then modprobe-ed ndiswrapper, I saw WPA support. w00t! 8)  big_smile

So to anyone with this problem: turn on the radio on your wireless card before doing anything. lol


#3 2005-08-10 15:30:02

Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879

Re: [SOLVED] Ndiswrapper bcmwl5a and WPA

Cobra wrote:

So to anyone with this problem: turn on the radio on your wireless card before doing anything. lol

Be careful with that though - on my laptop, modprobing ndiswrapper actually turns the card on (the light comes on) - if I hit the button, it segfaults the kernel.  I can turn it off when it's on and it works fine, but trying to turn it on brings it down fast, heh.


#4 2005-08-10 16:37:24

Registered: 2004-07-30
Posts: 109

Re: [SOLVED] Ndiswrapper bcmwl5a and WPA

Modprobing also turns my card on with WEP support, but nothing works and somehow, the radio isn't enabled... (I have no led to see if the radio is on or off sad ) I actually have to enable the radio with that BIOS hotkey (fn+f2) and after that I can use WPA etc after modprobing...


Board footer

Powered by FluxBB