You are not logged in.

#1 2005-08-09 17:23:44

From: Slovenia
Registered: 2005-04-18
Posts: 35

suspend2 + fglrx [SOLVED]

i just wonder if anyone got suspend2+fglrx working.

when using radeon, suspend2 works marvelous but i haven't got any luck with fglrx so far.
however, according to for example, i compiled vbetool (well, the latest version 0.3 by debian ) and i removed comment at "EnableVbetool yes" in /etc/hibernate/hibernate.conf. still, X only displays garbaged image and the system is frozen. any ideas?

it _does_ work. what i did:
1. switch to a virtual terminal and:

vbetool vbestate save > /tmp/vbestate
vbetool post
vbetool vbestate < /tmp/vbestate

3. back to ctrl-f7

nota bene:
- the first step is mandatory.
- all this could probably be omitted by uncommenting vbetool lines in /etc/hibernate/hibernate.conf. however, it didn't work for me.
- worked using vanilla and fglrx-8.16.20.
- also works with vanilla 2.6.13+swsusp2.6.13-rc7 (but swsusp doesn't work properly - power stays on... have to wait a couple of days)
- vbetool 0.2 (there is an entry in AUR as well)


Board footer

Powered by FluxBB