You are not logged in.

#1 2012-08-04 14:35:13

ArchIsCool
Member
Registered: 2012-08-04
Posts: 19

[SOLVED]Cannot open consolekit

Hi,

I have just installed a new ArchLinux and KDE on my PC. When I boot it, the normal KDE Login-Screen appears, after typing my password in and pressing return it shows this warning:

Warning: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 127

When I click ok, the usual loading screen appears and the harddrive-icon is shown, but then KDE crashes with showing the details:

Executeable: kdeinit 4 PID: 782 Signal: Segmentation fault(11)

/var/log/kdm.log sais:

[...]
klauncher(722) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(715)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"

kdmgreet(715)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
arguments to ck_connector_get_cookie() were incorrect, assertion "connector != NULL" failed in file ck-connector.c line 583.

(process:715): GLib-CRITICAL **: g_main_context_pop_thread_default: assertion `g_queue_peek_head (stack) == context' failed


But dbus is actually started through daemon array.
And /var/log/everything.log sais:

[...]
Aug  4 19:14:06 myhost kdm_greet[892]: Cannot load /usr/share/apps/kdm/faces/.default.face: No such file or directory
Aug  4 19:14:08 myhost dbus[597]: [system] Activating service name='org.freedesktop.ConsoleKit' (using servicehelper)
Aug  4 19:14:08 myhost dbus[597]: [system] Activated service 'org.freedesktop.ConsoleKit' failed: Launch helper exited with unknown return code 127
Aug  4 19:14:08 myhost kdm: :0[891]: Cannot open ConsoleKit session: Unable to open session: Launch helper exited with unknown return code 127
Aug  4 19:14:14 myhost kernel: [ 1837.870288] ksmserver[967]: segfault at 6bf656 ip 00000000006bf656 sp 00007fff91c5a548 error 14
Aug  4 19:14:14 myhost kernel: [ 1838.054796] kded4[963]: segfault at b920 ip 000000000000b920 sp 00007fff91c58db8 error 14 in kdeinit4[400000+c000]

Could you please tell me, what is going wrong here?

Last edited by ArchIsCool (2012-08-04 17:39:21)

Offline

#2 2012-08-04 15:09:35

kaszak696
Member
Registered: 2009-05-26
Posts: 543

Re: [SOLVED]Cannot open consolekit

Does Dbus start without any errors? Try to start/restart it manually.


'What can be asserted without evidence can also be dismissed without evidence.' - Christopher Hitchens
'There's no such thing as addiction, there's only things that you enjoy doing more than life.' - Doug Stanhope
GitHub Junkyard

Offline

#3 2012-08-04 15:14:35

ArchIsCool
Member
Registered: 2012-08-04
Posts: 19

Re: [SOLVED]Cannot open consolekit

DBus is starting and stopping without messages, everything actually seems correct, but the error is remaining

Last edited by ArchIsCool (2012-08-04 15:15:15)

Offline

#4 2012-08-04 15:19:10

ataraxia
Member
From: Pittsburgh
Registered: 2007-05-06
Posts: 1,552

Re: [SOLVED]Cannot open consolekit

Keep in mind that there are two DBus processes (or at least there should be):

- The system bus, started from rc.conf (or by systemd, if you use that). This is the one running as root.
- The session bus, started (in your case) by KDM when you log in. This one runs as your own user.

The error refers to the "session" bus. It makes sense that these other KDE components would crash without that running. It's mysterious to me why it wouldn't start up as usual when you log in.

Offline

#6 2012-08-04 16:57:50

ArchIsCool
Member
Registered: 2012-08-04
Posts: 19

Re: [SOLVED]Cannot open consolekit

Now I uninstalled phonon-vlc (and vlc) and changed from starting as daemon to starting with inittab, but the error remains

Offline

#7 2012-08-04 17:36:19

ArchIsCool
Member
Registered: 2012-08-04
Posts: 19

Re: [SOLVED]Cannot open consolekit

Well... I simply made a full system update (I installed the system the day before yesterday!!!)  with a bit complications and now it works.

Thanks anyway

Offline

Board footer

Powered by FluxBB