You are not logged in.

#1 2005-09-04 18:31:54

kyle.tk
Member
Registered: 2005-05-17
Posts: 13

tftp server

I am having a lot of trouble getting my tftp server to work. I am not even able to get files from myself. It always times out.
I have made a directory /var/tftpboot and put my files in it.
I added tftp: all allow to my hosts.allow.
I start tftpd and then try to get the file.

It still fails

Any advice.

Offline

#2 2005-09-04 20:09:41

Euphoric Nightmare
Member
From: Kentucky
Registered: 2005-05-02
Posts: 283

Re: tftp server

Have you ever had it working in the past??

My question is, did it just now break? or are you setting it up for the first time?

Offline

#3 2005-09-04 20:35:19

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: tftp server

hi! your supposed to put in.tftpd:all in your hosts.allow. i setup tftpd before and had this problem.

Offline

#4 2005-09-04 21:18:01

kyle.tk
Member
Registered: 2005-05-17
Posts: 13

Re: tftp server

ill try the  in.tftp in my hosts.allow

and yes this is my first time trying to set it up

Offline

#5 2005-09-04 21:23:06

kyle.tk
Member
Registered: 2005-05-17
Posts: 13

Re: tftp server

alright so I put in.tftp: all allow in hosts.allow

log still showed connection denied from xx.xx.xx.xx so I commented out the ALL: deny: deny line in hosts.deny. Then it started working. So what would be the proper syntax in hosts.allow to allow this without allowing everything

Offline

#6 2005-09-04 21:24:00

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: tftp server

not in.tftp its in.tftpd:all you forgot the d

Offline

#7 2005-09-04 22:54:52

kyle.tk
Member
Registered: 2005-05-17
Posts: 13

Re: tftp server

damn, i knew it was something small like that. Thanks for your help.

Offline

#8 2005-09-04 23:03:15

syamajala
Member
From: here, there, everywhere
Registered: 2005-01-25
Posts: 604
Website

Re: tftp server

yep, actually i was wondering if you could give me a hand. i just setup another diskless server/client thing and i'm having problems. this is what happens when i boot the client

Root-NFS: Server returned error -93 while mounting /netboot/diskless1
VFS: Unable to mount root fs via NFS, trying floppy.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

here is the dhcpd.conf

# DHCP configuration file for DHCP ISC 3.0
 
ddns-update-style none;
 
subnet 192.168.0.0 netmask 255.255.255.0 {
 
  pool {
    max-lease-time 86400;
    default-lease-time 86400;
    deny unknown clients;
    range 192.168.0.6 192.168.0.7;
}

  group {
        next-server 192.168.0.5;
        filename "/pxelinux.0";
        option domain-name-servers 192.168.0.1;
        option routers 192.168.0.1;

  host diskless1.genesis.blogdns.net {
       hardware ethernet                00:11:09:ba:0d:90;
       fixed-address                    192.168.0.6;
       option host-name                 "diskless1.genesis.blogdns.net";
       option root-path                 "/netboot/diskless1";
                }
        }
} 

and the pxelinux.cfg file

DEFAULT bzImage
APPEND ip=dhcp root=/dev/nfs nfsroot=192.168.0.5:/netboot/diskless1  

also i'm using atftpd and i started it like this

atftpd --daemon --logfile /var/log/atftpd.log --user nobody.nobody /netboot   

notice anything wrong? i've been trying to figure out whats wrong for the past few days but everything looks fine to me.

Offline

Board footer

Powered by FluxBB