You are not logged in.

#1 2012-10-12 21:23:47

Registered: 2011-04-10
Posts: 26

Problems with NetworkManager and new wireless networks.

I have a problem with NetworkManager, that I haven't had before, but I'm not sure when the problems started. I have a Samsung NC10 netbook and the wireless networking has been working flawlessly for several years. Recently I was at a friends house and was trying to connect to his WLAN with no success. When I click the WLAN name in nm-applet, it immediatly gives me a popup saying:

The network connection has been disconnected.

I have been trying with several other wlans with the same error. The thing is that it connects flawlessly to every WLAN that I have used before and is set to auto-connect in the nm-applet settings. I tried to remove my home network from the list (Edit Connections>Wireless>Delete) and now I can't connect to that one either. Since I mostly use networks that I have used before (and therefor are saved in the autoconnect list) I don't know how long the "connect to a new network"-error has been there. I have off course tried restarting the NetworkManager.service (I use systemd) and even the system itself.

I also have wicd installed and when I use that service instead of NetworkManager I can connect to any network (with wicd-curses), but I like NetworkManager better and I also use 3G modems from time to time that wicd can't handle.

How would I go about to solve this, I can't even find any logs for NetworkManager to search for errors in.

Edit: I have been reading a bit and it may have to do with permissions since I'm not root and I'm not running the nm-applet in Gnome (I use awesome). The awesome wiki says you have to add your user to the netdev group, but I don't even have a group with that name.

Last edited by mindglowba7fb830d2cbbed73 (2012-10-13 01:31:19)


#2 2013-01-07 01:54:06

From: Serbia
Registered: 2006-10-31
Posts: 759

Re: Problems with NetworkManager and new wireless networks.

I ran into this very issue just now, and my workaround is to "Connect to hidden wireless network". From there it connects as usual.

As for netdev group, you can add it with the groupadd command, and then add yourself to that group. I'm pretty sure I've never had to do that. I've tried adding myself to network group, but that also didn't help.


Board footer

Powered by FluxBB