You are not logged in.

#1 2012-10-30 22:56:40

Eit
Member
From: Italy
Registered: 2010-01-22
Posts: 57

r8169 messages at boot

Hi,

I've been constantly having 4 messages showing up during boot phase like this:

[    11.243332] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).

I usually boot without eth0 connected, but wired connection works.

I've googled a bit but I couldn't find any clear answer hmm

Offline

#2 2012-10-30 23:02:30

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: r8169 messages at boot

What is the output of

$ lspci | grep -i net 

The amount of information you have provided is pretty poor.  Please try again if you want a real answer.

Offline

#3 2012-10-30 23:20:28

Eit
Member
From: Italy
Registered: 2010-01-22
Posts: 57

Re: r8169 messages at boot

You're right, I'm very sorry but I couldn't figure out what could help in solving the problem because actually I don't have any functional problem, yet...I'm still not sure that actually something is wrong...

the output is

 lspci | grep -i net
07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
13:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

I add this, maybe it can help

dmesg | grep eth0
[    5.662236] r8169 0000:13:00.0: eth0: RTL8168e/8111e at 0xffffc90000668000, 78:84:3c:ec:c3:b4, XID 0c200000 IRQ 44
[    5.662238] r8169 0000:13:00.0: eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   10.943068] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.943882] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.944587] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.945296] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.948333] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.949109] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.949663] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   10.950378] r8169 0000:13:00.0: eth0: rtl_phyar_cond == 1 (loop: 20, delay: 25).
[   19.308645] r8169 0000:13:00.0: eth0: link down
[   19.308724] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   23.082842] r8169 0000:13:00.0: eth0: link down
[   23.082885] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Offline

#4 2012-10-31 11:41:26

Eit
Member
From: Italy
Registered: 2010-01-22
Posts: 57

Re: r8169 messages at boot

Sry for double post, but I found out that disabling the laptop-mode daemon in rc.conf stopped the messages...in the laptop-mode.conf file I don't see anything related to ethernet setting, except when it lists all the "zero configuration" modules that laptop-mode loads...

Offline

#5 2012-10-31 14:07:43

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: r8169 messages at boot

I am unsure with rev6, but I have the same ethernet card but rev9.  I needed the r8168 package.  It is the realtek kernel module.  Without it, my computer would sometimes not really be connected all that well.  For instance, on one attempt at installing Arch when the computer was new, I killed the install after two hours of installing base.  After realizing I needed the r8168 module, it took the ~5 minutes it should take on my connection speed.

Edit: According to my pacman.log, it took two minutes for base and base-devel.

Last edited by WonderWoofy (2012-10-31 14:09:48)

Offline

#6 2012-10-31 15:59:02

Eit
Member
From: Italy
Registered: 2010-01-22
Posts: 57

Re: r8169 messages at boot

WonderWoofy wrote:

I am unsure with rev6, but I have the same ethernet card but rev9.  I needed the r8168 package.  It is the realtek kernel module.  Without it, my computer would sometimes not really be connected all that well.  For instance, on one attempt at installing Arch when the computer was new, I killed the install after two hours of installing base.  After realizing I needed the r8168 module, it took the ~5 minutes it should take on my connection speed.

Edit: According to my pacman.log, it took two minutes for base and base-devel.

I've the realtek module r8169 installed (ofc installing the r8168 gives conflict), still I think it's a laptop-mode problem...

Offline

#7 2012-11-07 23:03:30

makey
Member
Registered: 2012-11-03
Posts: 20

Re: r8169 messages at boot

I have exactly the same ethernet card as you and I was also seeing these 4 messages during boot. I configured laptop mode as said on the wiki,look at the ethernet part. Messages don't appear any more. Hope it helps

Offline

Board footer

Powered by FluxBB