You are not logged in.

#1 2012-11-03 12:44:56

Greed1sGood
Member
Registered: 2012-02-11
Posts: 41

[SOLVED][GNOME 3.6] Keyboard layout toggle

After upgrading to gnome 3.6 the keyboard layout toggle shortcut key (alt+shift in my case) stopped working.

1. When I try to set the shortcyt through gnome gui (keyboard->Shortcuts->Typing) alt+shift is not registered. (but strangely enough any other combination is ok)
2. Tried to set the shortcut using xkb

/etc/X11/xorg.conf.d/01-keyboard-layout.conf

3. Tried setting the shortcut using the dconf editor

org.gnome.libgnomekbd.keyboard

None of these methods worked, any suggestions?

Last edited by Greed1sGood (2012-11-04 20:24:37)

Offline

#2 2012-11-03 15:59:44

doman18
Member
Registered: 2012-11-03
Posts: 9

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

It seems like some other action is binded to that combination or even more than one. Or maybe you have some keyboard layout that overwrites it? In my case (polish layout) Alt+shift means upper, diacrytic letters.

Last edited by doman18 (2012-11-03 16:01:11)

Offline

#3 2012-11-03 16:20:26

Greed1sGood
Member
Registered: 2012-02-11
Posts: 41

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

doman18 wrote:

It seems like some other action is binded to that combination or even more than one. Or maybe you have some keyboard layout that overwrites it? In my case (polish layout) Alt+shift means upper, diacrytic letters.

That was exactly my initial guess, but I've double checked the existing keybindings and alt+shift is not used by any of them, so I have no idea why is this happening.

Offline

#4 2012-11-03 16:37:56

doman18
Member
Registered: 2012-11-03
Posts: 9

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

Then i cant help because im on lxde and things here are a little bit diffrent (simpler). The only thing i can say that i had similar problem on debian long time ago. I couldnt get my additional media keys work in lxde so the simplest solution i found is installing xbindkeys program. Installed, downloaded some script for key recognizing, tried what is the code of every media key, put some simplest commands script for players , put xbindkeys in autostart and it worked like a charm for long time. Until after some upgrade stopped.  After long researchs i found that someone finally put those bindings in LXDE and they starting to conflict with xbindkeys bindings. Removing xbindkeys was a solution for me.

Offline

#5 2012-11-03 20:44:43

ikatson
Member
Registered: 2012-08-14
Posts: 4

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

As for the "alt-shift" combination in particular, you can set it through gnome-tweak-tool

I posted a more radical solution to that kind of problems here https://bbs.archlinux.org/viewtopic.php … 0#p1186590

Offline

#6 2012-11-03 22:42:02

YavkatA
Member
Registered: 2011-07-30
Posts: 12

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

Another, possibly easier way to fix this:

gsettings set org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher alt-shift

Offline

#7 2012-11-04 20:20:31

Greed1sGood
Member
Registered: 2012-02-11
Posts: 41

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

I've sort of solved it:

system settings -> keyboard -> shortcuts

1. set "switch to next source" to disabled .
2. set "switch to previous source" to disabled

in dconf editor go to org->gnome->desktop->input-sources
1. set the xkb options to

['grp:alt_shift_toggle']

The problem with this solution is that the language indicator in the taskbar is not changed when you change the keyboard layout, but that doesn't really bother me.

Last edited by Greed1sGood (2012-11-04 20:26:03)

Offline

#8 2012-12-28 22:44:46

mfaridi
Member
Registered: 2010-12-15
Posts: 191

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

I have this peroblem too but this guide

system settings -> keyboard -> shortcuts1. set "switch to next source" to disabled .
2. set "switch to previous source" to disabled in dconf editor go to org->gnome->desktop->input-sources
1. set the xkb options to ['grp:alt_shift_toggle']


can not help me
what I must do ?

my  gnome is up to date and I use last
gnome

Last edited by mfaridi (2012-12-28 22:48:58)

Offline

#9 2012-12-29 20:48:00

mfaridi
Member
Registered: 2010-12-15
Posts: 191

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

can I do this wih xorg.conf

Offline

#10 2012-12-29 20:53:44

Greed1sGood
Member
Registered: 2012-02-11
Posts: 41

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

Actually a couple of days ago I've found what I was looking for:
gnome-tweak-tool -> Typing -> Modifiers-only input sources -> select Alt-shift

So you don't have to use Xorg.conf

Last edited by Greed1sGood (2012-12-29 20:54:38)

Offline

#11 2013-03-29 17:42:50

rulet
Member
Registered: 2010-11-23
Posts: 18

Re: [SOLVED][GNOME 3.6] Keyboard layout toggle

How to set it on right win key?

Offline

Board footer

Powered by FluxBB