You are not logged in.

#1 2012-11-20 20:40:31

nixIT
Member
Registered: 2010-01-13
Posts: 396

[CLOSED] mount smb share gives error

Hello all,

Just did a fresh install of linux yesterday from the current ISO.  Everything seemed to go ok, a couple issues I'm working through.

I installed (I think) all related samba files per the wiki, and when I go to mount a share on my NAS:

mount -t cifs //srvnas/movies /mnt/movies -o user=nixit,password=!pa55w0rd

I receive the following error:

-bash: !pa55w0rd: event not found

is this because my password has a ! in it?  I've had this password for a while, and it worked before my reinstall, or am I missing something?

if I mount this way:

mount -t cifs //srvnas/movies /mnt/movies -o user=nixit

I am prompted for my password and all works.

I even tried putting the mount command in my fstab file, with my username/pw in a credential file, I don't get any errors, but the folders are not mounted.

--nixIT

Last edited by nixIT (2012-11-30 23:46:22)


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

Board footer

Powered by FluxBB