You are not logged in.

#1 2012-11-24 10:52:11

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

[solved] ifplugd; systemd, net-auto-wired: annoying beep

Hello everyone!

I experience annoying pc speaker beeps whenever the net-auto-wired service is getting started or stopped, e.g. on every boot or shutdown.
I've already tried various ways to mute the pc speaker:

  • "xset -b" in ~/.xinitrc

  • blacklisting pcspkr module

  • "setterm -blength 0" in /etc/profile

It doesn't work.

The following log corresponds to stopping and then re-starting the net-auto-wired service after having booted the system.

Nov 24 11:34:19 virtus sudo[2298]: freddy : TTY=pts/0 ; PWD=/home/freddy ; USER=root ; COMMAND=/usr/bin/systemctl stop net-auto-wired.service
Nov 24 11:34:19 virtus sudo[2298]: pam_unix(sudo:session): session opened for user root by (uid=0)
Nov 24 11:34:19 virtus systemd[1]: Stopping Provides automatic netcfg wired connection...
Nov 24 11:34:19 virtus dhcpcd[2320]: sending signal 1 to pid 1819
Nov 24 11:34:19 virtus dhcpcd[1819]: received SIGHUP, releasing
Nov 24 11:34:19 virtus dhcpcd[1819]: eth0: releasing lease of 85.170.167.0
Nov 24 11:34:19 virtus dhcpcd[2320]: waiting for pid 1819 to exit
Nov 24 11:34:19 virtus dhcpcd[1819]: eth0: removing interface
Nov 24 11:34:19 virtus netcfg[2301]: :: ethernet-dhcp down [done]
Nov 24 11:34:20 virtus kernel: e1000e 0000:00:19.0: irq 47 for MSI/MSI-X
Nov 24 11:34:20 virtus ifplugd[1675]: Link beat lost.
Nov 24 11:34:20 virtus kernel: e1000e 0000:00:19.0: irq 47 for MSI/MSI-X
Nov 24 11:34:20 virtus ifplugd[1675]: Executing '/etc/ifplugd/netcfg.action eth0 down'.
Nov 24 11:34:20 virtus ifplugd[1675]: Program execution failed, return value is 1.
Nov 24 11:34:20 virtus ifplugd[1675]: Exiting.
Nov 24 11:34:20 virtus systemd[1]: Stopped Provides automatic netcfg wired connection.
Nov 24 11:34:20 virtus sudo[2298]: pam_unix(sudo:session): session closed for user root
Nov 24 11:34:21 virtus kernel: e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
Nov 24 11:34:21 virtus kernel: e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
Nov 24 11:34:23 virtus sudo[2365]: freddy : TTY=pts/0 ; PWD=/home/freddy ; USER=root ; COMMAND=/usr/bin/journalctl
Nov 24 11:34:23 virtus sudo[2365]: pam_unix(sudo:session): session opened for user root by (uid=0)
Nov 24 11:35:58 virtus sudo[2365]: pam_unix(sudo:session): session closed for user root
Nov 24 11:36:03 virtus sudo[2469]: freddy : TTY=pts/0 ; PWD=/home/freddy ; USER=root ; COMMAND=/usr/bin/systemctl start net-auto-wired.service
Nov 24 11:36:03 virtus sudo[2469]: pam_unix(sudo:session): session opened for user root by (uid=0)
Nov 24 11:36:03 virtus systemd[1]: Starting Provides automatic netcfg wired connection...
Nov 24 11:36:03 virtus systemd[1]: Started Provides automatic netcfg wired connection.
Nov 24 11:36:03 virtus sudo[2469]: pam_unix(sudo:session): session closed for user root
Nov 24 11:36:03 virtus ifplugd[2472]: ifplugd 0.28 initializing.
Nov 24 11:36:03 virtus ifplugd[2472]: Using interface eth0/00:1C:25:9F:3E:24 with driver <e1000e> (version: 2.0.0-k)
Nov 24 11:36:03 virtus ifplugd[2472]: Using detection mode: SIOCETHTOOL
Nov 24 11:36:03 virtus ifplugd[2472]: Initialization complete, link beat detected.
Nov 24 11:36:03 virtus ifplugd[2472]: Executing '/etc/ifplugd/netcfg.action eth0 up'.
Nov 24 11:36:03 virtus ifplugd[2472]: client: up
Nov 24 11:36:03 virtus ifplugd[2472]: client: loading wireless-profile1
Nov 24 11:36:03 virtus ifplugd[2472]: client: loading wireless-profile2
Nov 24 11:36:03 virtus ifplugd[2472]: client: loading ethernet-dhcp
Nov 24 11:36:03 virtus dhcpcd[2505]: version 5.6.3 starting
Nov 24 11:36:03 virtus dhcpcd[2505]: all: configured as a router, not a host
Nov 24 11:36:03 virtus dhcpcd[2505]: eth0: broadcasting for a lease
Nov 24 11:36:04 virtus dhcpcd[2505]: eth0: offered 85.170.167.0 from 212.198.0.161
Nov 24 11:36:04 virtus dhcpcd[2505]: eth0: ignoring offer of 85.170.167.70 from 212.198.0.162
Nov 24 11:36:04 virtus dhcpcd[2505]: eth0: acknowledged 85.170.167.0 from 212.198.0.161
Nov 24 11:36:04 virtus dhcpcd[2505]: eth0: checking for 85.170.167.0
Nov 24 11:36:10 virtus dhcpcd[2505]: eth0: leased 85.170.167.0 for 14400 seconds
Nov 24 11:36:10 virtus dhcpcd[2505]: forked to background, child pid 2603
Nov 24 11:36:10 virtus ifplugd[2472]: client: :: ethernet-dhcp up [done]
Nov 24 11:36:10 virtus ifplugd[2472]: Program executed successfully.

This did not happen before using systemd, everything was fine back then.

Any ideas? Thanks!

Edit: Hardware is Lenovo T400.

Last edited by ball (2013-01-23 22:45:20)

Offline

#2 2012-12-18 17:19:49

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

[Sorry for the bump,  but I fear that nobody will recognize my edit...]

I made an interesting discovery: What is beeping is NOT the pc speaker. I realized that after manually loading the pcspkr module and beeping via echo -e "\a" or via the beep program provided by the package beep: the pc speaker beep sounds completely different from the beeps I have to hear on boot/shutdown, which are a much higher and therefore much more annoying tones.

I realized that the system beeps once whenever I detach my LAN cable, and beeps twice when I attach the cable back again. On re-attaching the first beep sounds immediately and the second beep sounds presumably after getting an IP address.

However, as a workaround to this problem muting alsa seems reasonable. How can alsa be configured to be muted on boot? Now it boots with 100% volume...

Any hints on resolving the problem or getting the workaround to work are vigorously appreciated! (Btw. my system is up to date)

Offline

#3 2012-12-18 18:06:13

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

Alsa? so the sound comes out of your sound card? I'm not sure how net-auto-wired got configured to play a sound file on those events.
I would think is the physical lan card making such noise on its own speaker.

Anyway, run alsamixer, mute all and then execute alsactl store to save the changes. reboot your system and check if it works.

If it does not works, turn off/unplug your speakers and try again. That way you can be sure if it comes out of your sound card.


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

#4 2012-12-18 20:07:35

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

chris_l wrote:

Alsa? so the sound comes out of your sound card? I'm not sure how net-auto-wired got configured to play a sound file on those events.
I would think is the physical lan card making such noise on its own speaker.

Yes indeed, the sound comes out of the sound card: when sound is muted I can't hear any beeps on boot/shutdown.

alsactl store worked, now I'm at least able to boot muted and don't have my day started with this ugly sound.

But the problem itself stays unresolved...

Last edited by ball (2012-12-18 20:13:53)

Offline

#5 2012-12-19 15:54:58

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

Then I guess the first step would be to reenable sound, disable net-auto-wired, and reboot to check if the sound still there. If it is, then is not that daemon the one causing the problem. Reenable net-auto-wired, and try another one until you find which one cause it.


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

#6 2012-12-22 12:45:34

sie
Member
Registered: 2010-06-30
Posts: 29

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

it's actually ifplugd that makes the beep, not the net-auto-wired daemon directly. _man ifplugd_ suggests that we should add -b to get rid of the beeps, therefore:

# locate net-auto-wired           
/etc/rc.d/net-auto-wired
/lib/systemd/system/net-auto-wired.service # We need this one
# vim /lib/systemd/system/net-auto-wired.service # Add -b to all ifplugd calls.
# systemctl --system daemon-reload
# systemctl restart net-auto-wired

And voila no fscking annoying beeps! I was suffering them for about two months until I decided to fix it.


a &

Offline

#7 2013-01-06 14:08:33

TheRatze94
Member
Registered: 2012-07-01
Posts: 33

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

Thank you very much sie !

I thought i'd never get rid of this annoying beeb.

Thanks,thanks,thanks! big_smile

Offline

#8 2013-01-23 17:54:58

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

@sie: thank you very much! This is it! Silence, finally!

But instead of editing the .service file changing the ifplugd configuration is better IMHO. Otherwise the change won't survive an upgrade of netcfg. So I edited /etc/ifplugd/ifplugd.conf and added the "-b" flag to ARGS.

EDIT: I just realized that adding "-b" to the default ARGS of ifplugd does not have the desired effect, the problem persists. So why is this the case? Do the flags which are employed in the .service file bypass the default ifplugd configuration? Or is this my very own user misconception? I did RTFM, though...

Currently this is my /usr/lib/systemd/system/net-auto-wired.service:

[Unit]
Description=Provides automatic netcfg wired connection

[Service]
EnvironmentFile=/etc/conf.d/netcfg
ExecStart=/usr/bin/ifplugd -i $WIRED_INTERFACE -r /etc/ifplugd/netcfg.action -fIns -b
ExecStop=/usr/bin/netcfg iface-down $WIRED_INTERFACE

[Install]
WantedBy=multi-user.target

If this issue really has to be addressed in the .service file, we should file a bug report/feature request.

Last edited by ball (2013-01-23 18:13:13)

Offline

#9 2013-01-23 20:17:23

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

Normally preferences set on flags at runtime always overwrite preferences on config files, so if the flags on the service activate the sound is normal it ignores the config file. If thats the case (I dont suffer from that problem, so Idk), its not a bug.

However, since such default preference sounds annoying (literally), yeah, I'll say you should add a bug report on that.


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

#10 2013-01-23 21:22:10

hawaiicharles
Member
Registered: 2012-12-21
Posts: 71

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

This might not be applicable based on your needs, but in my experience, ifplugd doesn't need to be installed at all.  As I understand it, ifplugd makes things more convenient if you physically plug and unplug your network cable often (or if you're accessing different wi-fi connection points).  If your computer never moves from its location and has the network cable plugged in all the time, you can get by just fine without it.

Last edited by hawaiicharles (2013-01-23 21:25:35)

Offline

#11 2013-01-23 22:43:59

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [solved] ifplugd; systemd, net-auto-wired: annoying beep

hawaiicharles wrote:

If your computer never moves from its location and has the network cable plugged in all the time, you can get by just fine without it.

I run Arch on a laptop, so I need ifplugd...

I filed a bug report: https://bugs.archlinux.org/task/33538 -- marking this as solved.

Offline

Board footer

Powered by FluxBB