You are not logged in.

#1 2013-01-09 05:18:02

student975
Member
From: Russian Federation
Registered: 2011-03-05
Posts: 601

prosody auto-SIGTERMs - why?

This is a complete session - a fragment from prosody.log file (prosody.err is empty!):

Jan 09 08:54:52 general info    Hello and welcome to Prosody version 0.8.2
Jan 09 08:54:52 general info    Prosody is using the select backend for connection handling
Jan 09 08:54:52 nas:posix       info    Successfully daemonized to PID 14551
Jan 09 08:54:58 c2s175b5f0      info    Client connected
Jan 09 08:54:58 c2s175b5f0      info    Authenticated as andrew@nas
Jan 09 08:56:22 mod_posix       warn    Received SIGTERM
Jan 09 08:56:22 general info    Shutting down: Received SIGTERM
Jan 09 08:56:22 general info    Shutting down...
Jan 09 08:56:22 general info    Shutdown status: Cleaning up
Jan 09 08:56:22 general info    Shutdown status: Closing all active sessions
Jan 09 08:56:22 c2s175b5f0      info    Disconnecting client, <stream:error> is: <stream:error><system-shutdown xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Server is shutting down: Received SIGTERM</text></stream:error>
Jan 09 08:56:22 c2s175b5f0      info    Client disconnected: Server is shutting down: Received SIGTERM
Jan 09 08:56:22 c2s175b5f0      info    Destroying session for andrew@nas/8e1e68e9-f32c-492b-9488-89fa8aef082e (andrew@nas)
Jan 09 08:56:22 general info    Shutdown status: Closing all server connections
Jan 09 08:56:22 general info    Shutdown complete

You see, there was a successful loging in of 'andrew@nas' client.
The service was started with

systemctl start prosody

But console returned to a prompt only at the moment the service was SIGTERMed with the message (look at the next command also):

Job for prosody.service failed. See 'systemctl status prosody.service' and 'journalctl -xn' for details.
# systemctl status prosody
prosody.service - XMPP (Jabber) Server
          Loaded: loaded (/usr/lib/systemd/system/prosody.service; enabled)
          Active: failed (Result: timeout) since Wed, 2013-01-09 08:56:22 MSK; 7min ago
         Process: 14548 ExecStart=/usr/bin/prosodyctl start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/prosody.service

Jan 09 08:54:51 nas systemd[1]: Starting XMPP (Jabber) Server...
Jan 09 08:54:52 nas prosodyctl[14548]: Started
Jan 09 08:56:22 nas systemd[1]: Failed to start XMPP (Jabber) Server.
Jan 09 08:56:22 nas systemd[1]: Unit prosody.service entered failed state
 

- as if systemd is waiting for something, and then just terminates the service. How to cure??


"I exist" is the best myth I know..

Offline

#2 2013-05-25 12:40:17

tirom13
Member
Registered: 2013-05-25
Posts: 1

Re: prosody auto-SIGTERMs - why?

Hello !

I had the same problem.

For me it seems, that systemd except prosody to put a pid file at /run/prosody.
Thruth is that prosody is configured to put this pid file at /var/run/prosody

Systemd wait for a file at /run/prosody, but after some time it undersand that prosody isn't launch.

I just updated the file /etc/systemd/system/multi-user.target.wants/prosoy.service to correct that

Offline

#3 2013-05-25 12:48:15

student975
Member
From: Russian Federation
Registered: 2011-03-05
Posts: 601

Re: prosody auto-SIGTERMs - why?

tirom13 wrote:

Hello !

I had the same problem.

For me it seems, that systemd except prosody to put a pid file at /run/prosody.
Thruth is that prosody is configured to put this pid file at /var/run/prosody

Systemd wait for a file at /run/prosody, but after some time it undersand that prosody isn't launch.

I just updated the file /etc/systemd/system/multi-user.target.wants/prosoy.service to correct that

Would you, please, file an issue with your decision?


"I exist" is the best myth I know..

Offline

Board footer

Powered by FluxBB