You are not logged in.

#1 2013-01-17 13:53:23

Xwang
Member
Registered: 2012-05-14
Posts: 56

smbnetfs not working after reboot

Hi to all,
I've followed the steps in the wiki to have smb share automatically mounted in /mnt using smbnetfs.
It works in the session, but if I restart the pc it does not work any more until I use the following command:

sudo systemctl restart smbnetfs

After that it works till the following restart.
What is wrong in my configuration?
I use a full systemd system (no rc.conf)
Can you help me?
Thank you,
Xwang

Offline

#2 2013-01-17 15:46:05

satanselbow
Member
Registered: 2011-06-15
Posts: 530

Re: smbnetfs not working after reboot

Your answer is in plastered all over wiki... systemd might be a good place to start (try the 2nd paragraph - it's a goldmine!)

Offline

#3 2013-01-17 16:25:58

Xwang
Member
Registered: 2012-05-14
Posts: 56

Re: smbnetfs not working after reboot

I've seen the wiki again but I've not found any clue to solve my problem.
Can you please help me?

Offline

#4 2013-01-17 17:06:03

satanselbow
Member
Registered: 2011-06-15
Posts: 530

Re: smbnetfs not working after reboot

... Have you enabled the service to autostart at boot?

Using the "systemctl start <any.service>", or "restart", will not persist when you reboot. To "autostart" the service on boot you need to "enable" it.

# systemctl enable <any.service>

Offline

#5 2013-01-17 17:12:31

Xwang
Member
Registered: 2012-05-14
Posts: 56

Re: smbnetfs not working after reboot

Yes, I have.
The strange thing is that if I execute systemctl to see which services have been activated at boot time, smbnetfs is active, but opening a samba connection it does not mount it.
After executing systemctl restart smbnetfs (once in the session), it works properly.

Offline

Board footer

Powered by FluxBB