You are not logged in.

#1 2013-01-20 11:46:58

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 671

[SOLVED] Pulseaudio overwrites ALSA settings

Hi, in my system I have pulseaudio installed. When I log in, my laptop speakers are muted and set to volume 0. I have to launch alsamixer to unmute them and set the volume, then they work fine. But even if I save the settings with "sudo alsactl store", at next boot they are again muted and at volume 0. I noticed that pulseaudio is the culprit: after fixing the speakers' volume I kill the pulseaudio server with "pulseaudio --kill", it is automatically restarted by KDE (I think) and speakers are muted again.
I think that there is some speaker settings in pulseaudio config files, but I can't find where. Anyway, these settings are not accessible in kmix, so I can't set them and I'm forced to launch alsamixer every time I log in. Is there a way to set these pulseaudio bits or, even better, to make pulseaudio use the alsa config file (/var/lib/alsa/asound.state) to set the volumes?
Thanks.

Last edited by snack (2013-01-20 13:58:18)

Offline

#2 2013-01-20 12:29:23

roentgen
Member
Registered: 2011-03-15
Posts: 89

Re: [SOLVED] Pulseaudio overwrites ALSA settings

Check this thread for a solution.

Offline

#3 2013-01-20 13:57:51

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 671

Re: [SOLVED] Pulseaudio overwrites ALSA settings

Thanks roentgen, the patch works.

Offline

Board footer

Powered by FluxBB