You are not logged in.

#1 2013-01-26 21:38:31

From: Chicago, IL
Registered: 2011-06-23
Posts: 56

Cannot write to Samba share [SOLVED]

I've got a RAID server hosting a samba share that I tried to configure by hand and then tried to configure via webmin. Both methods have resulted in a share that mounts perfectly fine in Gnome, but that I cannot write to. I go to create a new folder and receive a permission denied error from Nautilus. Same goes for when I try to read a file from the share.

My server's /etc/samba/smb.conf reads as follows:

        read raw = no
        write raw = no
        server string = Whitebox
        socket options = TCP_NODELAY
        force directory mode = 0775
        workgroup = WORKGROUP
        force create mode = 0664
        create mask = 664
        directory mask = 0775
        hosts allow = 192.168.42.
        security = user

        read list = nobody,@nobody
        writeable = yes
        wide links = no
        write list = patrick,@users
        path = /mnt/share
        valid users = patrick,@users
        public = yes

I'm really not sure what's wrong here. Any help?

Last edited by musasabi (2013-01-26 21:52:49)


#2 2013-01-26 21:52:34

From: Chicago, IL
Registered: 2011-06-23
Posts: 56

Re: Cannot write to Samba share [SOLVED]

Nevermind~, haha.

Kinda helps to chown the share properly. It occurred to me when I su'd to myself after ssh-ing to the server and still couldn't create a file. Impressive how a layer of abstraction can confuse an otherwise decent understanding of the basics.

Now to make sure I can automount the share when the server boots and retain permissions.


Board footer

Powered by FluxBB