You are not logged in.

#1 2013-02-03 19:46:00

Registered: 2012-11-27
Posts: 100

netcfg and net-auto-wireless

Hi, I'm using netcfg to connect on internet with ifplugd and was doing good until I got another wireless connection..
So the problem is that netcfg doesn't connect to a profile when I log on, I need to run netcfg -a as root and then connect to a profile.
I believe it is because I have 2 profiles that it can connect to since I have 2 wireless connections with 2 profiles..the problem is solved when I delete one profile or move it but it's annoying because sometimes I want to switch to the other profile.
Is there a way to make netcfg connect to the strongest signal or to set priority or something so it connects to one of the 2 profile at boot. (I know in the conf file there is a line saying connect = (last) but it doesn't seem to work).

thank you.


#2 2013-02-17 11:53:33

Registered: 2012-06-06
Posts: 33

Re: netcfg and net-auto-wireless

Have you tried using the net-profiles method instead of net-auto-wireless? You can define the profiles which will be loaded at startup (The netcfg.service will, however, only be executed once at system startup):

NETWORKS=(mynetwork yournetwork)

I'm not perfectly sure what happens when both networks are available. The netcfg feature list says all network profiles are started in the specified order, so i guess you have to specify your profiles from lowest to highest priority for netcfg to connect to your preferred network at last. That seems to do its job, doesn't look like an optimal solution to me though.


#3 2013-02-17 15:37:38

Registered: 2006-12-16
Posts: 103

Re: netcfg and net-auto-wireless

I think it should work if you enable net-auto-wireless.service and disable netcfg.


#4 2013-02-17 18:58:30

From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: netcfg and net-auto-wireless

You mention net-auto-wireless and ifplugd. ifplugd is necessary for net-auto-wired, not wireless. For proper roaming support with netcfg/net-auto-wireless, you need wpa_actiond. You may also need rfkill installed if you are having trouble with your interfaces being brought up, but you made no mention of that so I think it is not the case.


Board footer

Powered by FluxBB