You are not logged in.

#1 2013-02-11 20:55:43

Gullible Jones
Registered: 2004-12-29
Posts: 4,863

NFS4: all files owned by nobody:nogroup on client [SOLVED]

I have an NFS4 share set up, and all is not well. On the server, I can locally mount the share somewhere, and all permissions will look correct:

# mount -t nfs <hostname>:/mnt/share /mnt/mountpoint
# ls -l /mnt/mountpoint
... user1 groupx ...
... user2 groupy ...

But on client machines, everything goes pear-shaped:

# ls -l
... nobody nogroup ...
... nobody nogroup ...

idmapd is running, appears to be configured sanely (it looks pretty much like the one on the Arch wiki), and indicates in its logs (with verbosity cranked way up) that it is in fact mapping various numeric UIDs to the correct names. I've tried tweaking the domain and Translation settings in /etc/idmapd.conf, followed by restarting idmapd, to no avail every time. Googling on the subject has turned up many people who solved this with things I've already tried; and more people who never managed to solve the problem.

What might I be missing? Is there a known fix for this, short of falling back on NFS3?

Edit: Solved. I had to export the filesystem with fsid=0. Looking at the man page, though, I'm not entirely sure why this worked, and would be interested if anyone could explain...

Last edited by Gullible Jones (2013-02-12 14:15:55)


Board footer

Powered by FluxBB