You are not logged in.

#1 2013-03-02 03:58:15

holland01
Member
Registered: 2011-12-22
Posts: 50

[SOLVED] Netflix Repo Key Issue

Whenever I reboot Arch, I always am greeted with the following message:

Import PGP key , "Jesus Alvarez <jeezusjr@gmail.com>", created 2012-10-23? [Y/n] y
error: key "Jesus Alvarez <jeezusjr@gmail.com>" could not be imported

Granted, it's not a huge deal since I can just press Y a few times and all is good. What is annoying though is the fact that this keeps happening, which means that I must have done something wrong.

Either way, I was curious if anyone has experienced these issues before. Since the SigLevel for archnetflix was originally set to Required, I decided to just change it to Optional TrustAll.

This actually helped in a sense, because it prevented this:

error: database 'archnetflix' is not valid (invalid or corrupted database (PGP signature))

from being voiced.

Any ideas on how to fix this?

Thanks.

Dump of Pacman.conf

 #
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#UseDelta
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
#SigLevel = Optional TrustedOnly

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[archnetflix]
# Packages for viewing Netflix through patched WINE.
# See http://demizerone.com/archnetflix
SigLevel = Required
#SigLevel = Optional TrustAll
Server = http://demizerone.com/$repo/community/$arch

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

[arch-fonts]
# Prebuilt packages for font packages found in AUR
# This should be faster than building from source
# as many have download speed of 10KB/s. If you find
# missing font, email to <gmail.com: jesse.jaara>
# Now with pkgfile support.
Server = http://huulivoide.pp.fi/Arch/arch-fonts

###
# unity DE
##

[unity]
Server = http://unity.xe-xe.org/$arch

[unity-extra]
Server = http://unity.xe-xe.org/extra/$arch

###
# added for vim/python support
###

[herecura-stable]
# additional apps not found in community
Server = http://repo.herecura.be/herecura-stable/$arch

Last edited by holland01 (2013-03-02 05:46:18)

Offline

#2 2013-03-02 04:46:10

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,073

Re: [SOLVED] Netflix Repo Key Issue

holland01 wrote:

This actually helped in a sense, because it prevented this:

That is not helping at all. You are simply hiding the error that pacman is reporting. The right way to fix it would be to investigate if the package is actually corrupt and take appropriate action.

You need to understand the key options of pacman. If you simply trustall any package that pacman reports as invalid, you are basically not using the security feature of pacman at all


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#3 2013-03-02 05:44:59

holland01
Member
Registered: 2011-12-22
Posts: 50

Re: [SOLVED] Netflix Repo Key Issue

Cool, thanks.

I believe I solved it by using systemctl to stop gnupg, removing the gnupg folder, disabling the link to the netflix repo, and then running pacman-key --init; pacman-key --populate archlinux; pacman -Syy.

Offline

Board footer

Powered by FluxBB