You are not logged in.

#1 2013-03-02 15:51:29

kkkggg
Member
Registered: 2013-03-02
Posts: 2

Running some java applications gives blank window.

I'm trying to use Violet UML or UMLet on my laptop but both give me a blank window (no buttons, just gray background).

My java version:

java version "1.7.0_15"
OpenJDK Runtime Environment (IcedTea7 2.3.7) (ArchLinux build 7.u13_2.3.7-2-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

They both run smoothly on my ScientificLinux box with java 6:

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.6) (rhel-1.54.1.11.6.el6_3-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

I checked java6 on the laptop as well but it didn't help.
All versions of eclipse are running smoothly on the laptop without any problems.
My system is up to date. My wm is dwm.

Did anybody have a similar issue?

Offline

#2 2013-03-03 16:23:02

marcelomorales
Member
Registered: 2013-03-03
Posts: 4

Re: Running some java applications gives blank window.

Have you tried to use the _JAVA_AWT_WM_NONREPARENTING=1 environment variable?

Using that environment worked for me with the xmonad wm.

There are known problems with java and alternative WMs. See, for instance, http://awesome.naquadah.org/wiki/Problems_with_Java

Offline

#3 2013-03-04 16:14:39

kkkggg
Member
Registered: 2013-03-02
Posts: 2

Re: Running some java applications gives blank window.

marcelomorales wrote:

_JAVA_AWT_WM_NONREPARENTING=1

This solved the issue, thank you very much!

Offline

#4 2020-05-11 00:09:41

bandithijo
Member
From: Indonesia
Registered: 2016-07-30
Posts: 6
Website

Re: Running some java applications gives blank window.

marcelomorales wrote:

Have you tried to use the _JAVA_AWT_WM_NONREPARENTING=1 environment variable?

Using that environment worked for me with the xmonad wm.

There are known problems with java and alternative WMs. See, for instance, http://awesome.naquadah.org/wiki/Problems_with_Java

Thank you! This solved my issue on DWM.


Technical Blog:Journal | BanditHijo.GitHub.io

Offline

#5 2020-05-11 00:32:41

fukawi2
Administrator
From: .vic.au
Registered: 2007-09-28
Posts: 6,048
Website

Re: Running some java applications gives blank window.

@bandithijo Please read our forum guidelines and leave the dead to rest in peace: https://wiki.archlinux.org/index.php/Co … bumping.22

Closing.

Offline

Board footer

Powered by FluxBB