You are not logged in.

#1 2013-03-07 19:05:34

Registered: 2013-03-07
Posts: 27

[SOLVED]VMware Installation -> Practice run.

hi, i am extremely new to doing everything by command line, but have used it for some time for things that needed to be done.

i've managed to install arch in vmware, but it does not boot and i have narrowed the problem down to while i was partitioning i selected the whole drive for ext4 and installed grub grub-bios, should i leave a /boot partition or should i be fine with a single partition.

some of the complaints made by the installer when mounting the virtual drive, where about squashfs not found, i partitioned with a ubuntu live disc so that it would be easier for me to make sure it was flagged for boot, but it gave the same error immediately.

i am doing the installation on vmware 8 and under a windows 7 x64 host.
installing the 32-bit platform as i plan to do over my fuduntu install once i am comfortable with arch and not taking a chance of ruining my partitions.

any tips or ideas are welcome, i have followed the installation wiki, but there are some gray areas that google helped me to continue from, ie. location and timezone.

all in all i would say the installation was pretty simple, just i am unaccustomed to it.

Last edited by fallen00sniper (2013-03-09 02:59:48)


#2 2013-03-08 01:14:39

Inspector Parrot
Registered: 2011-11-29
Posts: 19,094

Re: [SOLVED]VMware Installation -> Practice run.

I'd recommend having a boot partition - it has a handful of advantages which can be read about elsewhere - but to directly answer your question: either way should work.  Single partition installations are common and fully functional.  The boot failure must come from some other issue.

Were there error messaged during boot?  Did you get to the grub menu?  Had you run grub-config (or whatever that command is)?

"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman


#3 2013-03-08 02:08:01

Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,098

Re: [SOLVED]VMware Installation -> Practice run.

Without some more information as to what you actually did, people would be just taking stabs at answering you. Nothing comes out of it. Please let us know if you are getting errors or not. If so, what are they, when do they occur?

Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !


#4 2013-03-08 03:30:07

Registered: 2013-03-07
Posts: 27

Re: [SOLVED]VMware Installation -> Practice run.

i did not get to grub as far as i know, i did not run grub-config, the only thing it said was squashfs not found, i'm going to try again in a minute and i'll post what it says here.

i believe my mistake was in how i formated my virtual drive, cfdisk worked very well for this and i believe i am good to go now.

got it, thanks for pointing out the grub-config, i completely forgot it and i caused me to read the beginners guide instead of the installation guide, it was much more thorough in helping me, maybe now i can be more confident about not killing my gaming windows install.

i have gotten everything installed and working, wired network took the longest and i am currently installing enlightenment17, if that goes well then this has been by far easier than i expected to install arch, the beginners guide is very well written and helpful.

i think this could be the linux for me, it makes me work for it and is not loaded down with software i don't use.

i think i broke x installing enlightenment17.

Loading extension GLX and sits there.

ok i have gotten the errors

failed to load module, module does not exist


ran Xorg -configure and now just a blank screen with a -.

reboot and startx still stuck, maybe i wouldn't have this problem if not using vmware?

removed the xf86-video-vmware
installed xf86-video-vesa

x works, reinstalled the vmware driver and x fails, still cannot figure out how to load enlightenment or gnome.

just going to install it on my laptop and see what happens, i think i could be happier with arch than i have been with other distros in the past.

took some time, but i have arch running with enlightenment on my other laptop and i figured out (finally) to remove the testing xorg gui and everything seems to be fine, so now if i chose to, i would do this on my vmware install, marking this solved.

even though once the x server goes down it sits at the same thing Loading extensions GLX and does not allow console access.

Last edited by fallen00sniper (2013-03-09 03:02:50)


#5 2013-03-09 07:50:35

Registered: 2013-03-07
Posts: 27

Re: [SOLVED]VMware Installation -> Practice run.

had to add this in, it helped me a lot and so far i have a fully functional arch install and currently using gnome until i find out if the command is the same to auto start enlightenment if i choose to switch over to it as i planned to begin with.

this was very helpful with having used the beginners guide. … he-process


Board footer

Powered by FluxBB