You are not logged in.

#1 2013-03-21 13:24:22

El Buzz
Member
Registered: 2013-03-21
Posts: 2

[SOLVED]Issue with pacman -Syu and dependancies

When I try to update my system I am asked to replace some packages. Then I am asked to choose one of four providers.
I am not sure what I should do.
Below there is the output of some attempts

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace kdegames-libkdegames with extra/libkdegames? [Y/n] y
:: Replace khrplatform-devel with extra/mesa? [Y/n] y
:: Replace libegl with extra/mesa? [Y/n] y
:: Replace libgbm with extra/mesa? [Y/n] y
:: Replace libglapi with extra/mesa? [Y/n] y
:: Replace libgles with extra/mesa? [Y/n] y
:: Replace libreoffice-extension-pdfimport with extra/libreoffice-common? [Y/n] y
:: Replace openjdk6 with extra/jdk7-openjdk? [Y/n] y
:: Replace qt with extra/qt4? [Y/n] y
resolving dependencies...
:: There are 4 providers available for lib32-libgl:
:: Repository multilib
   1) lib32-catalyst-utils  2) lib32-mesa-libgl  3) lib32-nvidia-304xx-utils  4) lib32-nvidia-utils

Enter a number (default=1): 4
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-all: requires nvidia-utils=310.19

-------------------------------------------------------------------------------------------
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace kdegames-libkdegames with extra/libkdegames? [Y/n] n
:: Replace khrplatform-devel with extra/mesa? [Y/n] n
:: Replace libegl with extra/mesa? [Y/n] n
:: Replace libgbm with extra/mesa? [Y/n] n
:: Replace libglapi with extra/mesa? [Y/n] n
:: Replace libgles with extra/mesa? [Y/n] n
:: Replace libreoffice-extension-pdfimport with extra/libreoffice-common? [Y/n] n
:: Replace openjdk6 with extra/jdk7-openjdk? [Y/n] n
:: Replace qt with extra/qt4? [Y/n] n
resolving dependencies...
:: There are 4 providers available for lib32-libgl:
:: Repository multilib
   1) lib32-catalyst-utils  2) lib32-mesa-libgl  3) lib32-nvidia-304xx-utils  4) lib32-nvidia-utils

Enter a number (default=1): 4
looking for inter-conflicts...
:: qt4 and qt are in conflict. Remove qt? [y/N] y
:: mesa and libglapi are in conflict. Remove libglapi? [y/N] y
:: mesa and libgbm are in conflict. Remove libgbm? [y/N] y
:: mesa and libgles are in conflict. Remove libgles? [y/N] y
:: mesa and libegl are in conflict. Remove libegl? [y/N] y
:: mesa and khrplatform-devel are in conflict. Remove khrplatform-devel? [y/N] y
:: libkdegames and kdegames-libkdegames are in conflict. Remove kdegames-libkdegames? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-all: requires nvidia-utils=310.19

The problem seems to be with the nvidia drives I installed. My video card is a Geforce GT 430 and I have installed the drivers that I found on the nvidia website.
It was suggested the 310 version. Now on arch website it says the current version is 313 (if I remember correctly) and I guess that's where the problems start.

Bottom line is I cannot update the system. I tried using apper but it appears to be broken. Won't go past the first screen. Whatever I click, it causes an unknown error message to appear.

Anyway, I am not sure why/if I have to replace the packages and which provider to choose.
Any ideas?

Added code tags and marked solved -Inxsible

Last edited by Inxsible (2013-04-10 15:03:10)

Offline

#2 2013-03-21 14:04:30

Kilz
Member
Registered: 2008-03-01
Posts: 140

Re: [SOLVED]Issue with pacman -Syu and dependancies

The problem is you installed the 310 nvidia drivers, these require the nvidia-utils package version 310. But that version doesn't exist in the repositories because its already up to version 313. There is a way to do it but it will require a lot of work around's involving old packages manually. You will need the nvidia-utils 310 probably have to downgrade the xserver to xorg 1.13 and the linux kernel to 3.6. Then blacklist the packages in your pacman.conf so they are not upgraded.
Alternatiy you could just install the nvidia 313 drivers in the repositories and be done with it.


I trust Microsoft about as far as I can comfortably spit a dead rat.
Cinnamon is a wonderful desktop
"Faith is the substance of things hoped for, the evidence of things not seen."

Offline

#3 2013-03-21 14:51:33

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [SOLVED]Issue with pacman -Syu and dependancies

Please use [ code ] tags for posting snippets of code or program output
https://bbs.archlinux.org/help.php#bbcode

like this

Offline

#4 2013-03-22 03:50:11

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: [SOLVED]Issue with pacman -Syu and dependancies

You need to update your nvidia-all package to the latest version (currently 313.26).

Offline

#5 2013-04-10 12:33:00

El Buzz
Member
Registered: 2013-03-21
Posts: 2

Re: [SOLVED]Issue with pacman -Syu and dependancies

Solved
big thanks all

updated nvidia first then updated all the rest
and it all worked fine


@Karol sorry, will do next time

Offline

#6 2013-04-10 12:56:40

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [SOLVED]Issue with pacman -Syu and dependancies

Offline

Board footer

Powered by FluxBB