You are not logged in.

#1 2013-03-30 20:41:03

Known
Member
Registered: 2012-08-23
Posts: 63

[SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

Hi all
I have a problem with running Bumblebee for a laptop using NVIDIA OPTIMUS.
I've read this post but nothig changed.
I'm using Intel driver and Nouveau...

#optirun glxgears -info
[  186.336392] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[  186.336470] [ERROR]Aborting because fallback start is disabled.

What am I have to do?
Please help...

Last edited by Known (2013-07-27 21:07:29)

Offline

#2 2013-03-31 01:17:10

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

systemctl status bumblebeed.service 

cat  /proc/acpi/bbswitch
locate nvidia | grep ko
output?

Last edited by hadrons123 (2013-03-31 01:18:28)


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#3 2013-03-31 06:15:07

Known
Member
Registered: 2012-08-23
Posts: 63

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

hadrons123 wrote:
systemctl status bumblebeed.service 

cat  /proc/acpi/bbswitch
locate nvidia | grep ko
output?

Thank you for answering:

#systemctl status bumblebeed.service
bumblebeed.service - Bumblebee C Daemon
          Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
          Active: active (running) since یکشنبه 2013-03-31 10:25:34 IRDT; 5min ago
        Main PID: 363 (bumblebeed)
          CGroup: name=systemd:/system/bumblebeed.service
                  └─363 /usr/sbin/bumblebeed

#cat  /proc/acpi/bbswitch
0000:01:00.0 ON

#locate nvidia | grep ko
zsh: command not found: locate

And I've installed this:
Is it related to the error because it says: Failed to load module "mouse" (module does not exist, 0)

#pacman -S xf86-input-mouse

Offline

#4 2013-03-31 06:22:08

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

In In my system /etc/bumblebee/xorg.conf.nvidia  I had to change the Device option "ConnectedMonitor". You will have to switch from "FDP" to "CRT-0". try if it works.


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#5 2013-03-31 12:28:35

Known
Member
Registered: 2012-08-23
Posts: 63

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

hadrons123 wrote:

In In my system /etc/bumblebee/xorg.conf.nvidia  I had to change the Device option "ConnectedMonitor". You will have to switch from "FDP" to "CRT-0". try if it works.

Sorry! I don't get the point...
You mean I have to change "FDP" to "CRT-0" in /etc/bumblebee/xorg.conf.nvidia...
You mean this or some thing else...
Cause locate nvidia | grep ko in this post has an answer but for me it is nothing...

And another question:
Could you please show me a way to switch off NVIDIA GPU?
My laptop getting so hot while I'm working with it. (I've installed bbswitch but I don't know if it works)

Last edited by Known (2013-03-31 12:30:08)

Offline

#6 2013-03-31 13:30:27

cybertorture
Member
Registered: 2010-05-05
Posts: 338

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

cat /etc/modules-load.d/bbswitch.conf 
bbswitch
cat /etc/modprobe.d/bbswitch.conf 
options load_state=0 unload_state=1
cat /etc/modprobe.d/nvidia_blacklist.conf 
blacklist nvidia
blacklist nouveau

This is all you need to do. Cheers


O' rly ? Ya rly Oo

Offline

#7 2013-03-31 13:52:26

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

update the bbswitch to the latest version , becoz there is a recent acpi change in 3.8 kernel which prevents switching off the Nvidia.

Known wrote:
hadrons123 wrote:

In In my system /etc/bumblebee/xorg.conf.nvidia  I had to change the Device option "ConnectedMonitor". You will have to switch from "FDP" to "CRT-0". try if it works.

Sorry! I don't get the point...
You mean I have to change "FDP" to "CRT-0" in /etc/bumblebee/xorg.conf.nvidia...
You mean this or some thing else...
Cause locate nvidia | grep ko in this post has an answer but for me it is nothing...

You got it right and I didn't mean anything else.

Last edited by hadrons123 (2013-03-31 13:55:01)


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#8 2013-03-31 17:40:21

Known
Member
Registered: 2012-08-23
Posts: 63

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

Hey guys
I do this several times and skim through many posts in forum but I can't stop my nVidia card:

cybertorture wrote:
cat /etc/modules-load.d/bbswitch.conf 
bbswitch
cat /etc/modprobe.d/bbswitch.conf 
options load_state=0 unload_state=1
cat /etc/modprobe.d/nvidia_blacklist.conf 
blacklist nvidia
blacklist nouveau

This is all you need to do. Cheers

And the answer is:

cat: /etc/modules-load.d/bbswitch.conf: No such file or directory
cat: /etc/modprobe.d/bbswitch.conf: No such file or directory
cat: /etc/modprobe.d/nvidia_blacklist.conf: No such file or directory

Could you please help me more...
My laptop is getting hot while I'm working.

Last edited by Known (2013-04-02 11:23:51)

Offline

#9 2013-04-02 11:38:46

Known
Member
Registered: 2012-08-23
Posts: 63

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

Hi
Guys I find this:

/etc/modprobe.d/bbswitch.conf

options bbswitch load_state=0 unload_state=1

Is this switch off nVidia card while using laptop to save power?

Offline

#10 2013-04-02 14:54:14

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

cat /proc/acpi/bbswitch is the one which will tell you if the switch is off.

For more info
https://github.com/Bumblebee-Project/bbswitch


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#11 2013-04-02 16:11:40

Lekensteyn
Member
From: Netherlands
Registered: 2012-06-19
Posts: 192
Website

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

Known wrote:

Hi
Guys I find this:

/etc/modprobe.d/bbswitch.conf

options bbswitch load_state=0 unload_state=1

Is this switch off nVidia card while using laptop to save power?

See the readme linked above. Try `modinfo bbswitch` too.

Offline

#12 2013-04-03 20:51:55

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

Why don't you just do

tee /proc/acpi/bbswitch <<<OFF

?

Offline

#13 2013-04-05 08:34:37

Known
Member
Registered: 2012-08-23
Posts: 63

Re: [SOLVED] Can't Stop nVidia with Bumblebee - bbswitch - Nouveau

Svenstaro wrote:

Why don't you just do

tee /proc/acpi/bbswitch <<<OFF

?

It just turn off nVidia Card? Yeah?

I think it is better than nothing...

Offline

Board footer

Powered by FluxBB