You are not logged in.

#1 2013-04-05 02:19:56

Registered: 2013-01-29
Posts: 27

Netcfg multi-profile daemon fails to start


today after I've upgrade my arch install (there was a kernel upgrade 3.8.4 to 3.8.5), I lost all my internet connection (wifi and ethernet card). My notebook Works with na aetheros ethernet/wifi card and it used to work fine with the alx driver from aur. Since this upgrade for some reason netcfg daemon doesn't want to start. If I try to start de ethernet card manually it configures it but I can't ping anything in the net. Any attempt to start wireless ends up in getting the message "RTNETLINK answers: Operation not possible due to RF-kill".

I looked around, but all the solutions I found did not had any similarity with mine. I am thinking to recompile the alx driver, since it cold be that after upgrade dkms may not recompiled the module well (if this is a real possibilit)y. Any suggestions where to look for?

I already had changed all the card names from ethX to the new naming in arch, so I don't think is some configuration problem, since it was working before. Just to be on the secure side, I already checked if all conf files are there and with the correct names.

Journalctl, ip link do not give me any further info. Is netcfg loading order important?

Well hope somebody can point what and where to look for more info.


PS: After rebooting today the ethernet card unexpectedly started and the internet is now working. Yesterday short after upgrading and rebooting I had an strange symptom which was the presence of an additional network device which I could not identifiy. After a second boot this additional device disappeared but netcfg-daemon was not able to start and today everything is fine.
I really do not know what happened since, yesterday at night I only checked config files tried to restart a couple of times the network services via ip link via netcfg, but did not aimed at any specific correction to make netcfg-daemon start.

PS of PS: Wrong after I've made the kde upgrade network went down again with the same problem described above. So it seems that thereis something wrong either with the module for the aetheros hardware or with the kernel. As I said before, I haven't changed anything in configuration between succesfull connection events. I have copied several journalling information if some one is willing to help me on that. It's correct that the alx driver is from AUR and there should not be any garantees for those software but I am trying to gather more information.

Any takers

Saga continues:

Well I finally fiddle a little around and apparently got the network to function:

1. As mentioned before, after upgrading kde package this morning I and rebooting I lost the net connection. Eventually after sometime the net came up again in the afternoon. I checked and rechecked the system journalling, but the only different thing I found was the netcfg.daemon which did not came up.

2. After beeing on air again I found out that only my ethernet card was working the wireless was disabled. Every time I tried to bring the wirelss up the I got the message: "RTNETLINK answers: Operation not possible due to RF-kill". Looked around what is rfkill (radio frequency kill - or a way to control if your wifi radio signal is on or off). I needed to instal the rfkill package to list the condition of my wireless. I played with the ALT-F2 button and with the on/off button from my dell notebook. I was never able to unblock the wireless soft and hard at the same time with the ALT-F2 and Wifi button. So I tried the sudo rfkill unable all and the wireless was there. Ah, during this process I reinstalled the compat-drivers-patched, so I really don't know if it was the reinstallation of the compat package or the soft and hard unblocking or both corrected the wireless problem.

So it seemed that the kernel upgrade for some reason blocked the wireless and did something with the ethernet card which I could not identify.

Now I need to check if the net is stable after every boot event

Last edited by camarao (2013-04-06 02:03:32)


Board footer

Powered by FluxBB