You are not logged in.

#1 2013-04-05 14:35:39

Registered: 2009-02-23
Posts: 27

[Solved] Using serial port (can't start communication)

Hello everyone. I'm trying to connect to a switch through a built-in to motherboard serial port using minicom. I have arch running on vanilla kernel. `zgrep -i serial /proc/config.gz` tells me that CONFIG_SERIAL_8250=y, but `dmesg | grep tty` shows only tty0 active. I can't see anything serial port related with neither lspci, lshw, nor lsusb.

I do have /dev/ttyS[0-3] but if I try to cat any of them it gives me input/output error. `setserial /dev/ttyS0` says "/dev/ttyS0, UART: unknown, Port: 0x03f8, IRQ: 4".

Setting uart to 8250 with setserial did not help :-\
I also tried starting agetty@ttyS0.service, no luck either.

It seems like it *should* work out-of-box. But I can't communicate with the switch :-\

Can someone please help me get the serial port working?

-> Hardware serial port
-> Vanilla kernel
-> `dmesg | grep tty` shows only tty0
-> `setserial /dev/ttyS0` says "/dev/ttyS0, UART: unknown, Port: 0x03f8, IRQ: 4"
-> cat: /dev/ttyS0: Input/output error
-> Minicom stays dark.
-> Thanks for help!

Last edited by Hexorg (2013-04-05 15:12:43)


#2 2013-04-05 15:12:08

Registered: 2009-02-23
Posts: 27

Re: [Solved] Using serial port (can't start communication)

Nevermind... Someone had serial port disabled in BIOS...


#3 2013-04-05 15:12:38

From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,662

Re: [Solved] Using serial port (can't start communication)

It looks like your system is expecting the serial port to exist on the old ISA bus.  Most modern architectures use a LPC (Low Pin Count) bus to provide ISA bus services.  The kernel sets up the four legacy MSDOS COM: ports of 0x3f8, 0x2f8, 0x3e8 and 0x02e8 sharing iqq's 3 and 4 and maps them to /dev/ttyS[[0-3];  regardless of whether there is really hardware there.

The question is:  How is your serial port actually implemented?  Do you know for certain that it is implemented as an legacy ISA device ? (Even though the hardware layer may be on the LPC bus?).  If it is, is this a BIOS machine?  Are the ports enabled in BIOS, mapped to the addresses the Linux kernel expects?   

Any chance the serial ports are implemented on a USB or PCI bus interface instead?

Edit:  Too slow.... At least I was on the right path smile

Last edited by ewaller (2013-04-05 15:13:12)

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
How to Ask Questions the Smart Way


Board footer

Powered by FluxBB