You are not logged in.

#1 2013-04-05 15:44:08

lagagnon
Member
From: an Island in the Pacific...
Registered: 2009-12-10
Posts: 1,073
Website

NTPD: not syncing for minutes after resume?

I have a laptop which I often suspend and is mostly used to run digital amateur radio transmission software. This software must be exactly synced to correct UTC time. For that I always have ntpd loaded and running.

I note however, that after resuming from suspend it can be quite a few minutes before the time gets synced and accurate as it needs to be. Is there any way to force ntpd to run and update after a resume?


Philosophy is looking for a black cat in a dark room. Metaphysics is looking for a black cat in a dark room that isn't there. Religion is looking for a black cat in a dark room that isn't there and shouting "I found it!". Science is looking for a black cat in a dark room with a flashlight.

Offline

#2 2013-04-05 21:19:24

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: NTPD: not syncing for minutes after resume?

Looking at the man-page for ntpd, it has a "-U" option. Maybe that can be used in your ntpd.service file.
In case you connect with networkmanager, there is another way here: https://wiki.archlinux.org/index.php/Ne … t_OpenNTPD

Offline

Board footer

Powered by FluxBB