You are not logged in.

#1 2013-04-13 19:02:02

Registered: 2013-03-16
Posts: 11

[SOLVED] Unable to run autoconf on

When I run autoconf to generate a configure script, I get the following error: error: must install xorg-macros 1.4 or later before running autoconf/autogen                                                           the top level                                                  
autom4te: /usr/bin/m4 failed with exit status: 1

I have xorg-utils-macros 1.17 installed, and my xorg-macros.pc file lives in /usr/lib/pkgconfig/.

If I remove the requirement from (by commenting lines 20 and 21), autoconf runs for a bit before displaying this: error: possibly undefined macro: AM_INIT_AUTOMAKE
    If this token and others are legitimate, please use m4_pattern_allow
    See the Autoconf documentation error: possibly undefined macro: AM_MAINTAINER_MODE error: possibly undefined macro: AC_DISABLE_STATIC error: possibly undefined macro: AC_PROG_LIBTOOL error: possibly undefined macro: AM_CONDITIONAL

autoconf exits prematurely, leaving a broken configure script behind. Running this configure script results in:

configure: error: cannot find install-sh,, or shtool in . "."/.

I found one similar thread in a search, but it is unanswered:

Any ideas?

Last edited by willroberts (2013-04-13 19:39:01)


#2 2013-04-13 19:37:49

Registered: 2013-03-16
Posts: 11

Re: [SOLVED] Unable to run autoconf on


$ sudo pacman -S pkg-config xorg-server-devel libtool automake
$ libtoolize --force

Consider adding AC_CONFIG_MACRO_DIR([m4]) to
and re-run libtoolize --force.

$ vim
$ libtoolize --force
$ aclocal
$ autoheader
$ automake --force-missing --add-missing
$ autoconf

At this point, I have a functional ./configure script with no errors.

Last edited by willroberts (2013-04-13 19:40:39)


#3 2015-05-17 11:47:08

Registered: 2015-03-16
Posts: 6

Re: [SOLVED] Unable to run autoconf on

+1, also had to:

sudo pacman -S xtrans


#4 2015-05-17 11:50:22

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,510

Re: [SOLVED] Unable to run autoconf on

ajc0, please don't "necrobump" old topics, especially when they are marked as [SOLVED]. … bumping.22


Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


Board footer

Powered by FluxBB