You are not logged in.

#1 2013-04-14 09:56:12

yarmash
Member
Registered: 2012-03-21
Posts: 12

DHCP_TIMEOUT in /etc/conf.d/netcfg has no effect

I want to set DHCP_TIMEOUT to 30 for all netcfg profiles. On  this page in wiki it is suggested to set the variable in /etc/conf.d/netcfg. But this has no effect. I tried 'NETCFG_DEBUG="yes" netcfg <arguments>' and the timeout was still 10.

How can I set DHCP_TIMEOUT for all profiles without editing every profile?

Offline

#2 2013-04-14 15:08:55

stqn
Member
Registered: 2010-03-19
Posts: 1,189
Website

Re: DHCP_TIMEOUT in /etc/conf.d/netcfg has no effect

Not an answer but you might want to try with netctl since netcfg will be deprecated very soon.

Offline

#3 2013-04-14 15:43:13

opt1mus
Member
From: UK
Registered: 2011-12-31
Posts: 197
Website

Re: DHCP_TIMEOUT in /etc/conf.d/netcfg has no effect

Could you paste into this thread your /etc/conf.d/netcfg and the debug output. It's easier for people to help with troubleshooting when actual output is to hand.

Offline

#4 2013-04-14 16:16:45

yarmash
Member
Registered: 2012-03-21
Posts: 12

Re: DHCP_TIMEOUT in /etc/conf.d/netcfg has no effect

opt1mus wrote:

Could you paste into this thread your /etc/conf.d/netcfg and the debug output. It's easier for people to help with troubleshooting when actual output is to hand.

Here it is (network names changed):

# cat /etc/conf.d/netcfg

# Enable these netcfg profiles at boot time.
#   - prefix an entry with a '@' to background its startup
#   - set to 'last' to restore the profiles running at the last shutdown
#   - set to 'menu' to present a menu (requires the dialog package)
# Network profiles are found in /etc/network.d
NETWORKS=(network1 network2)

# Specify the name of your wired interface for net-auto-wired
WIRED_INTERFACE="eth0"

# Specify the name of your wireless interface for net-auto-wireless
WIRELESS_INTERFACE="wlan0"

# Array of profiles that may be started by net-auto-wireless.
# When not specified, all wireless profiles are considered.
#AUTO_PROFILES=("profile1" "profile2")
DHCP_TIMEOUT=30


# NETCFG_DEBUG="yes" netcfg network1
DEBUG: Loading profile network1
DEBUG: Configuring interface wlan0
:: network1 up                                                                                                                                                                          [ BUSY ] DEBUG: status reported to profile_up as:
DEBUG: Loading profile network1
DEBUG: Configuring interface wlan0
DEBUG: wireless_up start_wpa wlan0 /run/network/wpa.wlan0/wpa.conf nl80211,wext
Successfully initialized wpa_supplicant
DEBUG: wireless_up Configuration generated at /run/network/wpa.wlan0/wpa.conf
DEBUG: wireless_up wpa_reconfigure wlan0
DEBUG: wpa_cli -i wlan0 -p /run/wpa_supplicant reconfigure
DEBUG: wireless_up ifup
DEBUG: wireless_up wpa_check
DEBUG: Loading profile network1
DEBUG: Configuring interface wlan0
DEBUG: ethernet_up bring_interface up wlan0
DEBUG: ethernet_up dhcpcd -qL -t 10 wlan0
DEBUG:
> DHCP IP lease attempt failed.
DEBUG: Loading profile network1
DEBUG: Configuring interface wlan0
DEBUG: Loading profile network1
DEBUG: Configuring interface wlan0
DEBUG: ethernet_down bring_interface flush wlan0
DEBUG: wireless_down stop_wpa wlan0
DEBUG: wpa_cli -i wlan0 -p /run/wpa_supplicant terminate
DEBUG: profile_up connect failed

Offline

#5 2013-04-14 18:22:06

fs4000
Member
From: Germany
Registered: 2007-10-15
Posts: 20

Re: DHCP_TIMEOUT in /etc/conf.d/netcfg has no effect

yarmash wrote:

How can I set DHCP_TIMEOUT for all profiles without editing every profile?

Netcfg does not source /etc/conf.d/netcfg but you could put a file with your options in /usr/lib/network/hooks/ and make it executable.
For netctl the path will be /etc/netctl/hooks.

Offline

Board footer

Powered by FluxBB