You are not logged in.

#1 2013-04-17 05:56:28

From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

netctl static ip failed for check too quick

The conf file /etc/netctl/myip

DNS=('' '')
ExecUpPost='echo "search" >> /etc/resolv.conf'

Try by

netctl restart myip

Job for netctl@myip.service failed. See 'systemctl status netctl@myip.service' and 'journalctl -xn' for details.

Apr 17 13:59:15 t64 systemd[1]: Starting Networking for netctl profile myip...
-- Subject: Unit netctl@myip.service has begun with start-up
-- Defined-By: systemd
-- Support:
-- Unit netctl@myip.service has begun starting up.
Apr 17 13:59:16 t64 network[906]: Starting network profile 'myip'...
Apr 17 13:59:16 t64 network[906]: The interface of network profile 'myip' is already up
Apr 17 13:59:16 t64 systemd[1]: netctl@myip.service: main process exited, code=exited, status=1/FAILURE
Apr 17 13:59:16 t64 systemd[1]: Failed to start Networking for netctl profile myip.
-- Subject: Unit netctl@myip.service has failed
-- Defined-By: systemd
-- Support:
-- Documentation:
-- Unit netctl@myip.service has failed.
-- The result is failed.
Apr 17 13:59:16 t64 systemd[1]: Unit netctl@myip.service entered failed state

How to trace into the command line which systemd real execute?

BTW, this network environment have a network behavior.  The network transfer is not allow at first setup.  In my netcfg, sometimes, I required to type twice to get it work.  I guess this is a kind of protection of Deny of Service.

I just found out, I've 'wicd' enabled in systemd, So, I disable it and reboot.

It can not work after reboot.
But, I can manual type, and it works.

So, the rest problem is how to let it delay the netctl internal check after some seconds.

Last edited by dlin (2013-04-17 06:22:05)

Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,


#2 2013-04-17 08:48:22

From: Sweden
Registered: 2011-02-05
Posts: 759

Re: netctl static ip failed for check too quick

For at static ip this service file is what I use;

cat /etc/systemd/system/eth0-network.service
Description=Network Connectivity

ExecStart=/sbin/ip link set eth0 up ; /sbin/ip addr add dev eth0 ; /sbin/ip route add default via
ExecStop=/sbin/ip link set eth0 down


No networkmanager/wicd/netctl/netcfg. This service waits for the network card to be up. Just change your sys-devices-*xxx and ip's accordingly.

EDIT; it does need the package iproute2

Last edited by swanson (2013-04-17 08:51:26)


Board footer

Powered by FluxBB