You are not logged in.

#1 2013-04-25 12:39:09

Registered: 2011-12-10
Posts: 19

Intel/ATI hybrid graphics conflicting Xorg confs?

I am trying to use vgaswitcheroo to turn on and enable my ATI card on boot. When I first startup my laptop I get the following output from vgaswitcheroo:

root@odin:ciarlill# cat /sys/kernel/debug/vgaswitcheroo/switch 
0:DIS: :Pwr:0000:01:00.0
2:DIS-Audio: :Pwr:0000:01:00.1

So I switch to the DIS card (this is before any X session has started, right after login):

echo DIS > /sys/kernel/debug/vgaswitcheroo/switch

This turns off the backlight on my laptop (cannot get it back on) and activates the monitor on HDMI-1. Then why I try startx (ignoring the backlight issue for now) I get the following Xorg log:

When this happens I have 2 configs in xorg.conf.d: 20-radeon.conf and 20-intel.conf (shown below). If I move 20-intel.conf out of the directory and attempt to "startx" again, everything works and the backlight of my laptop is restored. The problem is, if I boot without the discrete card (say on battery) I need the intel config in order to 'startx'.

I am looking for any work around or possible solution to get these configs coexisting and being able to switch my cards at will.



Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"


Section "Device"
        Identifier  "Radeon"
        Driver  "radeon"
	Option	"SWcursor"              "off" #software cursor might be necessary on some rare occasions, hence set off by default
	Option	"EnablePageFlip"        "off"  #supported on all R/RV/RS4xx and older hardware and set off by default
	Option	"AccelMethod"           "EXA" #valid options are XAA and EXA. EXA is the newest acceleration method and its the default.
	Option	"RenderAccel"           "on"  #enabled by default on all radeon hardware
	Option	"ColorTiling"           "on"  #enabled by default on RV300 and later radeon cards.
	Option	"EXAVSync"              "off" #default is off, otherwise on
	Option	"EXAPixmaps"            "on"  #when on icreases 2D performance, but may also cause artifacts on some old cards
	Option	"AccelDFS"              "on"  #default is off, read the radeon manpage for more information


Board footer

Powered by FluxBB