You are not logged in.

#1 2013-04-30 14:36:55

alfa8my
Member
Registered: 2013-01-12
Posts: 4

[SOLVED] Connman does not accept my arguments

Hi

I followed the wiki and connman starts alright after reboot (it's a fresh install). i can enable my wifi, but when I type in the name of the network and the passphrase, connmanctl tells me the argument list is too long.

I use:

connmanctl connect wifi_dc85de828967_4de656986574572697a_managed_psk PASSPHRASE

and it gives:

Error 'connect': Argument list too long

What should I do? Thanks for any help.

Last edited by alfa8my (2013-05-15 13:14:47)

Offline

#2 2013-04-30 14:44:37

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Connman does not accept my arguments

Did you see this part about connmanctl?

connmanctl --help wrote:

Note: arguments and output are considered EXPERIMENTAL for now.

I started using connman by testing connman_dmenu (community contributions) and that actually created the necessary profile for me.  So I never had to actually enter a passphrase from the command line.  You could also install and temporarily use connman-ui-git from the AUR as well, and that would create a profile for oyu as well.  Of course, these methods assume you are running some form of X windows, and teh first assumes you have dmenu installed.

I have been using connman exclusively for a maybe a month now, and it is great.  It works really well, and is much faster than any of my other options at switching between different access points in my house.  The only problem is that is seems to pull my hostname from the router (I think), so if you experiement at all with anything that depends on a certain hostname, this could be a problem.

I discovered that issue because I was trying to implement socket activation for urxvtd and systemd --user.  So I went to set RXVT_SOCKET, and then in a fit of indecisiveness, I switched to netctl again.  At that point urxvtc didn't work for a moment.  My solution was to make my hostname consistent everywhere I could think of.

Offline

#3 2013-04-30 17:13:58

Thme
Member
From: Raleigh NC
Registered: 2012-01-22
Posts: 93

Re: [SOLVED] Connman does not accept my arguments

alfa8my wrote:

Hi

I followed the wiki and connman starts alright after reboot (it's a fresh install). i can enable my wifi, but when I type in the name of the network and the passphrase, connmanctl tells me the argument list is too long.

I use:

connmanctl connect wifi_dc85de828967_4de656986574572697a_managed_psk PASSPHRASE

and it gives:

Error 'connect': Argument list too long

What should I do? Thanks for any help.

Terribly sorry for any confusion my mistake in the wiki may have caused. I may have assumed at some point that

connmanctl connect wifi_dc85de828967_4de656986574572697a_managed_psk PASSPHRASE

was the correct way to connect to secure networks. It (apparently) worked on one where I was at the time but It may have been due to an already existing profile created by connman-ui-git (not sure If i had it at the time running as I was scripting). I later tested it just as you did on a new network a few hours ago and found my edits were wrong. will update the wiki(gonna remove the  the missinformation) when I find the right documentation covering how passphrases are entered... There's very little on how to use connmanctl for the console so I'm groping around in the dark...


"You are like people in a dark room waiting for someone to turn the light on for you instead of groping around in the dark and turning it on for yourself." -J. Krishnamurti at age 19, to his students-
www.jkrishnamurti.org

Offline

#4 2013-04-30 21:59:08

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Connman does not accept my arguments

There was a patch submitted in September to include a man page, but it doesn't seem to have actually been committed.

Offline

#5 2013-04-30 22:21:13

Thme
Member
From: Raleigh NC
Registered: 2012-01-22
Posts: 93

Re: [SOLVED] Connman does not accept my arguments

WonderWoofy wrote:

There was a patch submitted in September to include a man page, but it doesn't seem to have actually been committed.

I definitely found the man page but after reading over it there's no mention of how one would connect to secure networks. what I did find usefull was the API here git.kernel.org/cgit/network/connman/con … xt?id=HEAD. It has what I'm looking for but unfortunately I don't know c (I guess it's time to start learning).
Edit:I found this on how to talk to connman through dbus https://gist.github.com/tranthamp/2721326Time to play and update the wiki when I get it all sorted out. It seems currently that connmanctl doesn't handle secure networks if my judgment is correct. I couldn't find anywhere where a patch was submitted to this effect. It's still under much development.

Last edited by Thme (2013-04-30 23:47:33)


"You are like people in a dark room waiting for someone to turn the light on for you instead of groping around in the dark and turning it on for yourself." -J. Krishnamurti at age 19, to his students-
www.jkrishnamurti.org

Offline

#6 2013-05-02 11:22:00

alfa8my
Member
Registered: 2013-01-12
Posts: 4

Re: [SOLVED] Connman does not accept my arguments

Thanks to both of you for your help: I installed econnman because I use an Enlightenment desktop. It doesn't connect.

ip link

tells me that my wifi port is not associated.

I installed connman on another machine, and it works—but because, I suspect, it was installed last month, before netcfg got deprecated, and net-auto-wireless does its thing for connman.

Last edited by alfa8my (2013-05-02 12:02:43)

Offline

#7 2013-05-05 11:31:53

vkumar
Member
Registered: 2008-10-06
Posts: 166

Re: [SOLVED] Connman does not accept my arguments

I recently ran into the "argument list too long" issue while trying to specify my wpa passphrase to "connmanctl connect". I'm working around the issue by;

$ connmanctl enable wifi
$ connmanctl scan wifi
$ cat << EOF > /var/lib/connman/<SSID>-psk.config
[service_wifi_<hash>_managed_psk]
Type = wifi
Name = <SSID>
Passphrase = <passphrase>
EOF
$ connmanctl connect wifi_<hash>_managed_psk

I learned about this workaround by reading the source to connman_dmenu [1]. It's a nice program. It didn't work perfectly (providing my password resulted in a "Not registered" error), but all I had to do was "mv /var/lib/connman/<SSID>_1-psk.config /var/lib/connman/<SSID>-psk.config".

[1] https://github.com/taylorchu/connman_dmenu

edit: backstory

Last edited by vkumar (2013-05-05 11:35:00)


div curl F = 0

Offline

#8 2013-05-09 00:12:10

mhertz
Member
From: Denmark
Registered: 2010-06-19
Posts: 664

Re: [SOLVED] Connman does not accept my arguments

Thanks for the tip, mate!

Btw, the last command still reported argument list to long for me, even though I ran it like you suggested i.e. without a passphrase, but I found out that it wasen't needed, because after having started the connman service, enabled wifi with connman and having added the profile to the connman dir, then it would connect completelly automatically after some secs, and if not, then run: 'sudo systemctl restart connman'...

So, to others, after having installed connman, do this:

# systemctl start connman
# systemctl enable connman
$ connmanctl enable wifi
$ connmanctl scan wifi
$ connmanctl services #lists connection-points with their hashes...
# cat << EOF > /var/lib/connman/<SSID>-psk.config
[service_wifi_<hash>_managed_psk]
Type = wifi
Name = <SSID>
Passphrase = <passphrase>
EOF

Offline

#9 2013-05-15 13:19:10

alfa8my
Member
Registered: 2013-01-12
Posts: 4

Re: [SOLVED] Connman does not accept my arguments

Hi

Thanks to all for your help! my problem is solved, on the one hand thanks to this update from Connman, and on the other hand to my realisation that my home network was just a WEP one. I converted it into a WPA/PSK one and it worked right away! econnman can easily create profiles and log on to networks.

Thanks again.

Last edited by alfa8my (2013-05-16 04:18:50)

Offline

Board footer

Powered by FluxBB