You are not logged in.

#1 2013-05-05 19:37:29

Lockheed
Member
Registered: 2010-03-16
Posts: 1,451

Problem mounting windows share

I am trying to mount a windows share (my WDTV Live Hub) on my linux laptop. There is no password and in windows, I can access it without any problem, but when I try to do it on linux like that:

sudo mount -t cifs //WDTVLIVEHUB/WDTVLiveHub/Vidéo/SérieTV  /home/jj/Desktop/NS

I get this:

Password for root@//WDTVLIVEHUB/WDTVLiveHub/Vidéo/SérieTV: 

and as I have no password, I hit ENTER and get this:

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Am I doing something wrong?


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

#2 2013-05-05 19:44:40

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problem mounting windows share

It may be a passwordless share, but because you are required to run the mount command with "sudo" you are effectively trying to mount the share as the user root.  I think if you were the specify the user within an options array, that might make it so your were mounting it as an acceptable user.

Offline

#3 2013-05-05 20:05:42

Lockheed
Member
Registered: 2010-03-16
Posts: 1,451

Re: Problem mounting windows share

I tried putting "" instead of a username, and a fake username, but I keep getting the same error:

$ sudo mount -t cifs //WDTVLIVEHUB/WDTVLiveHub/Vidéo/SérieTV -o username="",password=""  /home/juha/Desktop/NS
[sudo] password for juha: 
username specified with no parameter
$ sudo mount -t cifs //WDTVLIVEHUB/WDTVLiveHub/Vidéo/SérieTV -o username=juha,password=""  /home/juha/Desktop/NS
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
$ sudo mount -t cifs //WDTVLIVEHUB/WDTVLiveHub/Vidéo/SérieTV -o username=juha,password=ness  /home/juha/Desktop/NS
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Last edited by Lockheed (2013-05-05 20:07:40)


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

#4 2013-05-05 20:09:19

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problem mounting windows share

Honestly, without knowing absolutely anything about how your share is configured (other than your mention that it is passwordless, your expectation of assistance is pretty ridiculous.

Until you can do more than simply say "I tried this mount command and it didn't work", you are going to have a hell of a time finding help.

Offline

#5 2013-05-05 20:12:34

Lockheed
Member
Registered: 2010-03-16
Posts: 1,451

Re: Problem mounting windows share

Well, all I know is that
1. these are default share settings of WD Live Hub.
2. There is no info anywhere about any other specifics.
3. Windows sees it in Network Neighbourhood and accesses it without issues or asking for password.


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

#6 2013-05-05 20:14:48

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problem mounting windows share

Okay, well can the system even see the share?

Offline

#7 2013-05-05 20:16:21

Lockheed
Member
Registered: 2010-03-16
Posts: 1,451

Re: Problem mounting windows share

You mean linux? Yes, without it I would not get a question about password.


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

Board footer

Powered by FluxBB