You are not logged in.

#1 2013-05-13 13:18:54

miky76
Member
From: Italy
Registered: 2011-10-27
Posts: 135

[SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

every 2 mins I get this message in the /var/log/user.log file

May 13 15:07:47 localhost NetworkManager[235]: <warn> error poking ModemManager: GDBus.Error:org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.ModemManager1.service'  for details.

I do not have any modem, so I'm not sure if this ModemManager should be on or not. how can I disable this message?

Last edited by miky76 (2013-11-07 08:36:27)

Offline

#2 2013-05-13 15:49:52

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,421

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

Did you perform the diagnostics recommended in the warning message you posted?  Will you please post the outputs of those commands?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#3 2013-05-13 15:53:41

miky76
Member
From: Italy
Registered: 2011-10-27
Posts: 135

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

here is the result of the command

[root@artemide ~]# systemctl status dbus-org.freedesktop.ModemManager1.service
dbus-org.freedesktop.ModemManager1.service
   Loaded: error (Reason: No such file or directory)
   Active: inactive (dead)

but I think normal that it's inactive, because I do not have any modem that have to be managed...
I think that this is a false message, and I do not have to activate anything more than I already have. but it is annoyng to see in the error log this error message every 2 mins.

do you agree?

Offline

#4 2013-05-13 15:59:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,421

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

I agree, but...   Do you have the ModemManger1.service enabled?  If so, disabling it might fix your problem.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#5 2013-05-13 16:24:48

miky76
Member
From: Italy
Registered: 2011-10-27
Posts: 135

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

no I do not have it:

[root@artemide ~]# systemctl disable dbus-org.freedesktop.ModemManager1.service
Failed to issue method call: No such file or directory

[root@artemide ~]# systemctl stop dbus-org.freedesktop.ModemManager1.service
Failed to issue method call: Unit dbus-org.freedesktop.ModemManager1.service not loaded.

[root@artemide ~]# systemctl stop ModemManager1
Failed to issue method call: Unit ModemManager1.service not loaded.

[root@artemide ~]# systemctl status ModemManager1
ModemManager1.service
   Loaded: error (Reason: No such file or directory)
   Active: inactive (dead)

Offline

#6 2013-05-14 20:14:33

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

Offline

#7 2013-05-24 16:00:42

miky76
Member
From: Italy
Registered: 2011-10-27
Posts: 135

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

Hi adee,
i take it as a workaround, as the fix say

"do systemctl start ModemManager.service and systemctl enable ModemManager.service"

and I actually do not like to activate a modem manager, if I do not have any modem that have to be manage, but just for stop tu full the logs

do you know when this will be fixed?

Offline

#8 2013-05-24 16:48:19

rasertux
Member
From: Florianópolis, Brazil
Registered: 2012-03-03
Posts: 40

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

I have this issue too and solved moving the /usr/share/dbus-1/system-services/org.freedesktop.ModemManager1.service to my backup folder...

Offline

#9 2013-05-28 18:58:19

Götz
Member
Registered: 2009-02-16
Posts: 23

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

rasertux wrote:

/usr/share/dbus-1/system-services/org.freedesktop.ModemManager1.service

I too got rid of that problem after removing that file. That file doesn't seem to be very useful, and it fills up the log (I don't have a modem).

/usr/share/dbus-1/system-services/org.freedesktop.ModemManager1.service wrote:

# This D-Bus service activation file is only for systemd support since
# an auto-activated ModemManager would be quite surprising for those people
# who have MM installed but turned off.  Thus the Exec path available to
# D-Bus is /bin/false, but systemd knows the real Exec path due to the MM
# systemd .service file.

[D-BUS Service]
Name=org.freedesktop.ModemManager1
Exec=/bin/false
User=root
SystemdService=dbus-org.freedesktop.ModemManager1.service

It seems this problem is only affecting Arch Linux, because googling the error message shows only Arch or Arch-based distributions results.
Maybe https://bugs.archlinux.org/task/34971 is a real bug. But, whose fault is that?


What I hear, I forget. What I say, I remember. What I do, I understand.  –Tao Te Ching/Laozi

Offline

#10 2013-05-29 17:17:33

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

I think removing the file in /usr/share/dbus-1/system-services will certainly do the trick.  But I went ahead and used ABS to build networkmanager w/o the "--with-modemmanager" in the ./configure section.  I also took modemmanager out of the depends array.  Then I put in a group array into the PKGBUILD, in which I added it to a group called "modified" so that I can ignore this group in pacman.conf.  In this way I don't automatically pull in new versions of networkmanager that will also pull in modemmanager, but I still get notified by pacman that it is skipping this update because it is in the IgnoreGroup section.  (Thanks for this idea jasonwryan).

Offline

#11 2013-11-07 08:35:23

miky76
Member
From: Italy
Registered: 2011-10-27
Posts: 135

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

Hi All,
renaming

/usr/share/dbus-1/system-services/org.freedesktop.ModemManager1.service

solved the problem

thanks

Offline

#12 2013-11-07 19:46:02

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

Whoa! I commend the fact that you actually came back here to report the success, even if it has been several months.  Good work milky76!

Offline

#13 2013-11-19 02:25:43

techlive
Member
Registered: 2009-05-02
Posts: 25

Re: [SOLVED]Error poking ModemManager: GDBus.Error:org.freedesktop.systemd

WonderWoofy wrote:

Then I put in a group array into the PKGBUILD, in which I added it to a group called "modified" so that I can ignore this group in pacman.conf.  In this way I don't automatically pull in new versions of networkmanager that will also pull in modemmanager, but I still get notified by pacman that it is skipping this update because it is in the IgnoreGroup section.  (Thanks for this idea jasonwryan).


Thanks, This trick is great,

Offline

Board footer

Powered by FluxBB