You are not logged in.

#1 2013-05-16 02:04:59

kevin_chn
Member
Registered: 2011-04-27
Posts: 15

[SOLVED]pacman says "requires gnome-panel-bonobo"

Hi, I never had such problem until a few days before:

#pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace gcalctool with extra/gnome-calculator? [Y/n] 
:: Replace pylint with extra/python2-pylint? [Y/n] 
resolving dependencies...
warning: dependency cycle detected:
warning: lib32-gcc-libs will be installed before its gcc-libs-multilib dependency
looking for inter-conflicts...
:: yaml-cpp and yaml-cpp0.3 are in conflict. Remove yaml-cpp0.3? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-netstatus: requires gnome-panel-bonobo>=2.32.0
:: libgail-gnome: requires gnome-panel-bonobo
:: python-gnomeapplet: requires gnome-panel-bonobo

Any help? Thanks in advance.

Last edited by kevin_chn (2013-05-16 11:54:49)

Offline

#2 2013-05-16 02:43:22

mcmillan
Member
Registered: 2006-04-06
Posts: 688

Re: [SOLVED]pacman says "requires gnome-panel-bonobo"

I'm not seeing any of those in my database or in the aur, did you install from an unofficial repository? If not, asking for a gnome 2.* dependency makes me think those probably are old packages that have been dropped.

Offline

#3 2013-05-16 02:45:46

karol
Archivist
Registered: 2009-05-06
Posts: 25,426

Re: [SOLVED]pacman says "requires gnome-panel-bonobo"

I've found these packages in ARM, but not in any unofficial repository, so maybe OP haven't updated his system in a while.


@kevin_chn
If you don't need these packages, try removing them.

Offline

#4 2013-05-16 03:01:26

kevin_chn
Member
Registered: 2011-04-27
Posts: 15

Re: [SOLVED]pacman says "requires gnome-panel-bonobo"

karol wrote:

I've found these packages in ARM, but not in any unofficial repository, so maybe OP haven't updated his system in a while.


@kevin_chn
If you don't need these packages, try removing them.

Solved after removing these packages. Thanks both. I am now downloading the huge 1.7G updates.

Offline

#5 2013-05-16 11:12:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,426

Re: [SOLVED]pacman says "requires gnome-panel-bonobo"

Please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309

Offline

Board footer

Powered by FluxBB