You are not logged in.

#1 2013-05-18 14:10:46

Registered: 2013-03-30
Posts: 25

netctl works with wireless-config, not with wireless-configsection

I'm trying to get wireless connection to start automatically.

Following the netctl wiki I first tried to get it working with wireless-config telling wpa_supplicant to use the config file I use when connecting manually. That worked fine, but I want more than one profile to load automatically and the wiki said I can't do that with Security=wpa-config I need Security=wpa-configsection Looking at the example in /etc/netctl/examples I copied and replaced those elements that I understood with the corresponding elements from my wpa_supplicant file.
I ended up with:


This doesn't work, and the only useful things systemctl status and journalctl tell me are WPA association/authentication failed ... and inconsistent self IDs respectively.

I've tried replacing password with key and the wpa_passphrase result and I've tried trial and error with the options I don't know or know how to find that were in the example.

I expect that I'm getting phase2, eap, and priority wrong when I put them in, as I have no idea how to find the correct values out, but I'd also guess that they're not necessary as wpa_supplicant works without them.

I don't think there's any useful data in journalctl -xn and systemctl status, but will put them up if people want to see it.



Board footer

Powered by FluxBB