You are not logged in.

#1 2013-07-27 20:09:39

antesilvam
Member
Registered: 2012-05-05
Posts: 4

Intel Wireless 7260 --> iwlwifi loaded but no interface present

Hi!

I am trying to bring my Intel Wireless 7260 chip to life, but i am struggeling. It seems that no interface is present:

root@wisper # iwconfig 
lo        no wireless extensions.

As far as I understood, this chip should be supported by the most recent kernel.

root@wisper # uname --all
Linux wisper 3.10.3-1-ARCH #1 SMP PREEMPT Fri Jul 26 11:26:59 CEST 2013 x86_64 GNU/Linux

Here some details concerning the chip and my system:

root@wisper # lspci -vnn
(...)
01:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 6b)
        Subsystem: Intel Corporation Dual Band Wireless-N 7260 [8086:c060]
        Flags: fast devsel, IRQ 255
        Memory at f7e00000 (64-bit, non-prefetchable) [disabled] [size=8K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [40] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 5c-51-4f-ff-ff-0e-6a-6e
        Capabilities: [14c] Latency Tolerance Reporting
        Capabilities: [154] Vendor Specific Information: ID=cafe Rev=1 Len=014 <?>
root@wisper # lsmod | grep iwlwifi                                                                                                                                                            :(
iwlwifi      136611  0 
cfg80211     406176  1 iwlwifi
root@wisper # modinfo iwlwifi
filename:       /lib/modules/3.10.3-1-ARCH/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko.gz
license:        GPL
author:         Copyright(c) 2003-2013 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-3160-6.ucode
firmware:       iwlwifi-7260-6.ucode
srcversion:     4A6BCE73445D84070B64761
(...)
depends:        cfg80211
intree:         Y
vermagic:       3.10.3-1-ARCH SMP preempt mod_unload modversions 
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: agg TX, 4: agg RX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           bt_ch_inhibition:Enable BT channel inhibition (default: enable) (bool)
parm:           plcp_check:Check plcp health (default: 1 [enabled]) (bool)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           auto_agg:enable agg w/o check traffic load (default: enable) (bool)
root@wisper # ls -l /usr/lib/firmware/iwlwifi-*
-rw-r--r-- 1 root root 335056  8. Jul 21:42 /usr/lib/firmware/iwlwifi-1000-3.ucode
-rw-r--r-- 1 root root 337520  8. Jul 21:42 /usr/lib/firmware/iwlwifi-1000-5.ucode
-rw-r--r-- 1 root root 337572  8. Jul 21:42 /usr/lib/firmware/iwlwifi-100-5.ucode
-rw-r--r-- 1 root root 689680  8. Jul 21:42 /usr/lib/firmware/iwlwifi-105-6.ucode
-rw-r--r-- 1 root root 701228  8. Jul 21:42 /usr/lib/firmware/iwlwifi-135-6.ucode
-rw-r--r-- 1 root root 695876  8. Jul 21:42 /usr/lib/firmware/iwlwifi-2000-6.ucode
-rw-r--r-- 1 root root 707392  8. Jul 21:42 /usr/lib/firmware/iwlwifi-2030-6.ucode
-rw-r--r-- 1 root root 670172  8. Jul 21:42 /usr/lib/firmware/iwlwifi-3160-7.ucode
-rw-r--r-- 1 root root 150100  8. Jul 21:42 /usr/lib/firmware/iwlwifi-3945-2.ucode
-rw-r--r-- 1 root root 187972  8. Jul 21:42 /usr/lib/firmware/iwlwifi-4965-2.ucode
-rw-r--r-- 1 root root 345008  8. Jul 21:42 /usr/lib/firmware/iwlwifi-5000-1.ucode
-rw-r--r-- 1 root root 353240  8. Jul 21:42 /usr/lib/firmware/iwlwifi-5000-2.ucode
-rw-r--r-- 1 root root 340696  8. Jul 21:42 /usr/lib/firmware/iwlwifi-5000-5.ucode
-rw-r--r-- 1 root root 337400  8. Jul 21:42 /usr/lib/firmware/iwlwifi-5150-2.ucode
-rw-r--r-- 1 root root 454608  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6000-4.ucode
-rw-r--r-- 1 root root 444128  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6000g2a-5.ucode
-rw-r--r-- 1 root root 677296  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6000g2a-6.ucode
-rw-r--r-- 1 root root 460236  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6000g2b-5.ucode
-rw-r--r-- 1 root root 679436  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6000g2b-6.ucode
-rw-r--r-- 1 root root 463692  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6050-4.ucode
-rw-r--r-- 1 root root 469780  8. Jul 21:42 /usr/lib/firmware/iwlwifi-6050-5.ucode
-rw-r--r-- 1 root root 682892  8. Jul 21:42 /usr/lib/firmware/iwlwifi-7260-7.ucode
root@wisper # dmesg | grep iwlwifi  
(no output)
1 root@wisper # dmesg | grep Intel                                                                                                                                                            :(
[    0.063101] smpboot: CPU0: Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz (fam: 06, model: 45, stepping: 01)
[    0.063115] Performance Events: no PEBS fmt2+, generic architected perfmon, Intel PMU driver.
[    1.079292] input: HDA Intel MID HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input6
[    1.079328] input: HDA Intel MID HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input7
[    1.079358] input: HDA Intel MID HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input8
[    1.097264] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input9
[    1.098141] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input10
[    1.135222] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.10
[    2.040221] Bluetooth: hci0: read Intel version: 370710018002030d16
[    2.040223] Bluetooth: hci0: Intel device is already patched. patch num: 16
[   91.112838] Intel(R) Wireless WiFi driver for Linux, in-tree:
[   91.112845] Copyright(c) 2003-2013 Intel Corporation

I would be very gratefull, if somebody could give me a hint, what I could try.

Best,
  Benedikt

Offline

#2 2013-07-28 00:13:50

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

I don't think this card is supported on Linux... yet.  It is a *very* new card, so I think there might be some preliminary work on it, but I don't think anything resembling finished work. 

You might want to have a look at this page.  At the bottom, there is a link to iwlwifi-next.  You might want to think about giving that a try since it is a link to the git tree for the future iwlwifi.

Offline

#3 2013-07-28 01:37:29

antesilvam
Member
Registered: 2012-05-05
Posts: 4

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

Hi!

Thanks for your reply! I know, that the card is very new, but 'modinfo iwlwifi' for instance shows already an entry 'firmware:       iwlwifi-7260-6.ucode' and in the folder /usr/lib/firmware/ there is also a file iwlwifi-7260-7.ucode. That's why I thought that there is a small chance to get it working already... ;-)

Here is the corresponding commit for linux-firmware:
http://git.kernel.org/cgit/linux/kernel … 009c18902a

Best,
  Benedikt

Offline

#4 2013-07-28 03:58:49

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

The firmware might be there (which is a great start BTW), but that doesn't necessarily mean that there is already full support within the iwlwifi module itself.  You have to remember that changes have to go through the process of being written and accepted into the kernel then go through the whole rc process before making it to our repos.

You might want to try the linux-git package from the AUR.  It is listed as an old version, but since it is a git package it will just update itself as necessary to the latest version.

Offline

#5 2013-07-28 13:31:39

Gusar
Member
Registered: 2009-08-25
Posts: 3,524

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

Patches to enable the 7000 family on kernel 3.10: http://www.spinics.net/lists/linux-wire … 09955.html

If you're not up to compiling your own kernel, you'll need to wait for 3.11

Offline

#6 2013-07-29 14:03:46

rlevArch
Member
Registered: 2011-12-04
Posts: 35

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

I was able to get it working by compiling the wireless-testing kernel following the instructions by ryanvade at http://communities.intel.com/thread/422 … 0&tstart=0 and from the arch wiki.

I'd never compiled my own kernel, and I'm pretty eager to get back to the standard kernel once it's fully supported, but for now I have the card working and things are running smoothly. I'm wishing I documented what I did a little better (I promised myself I would, but never got around to it) so I could share with you.

Good luck!

Offline

#7 2013-10-31 16:51:15

Raindancer
Member
Registered: 2005-03-29
Posts: 13

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

With kernel 3.11.6 is (partially) working. Some issue but the interface is there.

Offline

#8 2013-11-20 08:32:00

Tasqa
Member
Registered: 2012-04-27
Posts: 14

Re: Intel Wireless 7260 --> iwlwifi loaded but no interface present

I can confirm the card is working well with kernel 3.12 though there seem to be some issues with others. I have not tested this myself though. Here is the bugreport: https://bugzilla.kernel.org/show_bug.cgi?id=63091

Offline

Board footer

Powered by FluxBB