You are not logged in.

#1 2013-08-13 20:17:30

infixdun
Member
Registered: 2013-08-13
Posts: 1

Courier-MTA, mail Ports Still Closed After Courier Daemon Is Started

I followed the tutorial on the arch wiki to setup courier-mta (https://wiki.archlinux.org/index.php/Courier_MTA). All the configuration seemed to go fine, but when I tried to stat courier, I get an error:

courier.service - Courier Daemon
   Loaded: loaded (/usr/lib/systemd/system/courier.service; enabled)
   Active: active (running) since Tue 2013-08-13 16:13:19 EDT; 7s ago
  Process: 16179 ExecStop=/usr/sbin/courier stop (code=exited, status=0/SUCCESS)
  Process: 16181 ExecStart=/usr/sbin/courier start (code=exited, status=0/SUCCESS)
Main PID: 16186 (courierd)
   CGroup: name=systemd:/system/courier.service
           16186 /usr/lib/courier/courierd
           16187 /usr/lib/courier/courierd
           16188 ./courieruucp
           16189 ./courierlocal
           16190 ./courierfax
           16191 ./courieresmtp
           16192 ./courierdsn

Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Started ./courieruucp, pid=16188, maxdels=4, maxhost=4, maxrcpt=16
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Started ./courierlocal, pid=16189, maxdels=10, maxhost=4, maxrcpt=1
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Started ./courierfax, pid=16190, maxdels=1, maxhost=1, maxrcpt=1
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Started ./courieresmtp, pid=16191, maxdels=40, maxhost=4, maxrcpt=100
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Started ./courierdsn, pid=16192, maxdels=4, maxhost=1, maxrcpt=1
Aug 13 16:13:19 corstekistan-hiview systemd[1]: Started Courier Daemon.
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: queuelo=200, queuehi=400
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Purging /var/spool/courier/msgq
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Purging /var/spool/courier/msgs
Aug 13 16:13:19 corstekistan-hiview courierd[16187]: Waiting.  shutdown time=Tue Aug 13 17:13:19 2013, wakeup time=Tue Aug 13 17:13:19 2013, queuedelivering=0, inprogress=0

It says the daemon was started, but when I try to telnet port 25 and 143 (even on localhost), the connection is refused. What am I doing wrong?

Offline

#2 2013-08-27 10:01:05

kokizzu
Member
Registered: 2013-08-27
Posts: 15

Re: Courier-MTA, mail Ports Still Closed After Courier Daemon Is Started

i have exactly the same problem, i guess that sudo systemctl restart courier does not start imapd and esmtp automatically..

so try:
$ sudo esmtpd restart
$ sudo imapd restart

then:
$ netstat -ant | grep :25 ; netstat -ant | grep :143
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN     
tcp6       0      0 :::143                  :::*                    LISTEN

Offline

#3 2013-08-28 14:09:16

kokizzu
Member
Registered: 2013-08-27
Posts: 15

Re: Courier-MTA, mail Ports Still Closed After Courier Daemon Is Started

just now, i read this note XD

Please note that courier start runs the main Courier mail server scheduling engine only. It does not start any other daemons that you may have, such as the ESMTP or the IMAP daemon.

from: http://www.courier-mta.org/courier.html

Offline

Board footer

Powered by FluxBB