You are not logged in.

#1 2013-08-30 14:21:13

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 3

Wired network stopped working

Hi all,
Since recently, and without any changes to network related config files, wired connections do not work any longer. Wireless connections still do.
I'm somehow suspecting this is DHCP related.
dhcpcd is not running as as systemd.service but started by NetworkManager. Upon activating wireled connection through gnome network settings I'm seeing

# ps aux | grep dhcpcd
/usr/bin/dhcpcd -B -K -L -G -c /usr/lib/networkmanager/nm-dhcp-client.action eth0

# journalctl -f
NetworkManager[444]: <info> Activation (eth0) starting connection 'Wired'
NetworkManager[444]: <info> (eth0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[444]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[444]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) started...
NetworkManager[444]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[444]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[444]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
NetworkManager[444]: <info> (eth0): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[444]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
NetworkManager[444]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager[444]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[444]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
NetworkManager[444]: <info> (eth0): device state change: config -> ip-config (reason 'none') [50 70 0]
NetworkManager[444]: <info> Activation (eth0) Beginning DHCPv4 transaction (timeout in 45 seconds)
dhcpcd[2044]: version 6.0.5 starting
NetworkManager[444]: <info> dhcpcd started with pid 2044
NetworkManager[444]: <info> Activation (eth0) Beginning IP6 addrconf.
NetworkManager[444]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
dhcpcd[2044]: eth0: soliciting an IPv6 router
dhcpcd[2044]: eth0: ipv6rs_sendprobe: sendmsg: Cannot assign requested address
NetworkManager[444]: <info> (eth0): DHCPv4 state changed nbi -> preinit
dhcpcd[2044]: eth0: soliciting a DHCP lease
NetworkManager[444]: <info> (eth0): IP6 addrconf timed out or failed.
NetworkManager[444]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
NetworkManager[444]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
NetworkManager[444]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
dhcpcd[2044]: timed out
dhcpcd[2044]: exited
NetworkManager[444]: <info> (eth0): DHCPv4 client pid 2044 exited with status 1
NetworkManager[444]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
NetworkManager[444]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) started...
NetworkManager[444]: <info> (eth0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
NetworkManager[444]: <info> Marking connection 'Wired' invalid.
NetworkManager[444]: <warn> Activation (eth0) failed for connection 'Wired'
NetworkManager[444]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
NetworkManager[444]: <info> (eth0): device state change: failed -> disconnected (reason 'none') [120 30 0]
NetworkManager[444]: <info> (eth0): deactivating device (reason 'none') [0]

# systemctl
...
NetworkManager.service      loaded active running   Network Manager

# systemctl list-unit-files
...
dhcpcd.service      disabled

Is it anything obvious that I'm doing wrong here?

Last edited by walz (2013-09-02 10:00:56)

Offline

#2 2013-08-30 14:34:21

headkase
Member
From: Canada
Registered: 2011-12-06
Posts: 1,413
Website

Re: Wired network stopped working

What is probably the reason is that systemd renames the network adapters during the boot process.  Your name as given is "eth0" and I can say with certainty that is not what systemd will rename it to.

Execute:

ifconfig

To get the name of your network adapter after systemd has renamed it.

The reason systemd renames network adapters is because in the past eth0, eth1, and so on were not always guaranteed to be the same adapters on multiple boots.  With the new systemd naming a network adapter will always end up with the same name, even if you add or remove hardware from the machine.

Last edited by headkase (2013-08-30 14:34:59)


We all make choices, but in the end, our choices make us.

Offline

#3 2013-08-30 15:35:13

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Wired network stopped working

headkase, do you really think NM would log things like

NetworkManager[444]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.

without finding the device? That would be pretty misleading ..
More likely imo is a problem with dhcpcd, as walz suspects. S/he probably probably never had the symlink removed, so that the persistent naming of systemd is not enabled or still masked.

Things to try:
1. Put IPv6 to "local link only" in network manager
2. Stop NM and try to connect manually, using

# systemctl stop NetworkManager 
# ip link set up dev eth0 
# dhcpcd -A 

3. If that fails, install "dhclient" and try with that.

and welcome to the forums, walz! Please use [code ] tags for longer output next time, thanks.

(for my own rememberance: this is my Arabian nights post :-)

Offline

#4 2013-09-01 22:43:32

ajbibb
Member
Registered: 2012-02-12
Posts: 117

Re: Wired network stopped working

I think I may have had the same problem earlier this week, the symptoms certainly agree your first paragraph.  It happened to be an Arch install I have to a USB device which I normally use in one of three different computers.  I did a complete upgrade last weekend without changing any of the network configuration files.  After the upgrade wireless worked on all three computers, wired on only two of them.  On the third it seemed I could get a DHCP address, and I could ping the router where the address came from, but absolutely nothing else worked regarding network (internet, email, Samba, etc).

I was using the trick to force the old style eth0, eth1 device names with the following symlink

ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules

Just before that line in the Network Wiki there is also a line that says it is very important to have persistent names for motherboards with integrated NIC's.  Well, the problem computer has one of these (as did one of the computers that worked incidentally), but gave it a shot and removed the symlink and my wired network came right up and works fine.

Edit:  I should add that I am also using NetworkManager to manage all the network configuration, DHCP, etc.

Last edited by ajbibb (2013-09-01 22:46:30)

Offline

#5 2013-09-02 09:37:26

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 3

Re: Wired network stopped working

Thanks for the nice welcome and all the quick replies. I forgot to subscribe to the topic to answer sooner.

I can confirm that the network device is not renamed

# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
...
Strike0 wrote:

Things to try:
1. Put IPv6 to "local link only" in network manager
2. Stop NM and try to connect manually, using

# systemctl stop NetworkManager 
# ip link set up dev eth0 
# dhcpcd -A 

3. If that fails, install "dhclient" and try with that.

1. Setting IPv6 to "local link only" results in the following journalctl output when activating 'Wired'

NetworkManager[568]: <info> Activation (eth0) starting connection 'Wired'
NetworkManager[568]: <info> (eth0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[568]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager[568]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) started...
NetworkManager[568]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager[568]: <info> Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager[568]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) starting...
NetworkManager[568]: <info> (eth0): device state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[568]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) successful.
NetworkManager[568]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager[568]: <info> Activation (eth0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[568]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
NetworkManager[568]: <info> (eth0): device state change: config -> ip-config (reason 'none') [50 70 0]
NetworkManager[568]: <info> Activation (eth0) Beginning DHCPv4 transaction (timeout in 45 seconds)
NetworkManager[568]: <info> dhcpcd started with pid 5027
NetworkManager[568]: <info> Activation (eth0) Beginning IP6 addrconf.
dhcpcd[5027]: version 6.0.5 starting
NetworkManager[568]: <info> Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
NetworkManager[568]: <info> Activation (eth0) Stage 5 of 5 (IPv6 Commit) scheduled...
NetworkManager[568]: <info> Activation (eth0) Stage 5 of 5 (IPv6 Commit) started...
dhcpcd[5027]: eth0: soliciting an IPv6 router
dhcpcd[5027]: eth0: soliciting a DHCP lease
NetworkManager[568]: <info> (eth0): device state change: ip-config -> secondaries (reason 'none') [70 90 0]
NetworkManager[568]: <info> Activation (eth0) Stage 5 of 5 (IPv6 Commit) complete.
NetworkManager[568]: <info> (eth0): DHCPv4 state changed nbi -> preinit
NetworkManager[568]: <info> (eth0): device state change: secondaries -> activated (reason 'none') [90 100 0]
NetworkManager[568]: <info> Activation (eth0) successful, device activated.
dbus[596]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
dbus[596]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Unit dbus-org.freedesktop.nm-dispatcher.service failed to load: ...e' for details.
dbus-daemon[596]: dbus[596]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
dbus-daemon[596]: dbus[596]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Unit dbus-org.freedesktop.nm-dispatcher.service...' for details.
NetworkManager[568]: <warn> Dispatcher failed: (32) Unit dbus-org.freedesktop.nm-dispatcher.service failed to load: No such file or directory. See system logs and 'system...' for details.
dhcpcd[5027]: eth0: no IPv6 Routers available
gnome-session[1833]: [3601:3653:0902/105453:ERROR:download_updates_command.cc(187)] PostClientToServerMessage() failed during GetUpdates
dhcpcd[5027]: timed out
dhcpcd[5027]: exited
NetworkManager[568]: <info> (eth0): DHCPv4 client pid 5027 exited with status 1
NetworkManager[568]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
NetworkManager[568]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) started...
NetworkManager[568]: <info> Activation (eth0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
dbus-daemon[596]: dbus[596]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
dbus[596]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
dbus[596]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service failed to load: ...e' for details.
dbus-daemon[596]: dbus[596]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service...' for details.

2. NetworkManager immediately restarts, when being stopped. Thus, I disabled it and tried your steps.

# systemctl disable NetworkManager
# ip link set up dev eth0
# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether e8:03:9a:a6:0a:41 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether c4:85:08:0a:cc:b5 brd ff:ff:ff:ff:ff:ff
# dhcpcd -A
dhcpcd[5319]: version 6.0.5 starting
dhcpcd[5319]: wlan0: up_interface: Operation not possible due to RF-kill
dhcpcd[5319]: eth0: soliciting an IPv6 router
dhcpcd[5319]: eth0: soliciting a DHCP lease
dhcpcd[5319]: wlan0: waiting for carrier
dhcpcd[5319]: eth0: no IPv6 Routers available
dhcpcd[5319]: timed out
dhcpcd[5319]: forked to background, child pid 5366

I also tried explicitely turning off IPv6

# dhcpcd -4

which also ended in a time out.
As neither solution worked, I'm going to try dhclient this evening.

Offline

#6 2013-09-02 09:57:21

walz
Member
From: Germany
Registered: 2013-08-30
Posts: 3

Re: Wired network stopped working

ajbibb wrote:

I was using the trick to force the old style eth0, eth1 device names with the following symlink

ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules

Just before that line in the Network Wiki there is also a line that says it is very important to have persistent names for motherboards with integrated NIC's.  Well, the problem computer has one of these (as did one of the computers that worked incidentally), but gave it a shot and removed the symlink and my wired network came right up and works fine.

I have the original blank (just comments) file /etc/udev/rules.d/80-net-name-slot.rules
Actually I don't really get the Network wiki here. It says since systemd v197 ethernet devices should be named to en... unless the rules file is deleted or symlinked to /dev/null, but still my device is called eth0.

Last edited by walz (2013-09-02 10:02:49)

Offline

#7 2013-09-02 14:00:29

ajbibb
Member
Registered: 2012-02-12
Posts: 117

Re: Wired network stopped working

There is now a big note over my desk that says "Do not trust your memory!".  I'm sorry, I also rely way too much on scripts, and I thought I was creating the symlink in the script.  I was actually copying a blank 80 rules file to /etc/udev/rules to force the old eth0, eth1 naming.  I removed this blank file from /etc/udev/rules and then the wired network came up at the next boot.

Offline

Board footer

Powered by FluxBB