You are not logged in.

#1 2013-10-01 08:51:45

darnir
Member
Registered: 2011-12-21
Posts: 47

Problems with gvfs on latest update

I ran pacman -Syu last night and updated my system. During the install process, pacman spewed out a few errors like:

[2013-10-01 02:11] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-tga.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-01 02:11] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-xbm.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined symbol: g_type_class_adjust_private_offset
[2013-10-01 02:11] [ALPM-SCRIPTLET] g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jasper.so: /usr/lib/libgdk_pixbuf-2.0.so.0: undefined 

The complete log is posted here.

After this, GTK apps like Firefix, Chromium, etc. All refused to load giving errors like:

symbol lookup error: /usr/lib/libgvfscommon.so.0: undefined symbol: g_type_add_instance_private

So, I downgraded my gvfs package to 1.16.3-2 and now everything works fine again.

I wanted to know what went wrong here.

EDIT: I must mention have [testing] repo enabled.

Last edited by darnir (2013-10-01 08:56:20)

Offline

#2 2013-10-01 09:24:49

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Problems with gvfs on latest update

Moving to [testing] Repo Forum

Offline

#3 2013-10-03 14:29:06

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: Problems with gvfs on latest update

You have an outdated glib library somewhere on your system. Make sure you have the latest version of glib2 from testing, and in case you already have this version, start a hunt for leftover glib2 library files on your system.

Offline

#4 2013-11-19 14:58:50

ccpplinux
Member
Registered: 2011-05-06
Posts: 25

Re: Problems with gvfs on latest update

Hi darnir,
How did you downgraded gvfs package to 1.16.3-2? Can you please send me the corresponding command?

Best Regards ...
ccpplinux

Offline

#5 2013-11-19 16:18:37

darnir
Member
Registered: 2011-12-21
Posts: 47

Re: Problems with gvfs on latest update

Use pacman -U and point to the package in your package cache.

See https://wiki.archlinux.org/index.php/Do … g_Packages

Offline

#6 2014-02-04 04:43:34

ccpplinux
Member
Registered: 2011-05-06
Posts: 25

Re: Problems with gvfs on latest update

I was able to download the file gvfs-1.16.3-2-i686.pkg.tar.xz from the page https://wiki.archlinux.org/index.php/Ar … ck_Machine and clicking on the link  packages which lead to the URL http://seblu.net/a/arm/packages/.

Offline

Board footer

Powered by FluxBB